Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #16769

    Hello:

    The navigation of the portfolio at the frontpage in my website (www.botonhome.es) does not work.

    I know how to fix this: just by selecting something like “Show last post entries in the frontpage” at Word Press’ control panel, instead of actually selecting the real page that we want in the frontpage. However, the plugin WPML requires that we select the actual frontpage here because otherwise it won’t show the English version of the frontpage (my website is in Spanish and we are creating a English version of it with WPML).

    Is there any other solution to solve this? We really need to work this out.

    Thanks.

    #92790

    Hey enriquebp,

    I didn’t have any trouble at all when visiting the page and navigating around the various elements in the ajax porftolio. I also tried going to the next page from the home page (at the very bottom) and had no issues either.

    Regards,

    Devin

    #92791

    Really? Both me and my partner, and a few other people that I have asked cannot go to the next page from the home page :S You can click next page and it goes to this link http://botonhome.es/page/2/ but it shows the frontpage, not the following page.

    What could we do to fix this?

    Thanks!

    #92792

    Hi enriquebp,

    Try to use the default on your Settings > Permalinks and see if this fixes the issue? then try to return it back to your original permalink structure. This might sound weird but sometimes re-updating the permalink structure miraculously fixes the issue.

    Regards,

    Ismael

    #92793

    Hello:

    Thanks, but I did that and still didn’t work. Any other possible solutions?

    #92794

    Hi enriquebp,

    I am not sure what’s causing the issue, but try to disable the plugins. It might be caused by a plugin conflict.

    Regards,

    Ismael

    #92795

    Hi Ismael,

    I tried that but it didn’t work either. As I told you, if I don’t set up any page as the “frontpage” at WordPress Admin Panel (Setting > Read — or something like this, my panel is in Spanish), then the navigation works (and of course the frontpage is showed as usual) BUT then we cannot translate the frontpage using WPML (because it doesn’t recognize the frontpage because no frontpage has been set up “officially” in WordPress). Hence I guessed it is the template that has problems, not the plugin. Right?

    We really need to fix this as we need a bilingual website (Spanish-English) :(

    #92796

    Hey enriquebp,

    Angular isn’t WPML ready so it may not be an easy fix though I can’t say for sure. I’ll tag another of the support crew who has more experience with WPML and see what else can be done.

    Regards,

    Devin

    #92797

    Hi

    Thank you. I hope someone can help me.

    However, as I wrote before, WPML has nothing to do with this bug — when WPML is not active, the bug is still there.

    #92798

    Hey enriquebp,

    The issue is that in order to use WPML you must set the front page as a static front page which the theme is not designed to support. If all you want is the core functionality then as you said you just need to change the settings from a static front page. If that is the case, there isn’t any need to go further.

    Regards,

    Devin

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Navigation of the portfolio not working in the frontage’ is closed to new replies.