Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #26145

    Hi guys…

    I’ve tried many audio players and am now using one of the most popular… JWplayer. The biggest issue is… when I view a portfolio page regularly (no AJAX) it plays fine, like here…

    http://djdevelopment.net/3/portfolio-item/treasure-island/

    but when I view these pages with AJAX, the player won’t work like (click on the Treasure Island portfolio thumb here to view the same post using AJAX)…

    http://djdevelopment.net/3/start-to-finish-titles/

    What do I have to do to make these players work within these posts using AJAX?

    Thanks!!

    #129468

    Hi,

    the audio player doesn’t work because you need to “bind” the player javascript function to the new html elements. These elements were loaded with ajax and the player function will ignore them unless you bind your code to the new elements too. Open up replete/js/avia.js and search for

    function avia_ajax_call(container)
    {

    You need to add your player init function below this line – then save avia.js and the player should work.

    #129469

    Thanks dude. I’m not familiar with the “add your player init function”… can you be specific? Where and what it is? JW player has a ton of files…

    Thanks!

    #129470

    Hi!

    Tbh I’m also not familiar with JW player. I’d recommend to contact the plugin/player authors and ask them for help. If you ask them to provide the code “to initialize the player after an ajax call” they can probably help you.

    Best regards,

    Peter

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Need help playing audio in this theme…’ is closed to new replies.