Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #26785

    Hi there,

    I’ve uploaded a new product to my site and it’s not displaying correctly in the Shop page.

    Please see: (see the first product pic)

    All of these pictures in the Shop page was designed to be 1000*892 actually.

    I’ve downloaded another pic from one of the other products and noticed that the dimension is 450*401, but the new product pic is 450*450, causing it not displayed fully.

    Please let me know how can I rectify this problem.

    Thank you very much!



    Please help. Thanks guys!


    Hello…. anybody?


    Hi Jason,

    Our support queue goes by oldest posted topic to newest so each time you self bump or add a reply it actually pushes your topic to the end of our queue and doesn’t bring it to our attention.

    As for the issue, it looks like the previous products were uploaded with different thumbnail settings. It could have been changed somehow with a WooCommerce update or perhaps a theme update but what you can do is re-generate your images using this plugin so that all images have the same generated thumbnail dimensions:




    Thanks Devin.

    I’ve downloaded and regenerated that specific new product photo. However it is still weirdly sized.

    Please advice,

    Thank you!


    It isn’t that image that needs to be regenerated I believe but all the rest. Or you can change the settings for your catalog images in WooCommerce>Settings>Catalog at the bottom of the page.




    Hi Devin,

    please see here:

    That’s the original setting.

    OK, if i regenerate all images, is there a chance that my site goes bonkers?

    thank you ,



    You can always change settings and regenerate them again. Its a pretty non-destructive change and can be changed around.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘new product photo in Shop page is not sized correctly.’ is closed to new replies.