Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #195333

    Hi!
    I’ve installed qtranslate in my website, but flags of its widget in the sidebar doesn’t show up.

    Anybody knows why?
    I already tested it with another template and it works fine.

    Help would be appreciated.
    Thanks

    #195424

    Hi mikikepaulita!

    Your best route would be to check with the plugin author. The theme itself doesn’t have any specific support fro qtranslate and unfortunately we have very little experience with it.

    Cheers!
    Devin

    #195427

    What you mean when you talk about experience with it?
    Newscast has problems with qtranslate or qtranslate downs’t work very good by itself?

    Just to know, because I have to build a website with 4 languages and I already have built big part of it using qtranslate… :/

    #195491

    Hey!

    Please try adding following code to Header.php file in Appearance > Editor

    echo "<div style='position:relative; margin-left:200px; padding-top:15px;'>";
    echo qtrans_generateLanguageSelectCode('both');
    echo "</div>";

    and following code to bottom of Style.css file in Appearance > Editor

    .qtrans_language_chooser li { float: left; position: relative; display: inline; padding-right: 6px; padding-top:3px; }
    a.qtrans_flag:hover {background-position: -18px 0 ; }

    Regards,
    Yigit

    #195549

    Thanks Yigit,
    the flags now show up, (I inserted them under the “search” filed), but there are also the name of the languages and they are not clickable.

    May you help me with this too?

    Many thanks.

    #195555

    Hi!

    Can you post the link to your website so we can inspect elements on it?

    Regards,
    Yigit

    #195578

    I’m still working on it on my computer… if you tell what you need I can post here the code…is that possible?
    This is how set up the header.php:

    <div id='headwrap'>
    		<!-- ###################################################################### -->
    		<div id="head">
    		<!-- ###################################################################### -->
    		<br/><?php do_action('wp_menubar','top'); ?>
    			
                <h2 class="logo ie6fix <?php echo $logoclass; ?>"><a href="<?php echo get_settings('home'); ?>/"><?php echo $logo; ?></a></h2>
                
    			<?php echo "<div style='position:relative; margin-left:200px; padding-top:15px;'>";
    echo qtrans_generateLanguageSelectCode('both');
    echo "</div>";?>
    			
    			<div class="nav_wrapper">
    			<!-- Navigation for Pages starts here -->
    			
    			</div><!-- end nav_wrapper --> 
    			
    			
    			<div class="catnav_wrapper">
    			<!-- Navigation for Categories starts here -->
    			<?php 
    	
    			wp_nav_menu( array( 'menu' => 'Second', 'menu_class' => 'catnav', 'echo' => true,
    	'fallback_cb' => '', 'before' => '', 'after' => '', 'link_before' => '', 'link_after' => '',
    	'depth' => 0, 'context' => 'frontend',  'walker' => new description_walker() ));
    	
    				
    			/* pre wp 3
    			if(is_object($k_option['custom']['kriesi_menu_cats'])) 
    						$k_option['custom']['kriesi_menu_cats']->display('Menu Manager Categories','show_main_description'); 
    			*/
    			?>
    			<!-- end catnav_wrapper: -->
    			</div>

    Is that correct?

    thanks

    • This reply was modified 9 months, 2 weeks ago by  mikikepaulita.
    #195597

    Hey!

    Please add following code to

    <?php echo "<div style='position:relative; margin-left:200px; padding-top:15px;'>";
    echo qtrans_generateLanguageSelectCode('both');
    echo "</div>";?>

    right under

    <div id="head">

    and add following code to bottom of Style.css file as well

    #qtranslate-chooser span { display: none; }
    ul#qtranslate-chooser { float: right; margin-right: 200px; }

    Best regards,
    Yigit

    #195599

    Hi!
    Something changed: the name of languages disappeared (great!), but if I put the code right under the
    <div id="head">
    the flags disappear too.
    If I leave the code where I putted before they are there, and that’s fine…it’s the right place to me for that, but still they’re not clickable. :(

    thanks for your time.

    #195604

    Got it!
    I had deleted the First menu (Iuse a plugin that menu), so I have the
    <div class="nav_wrapper">
    empty.

    I tried to put the code of qtranslate there…et voilà. Now the flags are clickable!

    Thanks a lot for you help!

    #195605

    Hi!

    You are welcome! Glad we could help :) Let us know if you have any other questions or issues

    Cheers!
    Yigit

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Newscast and qtranslate’ is closed to new replies.