Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14687

    The main column content on my main page (www.apachemagazine.com) has multiple pages, but when I click on 1,2,3 or >> the pages go here:

    http://apachemagazine.com/?paged=2

    (replace the ID number accordingly)

    It only says “Sorry, no posts matched your criteria” even though there are post available.

    I’ve deactivated all plugins to see if that was the problem.

    Any help would be appreciated.

    #84503

    Hello,

    What version of newscast do you have? The latest version is newscast_2.0.3.

    Regards,

    Ismael

    #84504

    I have 2.0.3

    #84505

    Hello,

    There is no problem with the page going to http://apachemagazine.com/?paged=2 because it is suppose to go there. I reproduce the problem in my localhost and the pagination is still working, I used WordPress 3.4 and the newest version of Newscast.

    Did you change anything on the theme files or updated the permalink structure?

    Regards,

    Ismael

    #84506

    I haven’t changed the permalink structure or edited the theme file.

    I did an experiment.

    When I exclude more than 3 categories from the main page content, it will still give me the 1,2,3>> buttons, but it won’t go anywhere. I believe that there’s no content to show.

    My question then is, why are we showing 1,2,3 page buttons when there’s no content to fill those pages?

    #84507

    Hi nualln,

    I can’t reproduce the same problem. However, maybe you can try this steps.

    1. Go to Settings > Permalink and select other permalink structure save changes, set it back to your old permalink structure and save it again(if possible, try to do it twice. Just to refresh the permalinks).

    2. Go to Settings > Reading.

    Set Frontpage Displays to Your Latest Posts

    Blog pages show at most, set it to 5

    For each article in a feed, show, set it to Summary

    and Save changes.

    3. Try to check if the pagination works.

    If this doesn’t work, you might have some post filter in your code that might cause the issue. Hope this would help.

    Regards,

    Ismael

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Newsroom main page pagination not working’ is closed to new replies.