Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #850638

    A page has the Blog Posts element set to “Excerpt with read more link”. However, the entire post content (which is a long NinjaForms form for three posts) displays on that page. How do I get this to actually just have an excerpt (no form), and not the entire page content?

    #850778

    Hey m,

    I’m not sure I understand the problem, on the page you linked to I can’t see a form. Or are you referring to the page in private? Please try to explain a bit further.

    Best regards,
    Rikard

    #851032

    Thanks. No I’m referring to the first link I provided. If you scroll down you see four forms.

    #851541

    Hi m s,

    You need to show excerpt filed by checking it in screen options and filling it out for those posts. Then it should not show the post content, but show the excerpts instead.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #851599

    Thanks I tried that (changing the page Blog settings to show Excerpt and deselecting the Excerpts box in the post header screen options) for one of the posts, as noted below. But nothing changed.

    #851942

    Hi,

    You don’t need to change blog settings, the settings that work here are the ones made in the Advanced Layout Builder element. And you need to select to show excerpt and put text in there that you want to show. You did all the opposite.

    Best regards,
    Victoria

    #852072

    Can you please be more specific as I don’t follow.

    “You don’t need to change blog settings, the settings that work here are the ones made in the Advanced Layout Builder element.” –> The only blog settings I see are the ones in the Advanced Layout Builder element called Blog. What am I missing?

    “And you need to select to show excerpt and put text in there that you want to show.” –> Put text in where exactly?

    “You did all the opposite.” –> The opposite of what? The other problematic posts still have the ‘opposite’ setting because I didn’t change them.

    Thanks for helping me.

    #853533

    I’ve tried selecting and deselecting the “Excerpt” box in the post screen options area, but it makes no difference on the fact that the form shows on the page. Please help.

    #853535

    Please advise.

    • This reply was modified 2 days, 11 hours ago by  m s.
    #853538

    The solution is to not use the NinjaForms metabox, but rather to use the shortcode. Thanks, this can be closed.

    #853551

    Hi,

    Thank you very much for letting us know, we do appreciate it a lot.

    Best regards,
    Basilis

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.