Viewing 29 posts - 1 through 29 (of 29 total)
  • Author
    Posts
  • #176949

    Hi, I have a problem on a site under development.

    With a standard theme I can preview a change, if I activate Enfold preview no longer works, using a child theme I checked the same theme configuration (2.3.2) locally with mamp and there it works.

    So it seems that it is the development environment that causes the malfunction.

    Do you have any idea about what can block the preview?

    Note that the preview tab is refreshed but the change is not displayed.

    Regards.

    Jean

    • This topic was modified 9 months, 1 week ago by  Jean.
    #177331

    Hello Jean!

    Maybe the server caches data? This can happen if plugins like WP Super Caxhe or W3TC are installed.

    Best regards,
    Peter

    #177341

    Hi

    I have sort of the same problem. Using MAMP locally on my iMac. I can preview most of the site but not the LayerSliders. It just shows the loading icon but nothing more. Clean WP 3.6.1 installation (swedish) loaded with Enfold Demodata, no plugins except bbPress.

    Best regards,
    Jens

    #177370

    Hi, on the development website I have not yet activated Super Cache, at least I do not remember.
    I just testing locally with Mamp.
    No extension Super Cache: all is well.
    Installing Super Cache but not activation: all is well.
    Enabling Super Cache with basic options: all is well.
    Activation of recommended options and management with the htaccess file: Can not preview.
    Disabling cache: Can not preview.
    Supression extension : Can not preview.
    Supression of rules htacces file : Can not preview.
    Supression browser cache and cookie : Can not preview.
    Uninstall theme Enfold and child theme: all goes well (with Twenty Eleven ).
    Reinstalling Enfold + child theme : Can not preview.
    Total suppression and Reinstalling WP + Enfold and new Htaccess file: all is well.
    Previous database Injection: Can not preview.

    The problem seems to be localized in the database.

    I will review the database table by table to find the fault.

    Regards.

    Jean

    • This reply was modified 9 months, 1 week ago by  Jean.
    • This reply was modified 9 months, 1 week ago by  Jean.
    #177713

    Hi!

    Clear the cookies and cache in your browser. Close all browsers, reopen it and try logging back into your WP Admin. Change the permalink structure on Settings > Permalinks then save it. Do this a few times. In the Settings > General, make sure that the WordPress address (URL) and the Blog address (URL) match.

    Cheers!
    Ismael

    #178043

    Hi, I have done this several times, I checked on the site of the Super Cache extension uninstallation, everything is OK, but the preview does not work.
    If I change the database is the same.
    If I reinstall WP and Enfold the same database that does not work, if I take an empty database with Enfold it works.
    If I activate another theme (Twenty Eleven, Twenty Ten) preview works with the same database.
    There must be a temporary cache for Avia right? This is where it does not work correctly.

    Regards.

    Jean

    #178439

    Just dropping in here: I have the same issue. WP SuperCache is installed but not active.

    #179589

    Hi!

    I can’t reproduce the issue on my test servers. Maybe someone can create us an admin account and post the login credentials as private reply?

    Regards,
    Peter

    #179596
    This reply has been marked as private.
    #179597

    Done. Hope, blue border means “private” :D

    #179694

    Hi, thank you for the test, I disabled the cache Super cache, disabled extension, emptied the browser cache and cookies … no preview.

    Too bad you board not left a standard WP theme (Twenty Eleven for example) you will see that theme preview works in this case with your current content, but not with Enfold.

    Look this screen capture:
    No preview

    Regards.

    Jean

    #180185

    Hi Jean,

    you see the Test-account-credentials?? Hey Dude, the there is a real problem with your description that only admins can see private posts…!

    • This reply was modified 9 months ago by  mlkg.
    #180666

    Hi!

    I tried to login but the login credentials don’t work for me (“The username or password you entered is incorrect. Lost your password?”).

    Cheers!
    Peter

    #180751

    Of course, Peter, because the credentials can obviously be viewed by non admins (see above). So I deleted the access immediately. Can you give me a secure way to pass you new credentials?

    #181191

    Hey!

    @mlkg – no, only you and the moderators can read the private replies. Other users (logged in or logged out) can’t read your reply. If you want to test it log out and reload the page – you’ll notice that some replies disappear (=private replies).

    Cheers!
    Peter

    #181322

    Hey!

    It seems that the private replies plugin would also allow the topic creator to see the reply. I have disabled that since it doesn’t really make sense. thanks for pointing that out and sorry for any initial shock this may have caused :)

    Best regards,
    Kriesi

    #200812

    Did anyone find a fix for this? Like you guys Iv’e tried everything to get the preview to work.

    It works until i publish the page, then it can’t update the preview.

    I tried using other themes and they work beautifuly :) What’s up?

    #200823

    Yeap, me too, no preview after publishing… wrong situation. Not good… :-(

    Regards.

    Jean

    #201000

    Hi!

    Can you please create us an admin account and post the login data as private reply?

    Cheers!
    Peter

    #201016
    This reply has been marked as private.
    #201017
    This reply has been marked as private.
    #201436

    Hi!

    The login credentials don’t work for me. I always get an error “ERROR: Incorrect username or password. X attempts remaining.”.

    Best regards,
    Peter

    #201439
    This reply has been marked as private.
    #201939

    Hi!

    I just logged in and tried out creating a new page and then previewing it and had no issues. This was in Chrome on a Windows machine.

    Best regards,
    Devin

    #201951

    Hi!

    Well that doesn’t really change anything for me :)

    See, the problem is that I can also create a NEW page and create a successful preview – the problem occours after the page has been published (and that go’s for all pages).

    So if I make a change and hit “Preview” – no change is visible. If I make the change and hit “Update” – the change is visible.

    To help you see how it looks like on my end, I just made a video so you can se my problem (same problem across three different browsers).

    And like I wrote earlier – when I activate any other theme, the problem goes away.

    #202825

    Hey!

    I still can’t log in. Maybe try to change the password and use alphanumeric characters only. Maybe the “ or other chars have a different character code in the forum and thus the password is not accepted.

    Regards,
    Peter

    #203008
    This reply has been marked as private.
    #203540

    Hi!

    I can’t modify the files on your server but try to replace following line in /wp-content/themes/enfold/template-builder.php

    
    	 //filter the content for content builder elements
    	 $content = apply_filters('avia_builder_precompile', get_post_meta(get_the_ID(), '_aviaLayoutBuilderCleanData', true));
    

    with

    
    	 //filter the content for content builder elements
    	 $content = apply_filters('avia_builder_precompile', get_post_meta(get_the_ID(), '_aviaLayoutBuilderCleanData', true));
    	
    	 if(is_preview())
    	 {
            $content = apply_filters('avia_builder_precompile', get_the_content() );
    	 }
    

    Cheers!
    Peter

    #204625

    Hi Dude, thank you for this code, it works fine now. To be added in the next update.

    Happy New Year 2014! :)

    Regards.

    Jean

Viewing 29 posts - 1 through 29 (of 29 total)

The topic ‘No preview with Enfold in dev website’ is closed to new replies.