Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #222487

    Hi all,

    I found the following tread. http://www.kriesi.at/support/topic/no-swf-allowed-in-portfolio/ However, I still can’t display SWF on my portfolio page.

    I tried the following link and use the button “add external video by URL”.
    http://www.newmediasurfer.com/wp-content/themes/newmediasurfer/flashbannerads/TBWA/alli/300×453.swf?width=300&height=453” rel=”prettyPhoto[flash]”

    However, it only displays URL on my alli page at http://www.newmediasurfer.com/design/flash-banner-ads/.

    At your convenience, please let me know the solution. Thank you.

    • This topic was modified 6 months, 1 week ago by  designsart.
    #222564

    Hi again,

    Here is my second test on the test page at at http://www.newmediasurfer.com/design/flash-banner-ads/.

    I used the iframe method from the thread at http://www.kriesi.at/support/topic/getting-flash-swf-to-display-properly/. The alli banner ad displays but the size is too small. It should be 300px x 453px.

    Here is my code:
    <html><iframe src=”http://www.newmediasurfer.com/wp-content/themes/newmediasurfer/flashbannerads/TBWA/alli/300×453.swf?width=300&height=453″ rel=”prettyPhoto[flash]” width=”300″ height=”453″ frameborder=”0″ border=”0″ scroll=”no” marginheight=”0″ marginwidth=”0″ style=”border:0; overflow:hidden;”></iframe></html>
    1. Is there a way to modify the display size of the banner ad?
    2. Why doesn’t the banner ad display on the pop-up lightbox?

    Thank you.

    • This reply was modified 6 months, 1 week ago by  designsart.
    #222920

    Hey!

    The output may have changed in how it grabs the video url. I’ll tag Peter on the topic and see if he has any ideas but it may be something that you’ll need to have customized in the theme files to support swf files in the slideshows.

    Regards,
    Devin

    #223266

    Hey!

    1. Is there a way to modify the display size of the banner ad?
    You can try to reduce the number of columns. Set it to i.e. 2 and the iframe size will increase.

    2. Why doesn’t the banner ad display on the pop-up lightbox?
    The lightbox probably just supports a link element and you can’t bind it to the iframe itself. You can try to set a preview image and apply an external link to it: http://www.clipular.com/c/4946710178562048.png?k=CYBbrITUvBQTqSCiIJashzTs-lI – make sure that the url ends with swf otherwise the lightbox might not recognize it as a video.

    Cheers!
    Peter

    #223515

    Hi Dude,

    Thank you for your reply.

    1. I don’t mean to change the size of display thumbnail. I mean I want to display the actual banner size 300px x 453px at http://www.newmediasurfer.com/portfolio-item/alli/. The current size of the banner ad is smaller than 300px x 453px. The current maximum height is only 343px.

    2. I have tried the method but it doesn’t work. Here is the swf file at http://www.newmediasurfer.com/wp-content/themes/newmediasurfer/flashbannerads/TBWA/alli/300×453.swf. Please let me know if it works on your end.

    Thank you.

    #224818

    Hey!

    1) Try this css code and insert it into the quick css field:

    
    #top.postid-1270 .slideshow li iframe, #top.postid-1270 .slideshow {
    height: 453px !important;
    width: auto !important;
    }
    

    2) Yes, it seems like the lightbox iframe won’t work without the parameters and you must use: http://www.newmediasurfer.com/wp-content/themes/newmediasurfer/flashbannerads/TBWA/alli/300×453.swf?width=300&height=453&wmode=opaque

    However it does not recognize it as a swf video because of the different ending and you must change the selector in the lightbox source code. open up angular/js/avia.js and replace:

    
    	$.fn.avia_activate_lightbox = function(variables)
    	{
    		var defaults =
    		{
    			autolinkElements: 'a[rel^="prettyPhoto"], a[rel^="lightbox"], a[href$=jpg], a[href$=png], a[href$=gif], a[href$=jpeg], a[href$=".mov"] , a[href$=".swf"],  a[href$=".swf"], a[href*="vimeo.com"] , a[href*="youtube.com"] , a[href*="screenr.com"]'
    		};
    

    with

    
    	$.fn.avia_activate_lightbox = function(variables)
    	{
    		var defaults =
    		{
    			autolinkElements: 'a[rel^="prettyPhoto"], a[rel^="lightbox"], a[href$=jpg], a[href$=png], a[href$=gif], a[href$=jpeg], a[href$=".mov"] , a[href$=".swf"],  a[href*=".swf"], a[href*="vimeo.com"] , a[href*="youtube.com"] , a[href*="screenr.com"]'
    		};
    

    The difference ist the swf selector – a[href*=".swf"] will search for “.swf” anywhere in the url whereas the default a[href$=".swf"] selector just checks the last 4 characters (end of the url).

    Best regards,
    Peter

    #225056

    Hi Dude,

    Thank you for your detailed reply.

    1. After adding the CSS code, the alli Flash banner ad looks good in archive mode: http://www.newmediasurfer.com/portfolio-item/alli/
    I use the code below:
    <html><iframe name=”Lin flash video” src=”http://www.newmediasurfer.com/wp-content/themes/newmediasurfer/flashbannerads/TBWA/alli/300×453.swf?width=300&height=453&wmode=opaque” rel=”lightbox” scrolling=”no” frameborder=”no” height=”453″ width=”300″> </iframe> </html>

    However, when I click alli title at http://www.newmediasurfer.com/portfolio/flash-banner-ads/, the alli Flash banner is still smaller.

    2. I modified the code at angular/js/avia.js. I still don’t see alli swf show up in the lightbox even I added rel=”lightbox” after “…=453&wmode=opaque”.

    Thank you.

    Lin

    #225400

    Hi!

    1) Try to add this css code:

    
    #top .ajax_slide_1270 .slideshow li iframe, #top .ajax_slide_1270 .slideshow {
    height: 453px !important;
    width: auto !important;
    }
    

    2) Try to remove the “name” attribute from the iframe. It contains some weird quotes which may break the html source code.

    Regards,
    Peter

    #225620

    Hi Dude

    Thank you.

    I tried your CSS code. Both links look good now.
    Archive mode: http://www.newmediasurfer.com/portfolio-item/alli/
    and http://www.newmediasurfer.com/portfolio/flash-banner-ads/

    I have clean the quotes. Then I tried to keep or remove the name attribute from the iframe. The name attribute doesn’t affect the swf to display. Here is the final code I use.
    <html><iframe name=”Lin’s video” src=”http://www.newmediasurfer.com/wp-content/uploads/2011/03/300×453.swf?width=300&height=453&wmode=opaque” rel=”lightbox” scrolling=”no” frameborder=”no” height=”453″ width=”300″> </iframe> </html>

    Thank you, Dude!

    Lin

    • This reply was modified 6 months ago by  designsart.
    #225982

    Hey!

    No, you can’t use the iframe code but just set a preview image, set an external link to it and insert this url: http://www.newmediasurfer.com/wp-content/uploads/2011/03/300×453.swf?width=300&height=453&wmode=opaque into the url field. Afaik you can’t bind the lightbox effect to an iframe but just to link element. Screenshot: http://www.clipular.com/c/4946710178562048.png?k=CYBbrITUvBQTqSCiIJashzTs-lI

    Cheers!
    Peter

    #226409

    Hi Peter,

    I created another test file using your method. The title is test at http://www.newmediasurfer.com/portfolio/flash-banner-ads/
    and http://www.newmediasurfer.com/portfolio-item/test-3/.

    I inserted a 300px x 453px image and manually added the url in the url field:

    http://www.newmediasurfer.com/wp-content/uploads/2011/03/300×453.swf?width=300&height=453&wmode=opaque

    The CSS is:
    #top.postid-1432 .slideshow li iframe, #top.postid-1432 .slideshow {
    height: 453px !important;
    width: auto !important;
    }

    #top .ajax_slide_1432 .slideshow li iframe, #top .ajax_slide_1432 .slideshow {
    height: 453px !important;
    width: auto !important;
    }

    1. The problem is that when mouse hover the thumbnail image on http://www.newmediasurfer.com/portfolio/flash-banner-ads/, the thumbnail images are not even.
    2. When I clicked the title test, the width of main image is too big and exceed 300px. Therefore, I changed the CSS setting as follows, The main image displays normal as 300px x 453px.

    #top.postid-1432 .slideshow li iframe, #top.postid-1432 .slideshow {
    height: 453px !important;
    width: 300px !important;
    }

    #top .ajax_slide_1432 .slideshow li iframe, #top .ajax_slide_1432 .slideshow {
    height: 453px !important;
    width: 300px !important;
    }

    3. Another problem is when I clicked the main image 300px x 453px, the lightbox displays blank. No swf file displays inside of the lightbox.

    Lin

    • This reply was modified 6 months ago by  designsart.
    #227862

    Hi!

    1+2) I couldn’t see any thumbnail images but just animated swf files inside iframes. If the portfolio grid is not even the thumbnails provably have different sizes and thus some images are smaller than other images. If you want to avoid different images sizes upload the original images with a size of 465×346. You can also upload bigger images (i.e. 700×400) and WordPress will generate a smaller thumbnail version of the image. If the original image is smaller than the thumbnail size (i.e. 460×340) WordPress won’t generate a bigger thumbnail and then the final image sizes may vary.

    3) This can happen if the browser blocks the swf file or iframe content because of security reasons. I recommend to stick with the current solution in this case because this may happen to your visitors too when they try to view the swf file with the lightbox.

    Best regards,
    Peter

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.