Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #271954

    I just upgraded to Version 2.0 of the theme, and now events that were previously checked “Hide from Upcoming Events List” no longer show up in the calendar at all. The new “Sticky in Calendar View” doesn’t do anything at all.

    HELP! We need all events to show up in the calendar, but only specific events in the countdown timer.

    #272483

    Hey Jason!

    Are you using the built version of the events calendar or a pro upgrade from Tribe?

    Best regards,
    Devin

    #272526

    I’m using the built-in version in the Incarnation theme. Before upgrading, I was able to click the checkbox and stop an event from showing in the countdown, but it still showed up on the calendar. This is the desired results. But after the upgrade, the event was hidden from BOTH the countdown and the calendar

    #272528

    Ah gotcha. I’ll have to check in with Kriesi if this is a bug or part of the new integration with the events plugin. I don’t know the details of the change but only know everything was re-written from the ground up to work with the new plugins re-done code.

    Edit: In the short term if you can reply back with a private reply that includes admin login credentials so we and Kriesi can see the issue first hand that will help as well.

    • This reply was modified 6 months, 3 weeks ago by  Devin.
    #272544

    Thank you. This is urgent since the site is live right now and I don’t want to try to go back to a previous version.

    #273758

    Hi!

    Please create us an admin account and post the login credentials as private reply.

    Best regards,
    Peter

    #273976
    This reply has been marked as private.
    #274395
    This reply has been marked as private.
    #275342

    PLEASE, i need a response on this. If this can’t be resolved, I will need to pursue getting my money back for a template with features that no longer work. I’m sure it’s a simple solution… PLEASE RESPOND!

    #275513

    Hi!

    Please read my answer above – it’s not a theme issue but the event calendar plugin developers changed the code. If you switch to the default theme (TwentyThirteen) the option “Hide from Upcoming Events List” will still hide the event from the calendar page too. This is completely unrelated to the Incarnation theme code. We include the “Events Calendar” code unmodified and we do not provide fixes or customization to it – even if it works different to the previous version. If you can’t work with the new version please install the 2.0.x version here: http://wordpress.org/plugins/the-events-calendar/developers/ – please note that you might need to downgrade to WP3.8.

    If you want to get a refund you need to contact Envato – however I’m pretty sure they won’t issue a refund in this case because it’s not a problem with our code but (if it’s really a bug and not a feature) how the event calendar plugin code works at the moment. I have not heard back from Rob La Gatta yet – but I’ll post the answer/solution asap.

    Regards,
    Peter

    #275596

    Hey!

    Someone of the tri.be support team now tries to reproduce the issue – please hold on.

    Cheers!
    Peter

    #275869
    This reply has been marked as private.
    #276642

    Hey!

    It isn’t necessarily a “broken” function unless the developers look into it and find it is indeed broken. With the re-write of the code things may have changed in a way where what you were once able to do is no longer doable. With software that is updated regularly and as part of a larger ecosystem there will be features removed, features added and things will change unless you don’t update anything.

    If it does turn out that this is the intended function of the code your only choice (outside of having the included plugin code customized) would be to roll back to the old version of the theme but that also brings with it its own negatives.

    Regards,
    Devin

    #279753

    Devin:

    Thanks for the response. However, as a customer who purchased your template, I don’t make the distinction between the theme and the embedded plugins that you included with the theme. I didn’t purchase the calendar separately… it is built in to your theme that I purchased. I don’t even have the ability to disable the calendar in the Plug-Ins menu. Therefore, I consider it broken if I update the theme and a previously working internal feature no longer functions. I would think as the developer you would want to fix this instead of encouraging me to roll back to a previous, working version of the theme.

    At any rate, please let me know if there is an attempt to re-enable this feature of the Incarnation theme. Thank you.

    #279975

    Hey!

    As it stands right now the developers probably won’t change or “fix” this. I noticed the official changelog ( http://wordpress.org/plugins/the-events-calendar/changelog/ ) mentions this change as a fix: “Fixed an issue where the “Hide From Event Listings” checkbox was not hiding events from Month view” and obviously the previous behavior was not intended. I’ll ask Kriesi to add a theme_supports check to the functions.php file – then you can add this code to your child theme functions.php file:

    
    add_theme_support('avia_deactivate_event_calendar');
    

    to deactivate the events calendar plugin if you want to use another event plugin and you don’t need to hack the parent theme files. For now open up incarnation/functions.php and delete this code:

    
    //adds a modified version of the events calendar plugin
    require_once( 'config-events-calendar/config.php' );
    

    to deactivate it.

    Regards,
    Peter

    #284287

    I’m getting ready to upgrade to v2.0 and would like to know if it’s possible to pick and choose what files get updated, i.e. would it be possible for instance to update some elements to v 2.0 while leaving others not updated? Maybe this is a stupid question … I don’t know but after reading about this issue regarding the events calendar plugin problem, I am just wondering …

    #284573

    Hi!

    No, tbh this is not possible. Events Calendar 3 changed major parts of the template engine and the update required a lot of theme code changes. You can stick with the old Incarnation version and use Events Calendar 2.x with it or update to the latest version of the theme and use Events Calendar 3.x with it.

    Regards,
    Peter

    #287040

    Just to be clear, there is no way to separate “Events Calendar” from the theme… there is no Plug-In that I can deactivate… the calendar feature is wholly incorporated into the theme, which is why I came to you to tell you the “Hide from Upcoming Events List” feature that was working before I upgraded the theme is now missing. I was trying to report a bug and see if it could get fixed. Instead, the response is that it has nothing to do with the theme. From your customer’s perspective, it is a fully-integrated part of the theme.

    To be clear, before I go through all the effort to reinstall a previous version that works, there is no way with the current theme to get the “Hide from Upcoming Events List” checkbox back, i.e.: show an event on the calendar that doesn’t show up in the countdown?

    #287657

    Hey!

    Yes, the only easy solution is to use a category to exclude the events from the countdown. Replace

    
    $defaults 	= array( 'posts_per_page' => 2, 'eventDisplay'=>'upcoming' );
    

    with:

    
    $defaults 	= array( 'posts_per_page' => 2, 'eventDisplay'=>'upcoming',  'tax_query'=> array(array('taxonomy' => 'tribe_events_cat', 'field' => 'id', 'terms' => array( 77 ), 'operator' => 'NOT IN' )));
    

    in wp-content/themes/incarnation/config-events-calendar/config.php and insert the id of the category you use to mark the hidden events into the query (the sample code uses the id 77 but you need to replace it with your custom id).

    Cheers!
    Peter

    #287659

    Hey!

    Update – my mistake – the solution works. I updated the instructions here: http://www.kriesi.at/support/topic/not-able-to-hide-events-from-just-countdown-timer-after-upgrading-to-v-2-0/#post-287657

    Cheers!
    Peter

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.