Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3093

    I have installed the blog page and was working fine but now when I click on ‘page 2′ at the bottom of the blog it brings me back to the same page.

    Here is my blog: http://www.richmondweddings.com/blog/

    I tried uninstalling the plug-ins but no joy.

    FYI – the permalink structure is set to the WordPress default.

    Any thoughts you have would be appreciated.

    #40616

    Hey,

    Sorry to hear that the Paged function appears to be slightly broken.

    I notice that you have modified the theme colours, have you made modifications to the theme functions, or adjusted any PHP code anywhere?

    Have you set the front page to point to a specific page (in WP Admin > Settings > Reading) or have you changed index.php?

    James

    #40617

    Thanks for getting back to me, James.

    I have set the front page to a static page: Richmond Weddings blog.

    No changes to index.php

    footer.php – I added some custom information to the copywrite class

    header.php – I changed the navigation to replicate the main site

    sidebar.php – I added some custom information/images for the sidebar

    style.css – changed colors and some simple width settings

    I had tried to change the permalinks to a custom setting but it didn’t work so I change it back.

    Any thoughts?

    #40618

    Hey,

    I think setting the front page to a static page is what’s causing the problem – logically a static page wouldn’t have page 2 / 3 etc even though this is a blog template page.

    Personally, I’d change the setting back to “latest posts” i.e. use the theme template files according to the Template Hierarchy – if you look at this image you’ll see that home.php is called before index.php for the homepage: http://codex.wordpress.org/images/1/18/Template_Hierarchy.png

    Duplicate template_blog.php, rename it to home.php and remove this code from the top of the file:

    /*
    Template Name: Blog
    */

    The blog template should now load as the homepage. If you get any layout problems, open up header.php and change this:

    <?php $body_id = is_front_page() ? 'frontpage' : 'subpage'; ?>

    <body id="<?php echo $body_id; ?>">

    to this:

    <body id="subpage">

    as every page (excluding the index.php home template) uses this id for the CSS styling.

    Let me know how you get on.

    James

    #40619

    wow – thanks for all the detail.

    I will try it out and let you know how it goes…

    #40620

    James – brilliant work!

    Did not need to do last step – no layout problems.

    Thanks so very much!

    #40621

    Hey,

    Glad this worked for you, the last step was a failsafe as there was the possibility the layout could have been slightly off without this change.

    Let us know if you have any other questions.

    James

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘page 2 not working’ is closed to new replies.