Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #26942

    HELP!!!! I installed the ShareThis plugin and checked it on several pages and all the links are broken. I am getting the error 404-page not found…. see this link

    I disabled and deleted the plugin, cleared the cache, restarted and am still getting the 404 error. What do I do next? And how can I avoid this in the future? It is so frustrating.

    login to

    name: guest13

    pass: Guest13

    then go to home page.



    fyi… i do have a backup of the website and database created by EZPZ OCB plugin dated 7/30/13 if it comes to that. But I want to find out what happened and how to avoid it in the future.



    Did you change your permalink settings? Settings > Permalink.






    How can I tell if they have been changed?


    ok… i went back to the default setting for permlinks and it works fine. But when i reset the permalink for custom setting “post-name” or /%category%/%postname%/ it breaks again. WP support says that maybe I need to delete the .htaccess file from the server. Will that solve the problem of the custom setting? Will the server automatically create a new htaccess file?


    Just noticed that now that the permalinks are set to default the “events/calendar’ page link does not work…. probably because it is still set for the page title instead of the “default” page ID. Please advise.




    Hi Sam,

    You can refresh the permalinks by either deleting the htaccess file and then re-setting your permalink options or try getting wordpress to do it by re-saving the postname permalink setting 3-4 times and see if that helps.

    The codex has a number of other steps you can try when troubleshooting your permalink issues here




    What directory is the htaccess file in?



    You can find the .htaccess on the root directory of your wordpress installation right alongside wp-includes, wp-content and wp-admin folders.



Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘page links broken’ is closed to new replies.