Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #18719

    Hello,

    I’ve had a portfolio page on my website for a while, and now I’d like to make my portfolio the home page. I just went into my Theme settings and changed the frontpage option to be my existing Portfolio page. Now when I visit my site, it is indeed showing “Portfolio” as my home page, but none of my portfolio items are showing up. I’m guessing this has something do with the permalink…? When I go in to edit my Portfolio page, it says the permalink is still: http://www.jenniferjaco.com/portfolio, but I would think it should just say http://www.jenniferjaco.com/ if that is supposed to be my homepage… right? Please help! What do I need to change to get my old portfolio items to show up as the homepage?? Incidentally, if I type http://www.jenniferjaco.com/portfolio into the address bar, my portfolio does appear exactly as it should.

    So I know it’s there! I just can’t figure out how to point to it properly…

    Thank you!!!

    #100599

    Hey!

    Please try to set your portfolio page as static front page. Go to Settings > Reading and select the Portfolio page as static front page.

    Best regards,

    Peter

    #100600

    Thank you!! Worked like a charm.

    I have one other problem, but perhaps I should start a new thread…

    I’ve noticed for a while that my portfolio sorting function doesn’t always work… sometimes projects that I know are posted don’t show up when I click on their category. And then they may show up the next time I visit the site. It’s hit or miss.

    Also noticing now that my pagination buttons don’t work for my portfolio… when I click on the numbers at the bottom for pages 2 and 3, page 1 just reloads and I can never see page 2 or 3. Does this have anything to do with making the portfolio a static front page?

    Thanks again!

    Jennifer

    #100601

    Hey Jennifer,

    For the pagination issue, try going to your Settings>Permalinks and changing the option to default. Save and then test it again. If it works, then go back to your permalinks and try selecting the page name option again and then saving and testing.

    You may need to regenerate your .htaccess file as sometimes it can become corrupted (wordpress issue). See: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    For the Categories, keep in mind that the sorting only works for items that are visible on that specific page. It will not pull up items that are not shown when the page first loads or on page 2,3 etc.

    Regards,

    Devin

    #100602

    Hi Devin,

    Thanks for your reply. However, I’m still a bit confused. I tried changing the Permalinks setting to default and didn’t notice a difference, but I don’t see a “page name” option. There are several other options, but not “page name.” What would you suggest?

    Perhaps my only solution is to regenerate my .htaccess file, but this is a little over my head and I’m having a hard time getting through all of those directions. Will keep trying.

    As far as your comment about the categories… that is very surprising! I would think the sort function would sort all related items, regardless of which page a viewer is currently on.

    Thanks,

    Jennifer

    #100603

    Hey!

    Actually it’s a technical limitation. Isotope (filter script) just sorts/filters the items on the current page and it can’t load all items dynamically with ajax, etc.

    Best regards,

    Peter

    #100604

    I still think there should be an option to load ALL items and show/hide the quantity we want. This way, the sort/filter would work as a charm.

    If performance affects people with too many items, one can revert it back easily.

    #100605

    Hi,

    Yep, it is a good idea. Unfortunately, the sort function doesn’t have that yet and like Dude said is limited on the current page only.

    Regards,

    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Pages not directing properly anymore’ is closed to new replies.