Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #28486

    I’ve updated to latest wp and choices and everything. Page 2 link at bottom of blog page just goes to the homepage. http://bradroseconsulting.com/index.php/resources/

    My site has that ugly index.php structure in it but i cant seem to get rid of it through permalinks or anything. something to do with my host. can we edit the pagination code to take that into account?

    #137702

    Hi,

    Afaik the index.php structure indicates that you’re using a windows server. I strongly recommend to switch to a linux server because windows servers don’t play nice with wordpress and the permalink rewrite function. Did you try to use a different permalink structure (Settings > Permalinks)?

    #137703

    Hey Dude,

    Unfortunately, the site is hosted at Yahoo and I don’t have .htaccess access. I am forced to settle with ‘Almost’ Pretty Permalinks unless I go ahead and switch hosts. pain in the butt. Have any code modification ideas? I can get in there and log it for myself to edit after future Choices updates.

    #137704

    But if you don’t have access to the htaccess file WordPress can’t rewrite the htaccess file too? It’s not possible to use the “pretty permalink” settings without rewriting this file because the sever doesn’t redirect the url request properly (see http://randomtype.ca/blog/the-wordpress-htaccess-file-explained/ ). You must switch the host or stick with the default permalinks in this case.

    #137705

    this is the site/blog page in question: http://bradroseconsulting.com/index.php/resources

    I’ve accepted that the index.php structure is being used. But is there a way to alter the theme’s pagination linking so that instead of going to /page/2 it goes to /index.php/page/2 ?

    #137706

    Actually it goes to /index.php/page/2 and not to /page/2 but the problem is that wordpress doesn’t return the right page. It points to http://bradroseconsulting.com/index.php/page/2/ instead of http://bradroseconsulting.com/index.php/resources/page/2/ and I’m not sure why. Please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – I’ll check if the pagination issue is a theme specific issue or a general issue which also occurs with the default theme. If I can reproduce this with the default theme it has something to do with your host or server configuration.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Pagination not working. goes to home page’ is closed to new replies.