Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #23837

    On a website I’m setting up for a friend the pagination for the home page isn’t working. It shows up but if you click to go to page 2 it shows the information on page 1. The URL changes and says page 2 but the posts don’t change like they should.

    On the category pages the pagination seems to work just fine. Any thoughts?

    Also, I tried creating a new home page to see if that fixed the problem but it had the same issue as well.




    Try to the following one at a time.

    1.) Please try to flush your permalink settings. Go to Settings > Permalink, change the settings then change it back again. Do this a few times.

    2.) Delete a post then create it back again. If you are using a caching plugin, flush your cache settings after.

    3.) Edit template-blog.php then find this code

    $avia_config['new_query'] = array( "paged" => get_query_var( 'paged' ), "posts_per_page"=>get_option('posts_per_page') ) ;

    Replace it with

    $avia_config['new_query'] = array( "paged" => get_query_var( 'paged' ) ? get_query_var('paged') : 1, "posts_per_page"=>get_option('posts_per_page') ) ;

    Remove browser cache then reload the page.




    Hi there,

    Got exactly the same issue on the portfolio category pages with porfolio items… Pagination links keep sending me to first page, though URL is changing.

    I tried all of the above, and also to change the template-portfolio.php file the same way as you prescribed… but the issue remains the same.

    Can you please advise whether there is any other possible causes?





    You might want to visit this link Look further down on why “Paged Navigation Doesn’t Work” etc.




    I got it working, but I just switched from having a static homepage to have it show the recent posts.


    Hey tuttlephoto,

    Glad that fixed it for you. Typically you should use that if a theme offers a way to designate the home page with its own set of options to prevent any issues (though it doesn’t always cause them).



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Pagination not working properly’ is closed to new replies.