Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #11139

    I’m using Angular for a while and just notice that permalink seem to be broken. Doesn’t work from the wordpress admin as well. All the portfolio items content is displayed in the portfolio section.

    http://gridspace.ca

    Broken permalink http://gridspace.ca/portfolio-item/jean-paul-gaultier/

    Any ideas ?

    Regards,

    #70673

    Hi,

    Try to change the permalink structure back to default and save it. Check if the permalinks update and if it works. Then try to use this permalink custom structure: /%category%/%postname%/ . Then try to check if it works.

    Hope it helps. :)

    Best Regards,

    Ismael

    #70674

    Hi Ismael,

    I did several tests and it sounds that something’s wrong with the theme.

    I reset the structure to default and applied the structure /%category%/%postname%/ and my post still result of a page not found:

    http://gridspace.ca/portfolio-item/cn-star-trek/

    What I found weird is that adress work: http://gridspace.ca/portfolio-item/cn-star-trek/?portfolio=cn-star-trek

    Maybe it would be helpful if I give you access to my WP ?

    Drop me a line info:gridspace.ca

    Thanks in advance!

    #70675

    Hi Gridspace,

    If I understand correctly, the default permalinks work correctly but custom ones do not. If that is the case, it is not theme related. You can try to flush the settings by hitting the default setting and saving multiple times followed by selecting a new permalink structure you would like and saving once again.

    You can see the wordpress requirements and troubleshooting here: http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks

    If you’d like to double check that its server related and not theme related, change the them to the default wordpress theme and try changing your settings and testing again.

    Regards,

    Devin

    #70676

    I am having the same problem after upgrading the theme to latest version. Seems that something *in the theme* indeed breaks permalinks for pages – posts are not affected.

    #70677

    Ha! Looks like “Reset all options” and saving (I did it three times) and then changing permalink options bring the permalinks back! It’s quite strange, I’ve never seen this happen before…

    Even stranger is that if I edit any theme settings, the 404 problem with pages returns. So, this is not a fix.

    A kind of a fix is to:

    1. edit theme settings

    2. go to Settings > Permalinks and change settings a couple of times

    #70678

    Hey!

    Basically you just need to flush the permalinks. Go to Settings > Permalink hit the save button and reload this option page 1 or 2 times. Thiswill force WP to rewrite the htaccess file.

    Regards,

    Peter

    #70679

    @Dude

    I did what you said many times and it is still broken. Also noticed that problem occurred since I updated the them. Only default permalink structure work.

    Only Portfolio Items are affected by this problem. Blog posts work perfectly.

    Could you please do your best efforts solving this major issue ?

    Regards

    #70680

    Hi Gridspace,

    In your theme options, go to the Portfolio tab. Where it says “Enter a page slug that should be used for your portfolio single items” make sure the text you put there does not conflict with any other slug name on the site. So if you have it as portfolio but you also have a page named portfolio, it will not work.

    Regards,

    Devin

    #70681

    Thanks for your time Devin but, unfortunately, I tried everything mentioned yet and I’m still stuck with page not found post.

    I experience this problem since I updated the them on the second week following launch.

    I’m stuck and this a major bug.

    Thanks for your help!

    #70682

    Do you have a link to your site where its having the issue? Is it happening with default permalinks set as well?

    It could be any number of issues thats causing it and it could be unrelated to the theme as well so the more we know specifically about your site and the issue that is happening the more likely we are to find a fix.

    #70683

    @Devin Please read the previous posts

    my Website http://www.gridspace.ca

    Only the portfolio section is affected by this issue (work section)

    The wordpress blog work perfectly

    I’m pretty sure it is related to the them.

    Thanks for your help!

    Christian

    #70684

    Can you try going into the theme options> Portfolio and changing the page slug for the portfolio from “portfolio-item” to something else and then saving?

    Could also try updating the theme to the most recent 1.2 release as it has some backend/framework updates that might help.

    #70685

    Hi Devin, I updated the them and run many test to try to figured out what’s going on and it is not fixed yet. This issue is poisoning my business. Could you please send me a quote for technical assistance at info at gridspace dot ca ? Regards

    #70686

    Can you create a temporary admin account for me.

    You can send the information to my email at DevinVinson (at) gmail.com. Make sure to include a link to this topic so that my spam filter doesn’t grab it :)

    Regards,

    Devin

    #70687

    This looks like you are running on a webserver plataform that doesn’t have .htaccess support, like ngnix. If you do, you will have to convert your .htaccess file into a configuration file used by ngnix.

    Ngnix is much faster than apache, but it has its issues.

    Edit:

    I use this site to convert. Its beta, but works well

    http://www.anilcetin.com/convert-apache-htaccess-to-nginx/

    #70688

    @rckmnx my server support .htaccess The permalinks only fail for the portfolio section, they work perfectly for the standard WP blog

    #70689

    Too bad i thought it would help. Good luck ;)

    #70690

    thanks :)

    #70691

    Hi Gridspace,

    Can you try disabling the plugins you have installed. Then refreshing your permalink settings again (change them, save, change back then save).

    Regards,

    Devin

    #70692

    hmm it is mysterious. I desactivated and re-activated the plugins and the problem is resolved! Thank you very much for your help!!

    cheers!

    #70693

    Great! Glad that fixed the issue. Sometimes it just takes a little bit of refreshing :)

    Regards,

    Devin

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Permalink = Page Not found’ is closed to new replies.