Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #3251

    Hi Dude and Jason and other Admins,

    I know there has been several threads in the past few weeks/months on this. I’ve checked all of them and tried differen things. I really do believe now that this might be a bug in code of portfolio.php but I am not a coder nor do I have experience. I’d love some help. Here’s what I have so far. This is in sequential format:

    +I renamed the “portfolio” category/page into “cases”

    +everything seemed ok until i changed the permalink structure under “settings” to /%category%/%postname%/ –>before I did this of course, the title of the re-named page was cases, but the url said “portfolio”

    +After the permalink structure change, I received “404 not found” errors only under the portfolio “item” links and nowhere else. the top level url had changed into mysite.com/cases for the “portfolio” section and that part worked correctly. Like I said though the “items” under the “portfolio” section gave me the 404 error.

    Note:so this means that http://mysite/cases/information-technology/ works. The problem is that when i click on any link under that post it doesnt work. but i also noticed that the url was very different and that it did not follow my permalink structure. Here’s an example of what the 404 url looked like http://mysite.com/category/portfolio/information-technology/.

    i.e. “category/portfolio” replaced “cases/” in the url

    this is a programming bug probably in the portfolio.php file.

    I tried:

    +reloading permalink structure to several things, the only one which allows everything to work accurately is the defaul choice on the setting page.

    +i checked htaccess and rewrote it based on the recommendations of on of the threads here

    +i changed the portfolio file in the “portfolio” category section based on another thread from here and nothing happened. I changed it back

    + I also removed the word category from the portfolio.php (which no one had mentioned) from this code

    $slugRule = get_option(‘category_base’);

    if($slugRule == “”) $slugRule = ‘category';

    and it got rid of the word “category” from the url, but i changed it back. I want the naming to be based on /%category%/%postname%/ it doesnt serve me to remove random words from a fixed url

    Please help. This is a very annoying problem and it has NOTHING to do with the server, the host or the user. This is a code error or flawed design. I’d love for my permalink structure to work.

    I’d be ready to provide an Admin user name for your to investigate. Until I get a reply I will set the permalink structure to the suggested default.

    Thanks,

    Joe

    #41367

    We will release a theme update this week which should adress the permalink error :)

    #41368

    you are an awesome individual Dude! :)

    #41369

    Hi, i’ve got this problem with my site http://www.chillybin.com.sg, any idea of when an update will be published?

    #41370

    Hey,

    Kriesi is working on theme updates, I can’t tell you when they will be available though. There needs to be extensive testing before we can issue an update as any problems that arise from the update need to be squashed before release.

    James

    #41371

    What files are being replaced? I don’t want to have to style out my entire site again….

    #41372

    I take it version 1.2 did not address the permalink Portfolio issue.

    #41373

    Have you tried to reset your permalinks? Go to Settings > Peralinks and click on the “Save” button.

    #41374

    @Dude~

    Yes, I updated the Permalink structure and cleared cache and it didn’t fix the issue.

    Z

    #41375
    #41376

    Thanks for helping us out – here’s Kriesi’s post:

    Hey everyone, Seems I forgot to mention two files to update:

    kclass_advanced_css_style.php located in framework/classes/ and

    portfolio.php in theme_options

    #41377

    Where is the link and directions to fix this? I am so disappointed at the customer support for this theme.

    I went to the facebook link and what did they do for me?

    Where do I find this and then what am I suppose to do?

    Hey everyone, Seems I forgot to mention two files to update:

    kclass_advanced_css_style.php located in framework/classes/ and

    portfolio.php in theme_options

    #41378

    The files are updated – Kriesi just forgot TO MENTION them in VERSION.RTF. Download the update and extract portfolio.php located in the folder theme_options. The replace the “old” portfolio.php (also located in theme_options folder) on your server with the new one…

    #41379

    Where?

    I still have no idea where to download this file or updated version. Did you update it on

    Themeforest so I can just download a working copy of this theme?

    I need a link to the files.

    How am I suppose to know what or where this is?

    “Kriesi just forgot TO MENTION them in VERSION.RTF”

    Where do I find the “folder theme options?

    Help a person out here please geez.

    #41380

    You can download the update @themeforest.net – download the zip archive and extract it You’ll get another archive (avisio.zip) and a Version.rtf file (text file – open it with notepad or editor). This file tells you which theme files were updated. Kriesi forgot to mention the portfolio.php file and the kclass_advanced_css_style.php located in framework/classes/ . Extract avisio.zip and you’ll see a folder called “theme_options with contains a file portfolio.php and folder “framework” which contains a folder “classes”. There you can find kclass_advanced_css_style.php

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Permalinks bug for only the Portfolio section-Again!!’ is closed to new replies.