Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #13159

    When I go to a single product page, it’s automatically jumping to the product description and redirects the page url to #tab description. It skips the short description at the top of the page. I saw someone else had this problem and tried the quick CSS code given but it didn’t work.

    .dual-sidebar .related.products .content {

    margin-left: 0;


    I also disabled all plugins but it’s still jumping down the page. Please help! Here is the url (please remove after looking thanks)



    Please go to your header.php and look for this code.

    <!-- custom.css file: use this file to add your own styles and overwrite the theme defaults -->
    <link rel="stylesheet" href="<?php echo get_bloginfo('template_url'); ?>/css/custom.css" type="text/css" media="screen"/>
    <!--[if lt IE 8]>
    <style type='text/css'> .one_fourth { width:21.5%;} div{zoom:1;}</style>

    Place this script above

    <script type="text/javascript">
    setTimeout(function() {
    if(location.hash) {
    window.scrollTo(0, 0);
    }, 1);

    I hope it works.




    No, unfortunately that didn’t work. Still skipping. Any other suggestions?




    I found a solution that works for me for now. Instead of using the woocommerce tabs, I just made my own tabs from the tabs button included with this theme and put them in the short description area of the product page. I only used the short description area for my content and didn’t use the other description box at all. I then deactivated the reviews. Now it doesn’t jump down the page to reviews or the descriptions tab since neither exist.

    It will load the page correctly now, however, if I scroll down the page and hit my refresh button, it loads the page wherever I left it. If I scrolled down to the related products for example, it will refresh the page in that same spot, not the top of the page which I thought was strange. Maybe something to do with cookies? No idea, but at least it’s somewhat working now.

    Now if I can just get a vertical dropdown menu to work with this theme, I’ll be over the moon.



    Glad you found a solution for this.

    This might help other users with the same problem.



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Please Help! Product Pages skipping content’ is closed to new replies.