Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #383


    First off, great theme!

    In terms of the menu, once First and Second menus are set up, can it be be possible to disable them in the header? I’m considering only having the menu in the sidebar, and can set it up using a widget. I don’t want to use the Pages widget because my HOME page does not show up there.

    On that piece, when I set up wordpress, I followed the instructions from many guides on having 2 HOME pages, and then hiding one of them (in say ABOUT). The problem with that is when I set up the menu, there is quite a bit of even space between HOME and the next page, whereas everything else is even. (Ex. HOME……….BLOG…PAGE2…PAGE3…PAGE4) Would you know how to fix that?


    Edit: I was able to set up a menu on the sidebar, by creating a new HOME page. Then it would show up on the PAGES widget.

    However, the second issue still exists. Even if I create a custom link for HOME, there still shows that space from HOME to the next item in the menu. How can I make the spacing even for each of the items in the menu?




    Assuming you’re using the latest version of the theme and using WordPress 3.0, you can use the custom menus (Appearance -> Menus) to specify exactly which links you want, what order and what text.

    Best regards,




    Thank you for your response. I have tried setting up custom menus, but have been having a couple of issues…

    1. When I use custom menus, the spacing between HOME and the next link is not the same as the space between the other links? Is that something built in? I’ve tried typing each link in, and it is the same. That goes for the links in the bigger menu (second menu) immediately above the slider. The menu with the smaller text (first), right below the logo, shows up fine. Is there a way to fix that?

    2. Another option for me would be not to have the menu show up top, but just in one of the sidebars. How can I make it so that the menus do not show up at all in the header, but can still show up on the sidebar? I’ve tried adding several other menus (ex. test, third, fourth, etc) with no items. hoping that nothing shows up in the header (but can still select the menu for the sidebar), but the menu still shows up in the header. How can I fix that?

    I’d use the PAGES widget, but because I am considering taking away the static home page and just making the blog page home, I can’t seem to get HOME to show up on the PAGES widget.

    Thanks so much!



    1.) What’s the URL? Need to see it 1st hand to work out the spacing bug.

    2.) There is a custom menu widget built just for this. You’ll find it under Appearance -> Widgets in WP Admin.





    I think I’m really leaning towards just removing the menus in the header. What would I have to remove there?

    I am using the custom menu widget on the sidebar, and that works fine for me. It’s just that in order to use the sidebar widget, I have to activate one of the header menus. I just want to use the sidebar widget by itself.

    Can you please let me know what I need to remove?



    You can remove the menu by removing this code from header.php:

    wp_nav_menu( array( 'menu' => 'First', 'menu_class' => 'nav', 'echo' => true,
    'fallback_cb' => '', 'before' => '', 'after' => '', 'link_before' => '', 'link_after' => '',
    'depth' => 0, 'context' => 'frontend'));

    /* pre wp 3
    $k_option['custom']['kriesi_menu_pages']->display('Menu Manager Pages','show_basic');

    If you’d like help getting the layout of the menu fixed (if there is an issue) let me know.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Please help with menu!’ is closed to new replies.