Viewing 30 posts - 1 through 30 (of 36 total)
  • Author
    Posts
  • #15693

    When i click to an item on the 4 column gallery, the image get bigger than the it should.

    The actual size of the image is 320×320.

    How can i change the code so it will stay 320×320 when is opened?

    At the moment with the resize it lose it s resolution.

    Thank you in advance

    #88611

    Hi,

    When you click and lightbox show up? Or on the ajax view?

    Regards,

    Ismael

    #88612

    On the ajax view

    #88613

    Hi,

    Please open functions.php and find this code.

    $avia_config['imgSize']['logo'] = array('width'=>446, 'height'=>218 ,'copy'=>'greyscale'); // images for dynamic logo/partner element

    Create a new one below for our ajax images. Name it portfolio-ajax for example.

    $avia_config['imgSize']['portfolio-ajax'] = array('width'=>320, 'height'=>320 ,'copy'=>'greyscale'); // new portfolio ajax image

    Open functions-choices.php and find this code

    $slider -> setImageSize('fullsize');

    Replace it with our new thumbnail size.

    $slider -> setImageSize('portfolio-ajax');

    You need to regenerate the thumbnails or upload them again.

    Regards,

    Ismael

    #88614

    How i refenerate the thumbnails?

    #88615

    i did what u wrote..changed the code…..i uploaded again the picture but stil it shows the picture bigger…

    You can have a look ….i have uploaded another picture for the 3rd item

    ACQUATONDO 22

    http://www.rhodes-apartments.biz/tasos/%CE%BA%CE%B1%CE%BB%CE%BF%CF%81%CE%B9%CF%86%CE%B5%CF%81/montelakalorifer/

    #88616

    Hi,

    This is the regenerate thumbnails plugin. http://wordpress.org/extend/plugins/regenerate-thumbnails/

    Could you please disable the 5 slider plugins you are currently using, and please check the settings because right now you have 250×250 as the thumbnail, 495×400 as your large image. Have you edited the media queries? because in tablet size the image is huge while at higher screen sizes it is tiny.

    You should look in functions.php to make sure the sizes are set how you want them and deactivate all extra plugins until this is solved and then add the plugins until you find the one causing this problem.

    Thanks,

    Nick

    #88617

    Dear Nick

    Thank you for your reply…i have deleted the slider plugins..(found 4)

    I cannot find the 495×400 large image at the Editor so i can change it.(it s not at the functions.php)

    Is this what i have to change so the images at the ajax view will not be resized to a bigger version?

    #88618

    http://www.rhodes-apartments.biz/tasos/KALORIFER%20FIREPLACE/elegant/#!prettyPhoto

    check this…This is bigger than the normal picture so it loses resolution

    Where is this setting so it will not be resized?

    #88619

    Hi,

    Sorry for the delay. On the link above, We can make the image size lets say 320×320 m how you cropped it there.

    Please add this to Quick CSS in the back end under Choices > Theme Options > Styling:

    #top .slideshow li img{max-width: 320px}

    or

    #top .slideshow_container ul{max-width: 320px}

    Thanks,

    Nick

    `

    #88620

    Thank you Nick for the reply.

    I made the change ..but i want another page a different size picture

    For this page :http://www.rhodes-apartments.biz/tasos/%CF%86%CE%BF%CF%85%CF%81%CE%BD%CE%BF%CE%B9-%CE%B5%CF%80%CE%B1%CE%B3%CE%B3%CE%B5%CE%BB%CE%BC%CE%B1%CF%84%CE%B9%CE%BA%CE%BF%CE%B9/

    1)How can i keep the normal size picture only in this page and not make it width 620 px?

    2) I would like also to keep the colors of the image because at the moment is shown grey…How i can remove greyscale only for this picture?

    #88621
    #88622

    When i make the above change you told me …it s changes also the central page….the with of the main pic goes to 320 px

    so i had to remove the quick css you gave me

    #88623

    Hi,

    Please remove the previous fix and try this one instead (just in case do not lose the original fix for now until you make sure this works)

    #top.single-portfolio-entry .slideshow li img{max-width: 320px}

    and

    #top.single-portfolio-entry .slideshow_container ul{max-width: 320px}

    Thanks,

    Nick

    #88624

    Nick it didn t work..DO you have any idea if i can do that separetly,,,chance the code in each page-portfolio so it will not effect the other portfolio pages?

    #88625

    Hi,

    I am sorry, I keep getting error -> .isotope-item.post-entry.post-entry-802.no_margin.flex_column.all_sort.portfolio-entry-overview.portfolio-loop-1.portfolio-parity-odd.%cf%86%ce%bf%cf%85%cf%81%ce%bd%ce%bf%ce%b9-%ce%b5%cf%80%ce%b1%ce%b3%ce%b3%ce%b5%ce%bb%ce%bc%ce%b1%cf%84%ce%b9%ce%ba%ce%bf%ce%b9_sort.one_fourth.first.portfolio-entry-description.no_combo , selectors like this and my computer freezes.

    Let me see if anyone else here can lend a hand.

    Thanks,

    Nick

    #88626

    Hi gnikolis,

    Just coming into this, what is your final goal you are looking to achieve and what is the issue currently? It looks like it started out that you wanted to make the image area in a ajax portfolio smaller once the individual portfolio item is expanded on the same page correct?

    Regards,

    Devin

    #88627

    yes correct…The image looks bigger when you click on it…How can i change this separetely in each portfolio page?

    http://www.tzotzolis.gr/models/

    #88628

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.page-id-732 .slideshow li img {
    width: auto;
    margin-left: auto;
    margin-right: auto;
    }

    This will need to be repeated for each page that you have this kind of portfolio on that you want to have the image not adjust to the actual slideshow area. Here is a quick write up on finding the page ID in wordpress: http://www.techtrot.com/wordpress-page-id/

    You will need to copy and then replace that 732 number in the above code for each page ID you want the css to work with.

    Regards,

    Devin

    #88629

    i have tried the above code…the picture remains the same size as it is…but

    is showning at the same time 1/2 of the picture next to the normal one..

    i had to remove the code because the site is live now…

    So u have any idea why this happens?

    Thank you in advance

    #88630

    You can also try:

    #top.page-id-732 .slideshow li img {
    width: auto;
    margin-left: auto;
    margin-right: auto;
    display: inline-block;
    }

    The best alternative will always be using larger images however, since then they will be usable for all the various features throughout the site.

    Regards,

    Devin

    #88631

    Dear Devin

    I tried also this code but unfortunatelly is shows the picture twice…any other suggestions?

    should i use larger images? which with should i choose?

    #88632

    Larger images would definitely fix it as they then wouldn’t need any kind of modification. When trying the above css, make sure to flush your local cache by refreshing the page a few times. Just in case you are seeing the site without the updated css.

    Once you have used a new larger image, just to make sure all sizes have been properly re-generated use: http://wordpress.org/extend/plugins/regenerate-thumbnails/

    This way everything is properly set to the sizes set in functions.php. If you made any changes to functions.php for image sizes as well, they will be used so keep that in mind.

    Regards,

    Devin

    #88633

    i used again the above code and regenarate the thumbnails but it din t work …still showing 2 times the picture..

    In some items i cannot use biger size pics…because are provided by the company…

    the Portfolio seems a bit hard to set…Am i the only one?

    I don t understand why there is no specefic fields where somebody can set how the pics should look on the portfolio page and how when you click on them…

    #88634
    #88635

    The pic is 554x 345 and i cannot change it because is provided by the company…

    As a thumbnail is shown good…but when u click on it..it s a disaster..

    From where i can set the 554 X 345?

    #88636

    I’m not sure what else to do. At different points the above css worked on my end with smaller images but there isn’t a lot of control when the images are much smaller than the space provided.

    Also note, the css I gave above needs to be customized to the specific page. So the link you just provided would need the following css instead:

    #top.page-id-214 .slideshow li img {
    width: auto;
    margin-left: auto;
    margin-right: auto;
    display: inline-block;
    }

    Regards,

    Devin

    #88637

    i tried to resize the images..both are 630×630 now …look how the first one is shown when you click on it..and look at the 2nd…

    How can that happen even though both have the same size…

    It hust drives me crazy….

    How other people fix their images on this portfolio?

    Does it work???

    http://www.tzotzolis.gr/sinthetes/

    #88638

    Which size i have to use so it will not be resized?

    #88639

    I don’t know where you re-sized the images at but the ones being loaded in are 320×320. Perhaps you are still using that size in your functions.php, but I can’t be sure.

    At this point, you need to make sure you are using the stock theme files since this has been strung out for so long with so many different changes additions.

    Try re-loading the theme just like you first installed it to make sure everything is back to square one. Then, you will once again need to re-generate your thumbnails with the plugin you have installed so that the correct sizes of images are used from the functions.php.

    Typically, the process is a lot more straight forward than this but when using images that are so much smaller than the theme and layout are designed for it causes issues like this since the images then get stretched.

Viewing 30 posts - 1 through 30 (of 36 total)

The topic ‘Portfolio 4 culumns item view’ is closed to new replies.