Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20641

    I am using the portfolio page as the homepage – it is not displaying more than 12 items. I have gone into Angular > Theme Options > Portfolio and marked that 20 items should be displayed per page, but it doesn’t change anything.

    Also – while it is sorting by category, I want the order of the portfolio items displayed to be in alphabetical order. I am unsure how I can change the order – right now it looks like it’s just displaying whichever ones I added last – first.

    Any help would be appreciated.

    Thanks

    #108422

    anyone?

    #108423

    1) It seems like you’re using a dynamic template on the home/front page. In this case you need to configure the portfolio options on the Template builder option page. Go to Angular > Template Builder and select your front page template. Then click on the portfolio element and change the number of items.

    2) Add following code to the very bottom of functions.php to change the portfolio order:

    function loop_portfolio_query( $location )
    {
    if ( $location == 'loop-portfolio' )
    {
    global $avia_config;
    if(isset($avia_config['new_query']))
    {
    $avia_config['new_query']['orderby'] = "title";
    $avia_config['new_query']['order'] = "ASC";
    query_posts($avia_config['new_query']);
    }
    }
    }
    add_action( 'avia_action_query_check' , 'loop_portfolio_query', 10, 1 );

    #108424

    that did the trick, thanks so much!

    #108425

    Hi lisalokshin1,

    Glad that Peter helped you. :)

    Cheers,

    Ismael

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Portfolio as homepage- won't allow more than 12 items – also random sorting orde’ is closed to new replies.