Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #16882


    Recently, the autorotation function on my portfolio has stopped working.

    If you click on a portfolio item for the first time, the autorotation works. Once you exit that item and re-visit it, the autorotation function stops working altogether, along with the forward and backward functions. The only way to view all the items is to click on the portfolio image, which enlarges then manually scroll through the items. As we all know, this doesn’t work on smartphones and tablets which means my site is useless for people wanting to view my work on these items.

    The only way to make this autorotation function work again is to re-fresh the website in the browser.

    I’m running the latest version of wordpress and I’ve deactivated all plugins and this has no effect.

    my site is

    Can someone look into this matter as this has basically rendered my site unusable.




    Hey Chris,

    It looks like the way in which your caching plugin has condensed the javascript files is causing an error with them. This would explain the odd behavior with the effect.

    I believe W3 has a way to change its settings to not modify the javascript files which should fix the issue.




    Hi Devin, thanks for the swift response.

    I’ve deactivated W3 total cache and even removed the plugin and autorotation still only works the first time around. I’ve also visited a few sites using the angular theme that have posted their links on this forum and their sites do exactly the same. Click on a portfolio entry, watch it autorotate, click the ‘x’ button, revisit it and the autorotate doesn’t work. Do you think this is a fault with the theme? Or do you have any other suggestions? I’ll try anything to get it to work.



    #93260 is a site in the Showcase your website thread. The autorotation failed too. Could it be my browser? I’m using safari 5.1.7


    Hey Chris,

    Nope, I see what you mean now and re-create it on my end as well. I’ll send the bug to Kriesi for a fix in the next release.




    Thanks Devin.




    thanks, I was able to identify the issue, a fix its on its way ;)

    Best regards,


Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Portfolio Autorotation only works once’ is closed to new replies.