Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #13702

    Iv noticed the portfolio “window” doesn’t always resize, sometimes it takes very long, and sometimes it get’s stuck.

    Please see screencast for example.

    http://www.youtube.com/watch?v=IhIjvhNtctE

    Any ideas whats causing this ?

    Regards

    Paul L.

    #80239

    Hey Paul,

    I’m really not quite sure why you are getting such a slow response. When I view the site live there is a slight delay while the images load but everything adjusts quickly after that. I’m also not getting any errors in the code either

    Are you able to try the site on any other computers or browsers to see if it might be a computer or browser+OS specific issue. Thank you for making the video as it does show whats happening on your end very clearly :)

    Regards,

    Devin

    #80240

    It’s quite odd as it happens now and then, i can’t reproduce the problem at will it “seems” random. I haven’t experienced it yet in Firefox, but i haven’t really tested the site in Firefox that much.

    I’ll test firefox a little more and see if it’s isolated to safari.

    Screencast is much better explaining then i am.. :-)

    Regards

    Paul L.

    #80241

    Hi,

    Let us know what you find in Firefox.

    Regards,

    Mya

    #80242

    Hi!

    It’s now a permanent problem :-(

    Once i started filling my portfolio the first image in every portfolio item only loads half way. :-(

    It’s not loading slow, because if i turn on auto play the first image never loads more then half-way.

    This is pretty much consistent on safari, if i just show one category on the portfolio page with one portfolio items it loads without any problems.

    Changing back it’s back to half-way loading.

    This is isolated to safari, as it does not happen on firefox.

    Iv replicated the issue on several machines running safari, all mac’s as i don’t have a pc.

    Please advice!

    I need to have many items in my portfolio and i don’t want to use pagination (it doesn’t seem to help anyway) as the filtered portfolio doesn’t work that well with multiple pages.

    Iv tried a fresh install of the theme, without any hanges, still the same. I have versions 1.4 (which i believe is the latest)

    My system:

    system.png

    Please se this screencast for more info:

    http://www.youtube.com/watch?v=i4UFGhwsqwY

    #80243

    Hi Paul,

    Try testing everything without any plugins active to make sure there aren’t any conflicts. I’m already getting one javascript error when I view your site so the issue could be related though I can not say for sure.

    Regards,

    Devin

    #80244

    Hi Devin!

    I tried that as well, no difference sadly. .-(

    These are the plugins installed:

    plugins.png

    The plugins are disable now, can you check if you still get the java error ?

    Regards

    Paul L.

    #80245

    If anyone have the time to check on this it will be much appreciated as i need to get it fixed as soon as possible.

    Kindest Regards

    Paul

    #80246

    I know Java is old on mac, as it’s distributed by Apple, but then again firefox work without fail and it uses the same java version as Safari does ?

    Can someone replicate the bug on their Mac with safari ?

    I don’t get the error on iPad with safari…

    Also where can i check for java errors ? (i’v disabled all the plugins)

    Regards

    Paul L.

    #80247

    Hi Paul,

    So is it now only happening for you on your computer using Safari? My guess would then be its related to a setting/plugin/addon or local difference.

    I’ll mark the topic for the other support crew to take a look at to see if anyone is able to get the same error when viewing your portfolio page here: http://paullindqvist.se/portfolio/

    Regards,

    Devin

    #80248

    Hi Devin, it happens on all my mac’s iv tested with latest OSX and Safari (5 mac’s in total) so it’s isolated to Safari for sure, since i can’t replicate the issue on either Chrome or Firefox. However it’s still troublesome as some potential clients will look at the site with safari.

    Regards

    Paul L.

    #80249

    Hey!

    I marked this thread for Kriesi too – he should be able to reproduce the issue on a Mac.

    Regards,

    Peter

    #80250

    Just to confirm that it happens on safari 6.0 and OSX 10.8 (mountain lion) so it certainly seems to be a bug with safari.

    #80251

    Hi Paul,

    I’ve experienced similar issues with half loading images only when the connection was lagged while trying to load a whale of a web page. First thing we need to do is web optimize those images. Right now the browser is trying to swallow a 6 megs site broken up into 67 non parallel requests, with 400k images.

    This is bad for two reason – clients wont wait; and google uses speed as in important component of their ranking algorithm, which means it will be much harder for potential customers to find your site even when all other metrics are matching up.

    Lets take a look at http://paullindqvist.se/wp-content/uploads/2012/07/2012-paul-lindqvist-6.jpg . Right now its at 394K, but I was able to easily compress it to 89.9K without changing it’s width or height nor making it look any different from the original. A further gzip compression will probably shave another 30k off.

    Once, every image is optimized, and the site is down to 1 meg or under (per page), I am certain these loading problems will go away. If you want to replicate the error, empty your cache and reload it during peak usage hours. Once you repeat that a few times, you will hit the problem when the browser chokes. Also please consider using a content delivery network (CDN) to distribute the load over multiple parallel connections, you will be running fast and smooth.

    #80252

    Hi Nick!

    Thanx for explaining the cause of the problem, really appreciate it!!

    So i guess i have to upload all the images again (after i optimized them in photoshop ) ?

    Or are there a more efficient way, maybe a plugin that optimize all the images already uploaded ?

    If not, is the best method to optimize the images with Photoshops “save for web” method, or is there another way you recommend ?

    Again much appreciated for your help!

    Regards

    Paul L.

    #80253

    Hi,

    There is a plugin but I had mixed results using it. There is a better plugin but you must ask your webmaster if the host allows the use of them, Its best for JPG to be loaded into Photoshop, to change all resolutions to 72 , and increase the size of the file back to what it was at 400. So you start off with a 400 dpi file that’s 800×300 lets say, when you drop resolution to 72 it will become 150×60 lets say, and then you change image size back to 800×300. Then save for web at no more than jpg of quality 55.

    This http://www.webpagetest.org/compare in my opinion is the most comprehensive analyzer of website speed issues, is free, and saves previous tests so you can see how your optimization progresses.

    http://wordpress.org/extend/plugins/ewww-image-optimizer/ this is the best image optimizer plugin in my opinion but it requires webmaster to help you. There is a second plugin that compresses also with no need of webmaster, but i can’t recall its name.

    http://wordpress.org/extend/plugins/w3-total-cache/ use this plugin to cache tho difficult to setup correctly, and time consuming, once done, it increases the speed by a factor of 10, 1000%. It also will offload your images to a cdn or even your own sub-domains to create parallel downloads for visitors, speeding up their experience.

    Make sure there is a file called .htaccess at the base of your website. Its very important that inside it there are directions for server to compress your files and also to force visitors to cache (neither of which you are using now), to also speed up the site. w3 total cache plugin , when installed and configured will add whats needed in it. But otherwise this is a good starting point http://html5boilerplate.com/template/htaccess.txt?.xml though it cant be used as is without modification and having your current .htaccess merged with it to some extent.

    If you follow these guidelines you should be loading at 5-6 seconds per page instead of the current 33-37 on the first load and 1-2 seconds on subsequent. Good luck!

    Nick

    #80254

    Wow Thanx Nick!! Much appreciated !!!

    #80255

    Hi paullindqvis,

    Glad that Nick helped you. :)

    Cheers,

    Ismael

    #80256

    Nick if you have the time could you please check my site again and see if you see an improvement ?

    http://paullindqvist.se

    The plugin that required webmaster to install was a no go sadly, smush.it seems to be very unstable.

    So i downloaded all the image and ran them thru a batch optimizer and uploaded them again.

    Thanx!

    Regards

    Paul L.

    #80257

    Hi!

    I marked this thread for Nick.

    Best regards,

    Peter

    #80258

    Hi Paul,

    You did great with the images. You are now:

    Page load time: 7.29s

    Total page size: 1.98MB

    Total number of requests: 66

    So you cut 70%.and photos look good, Perhaps you can shave off at least another 300k with loss-less compression for images.I am not sure if that’s worth it though since as a photographer (for some reason I thought you were a chef (hehe) with all the photos of food, i got hungry).

    The remaining optimization requires having a cooperative host since most of these things require them to click one button and it benefits them to since less bandwidth is used up.

    But if you are up for it, here is a video http://www.youtube.com/watch?v=Lbs3pRL4XQg for a plugin you can install yourself.. I don’t know your comfort level with English, but this plugin is so popular if you search in Swedish YouTube for w3 total cache, i am certain there are instructions in that language.

    But if you are comfortable following along this short video, you will not need a webmaster and perhaps get down to 3 seconds instead of 7 without losing image quality. Just don’t turn on things you don’t know. If after turning everything like shown in video, you don’t like the result just de-activate it and that’s it.

    Good Luck,

    Nick

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Portfolio bug ?’ is closed to new replies.