Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #25576

    Hi there,

    my site is http://www.fortknightstale.com

    On the “archive” page you’ll see my problem with the image cropping; I need the images to be the ratio they are (if you select a portfolio item you’ll see why), can I have the portfolio page images have whitespace at top and bottom instead of cropping the left and right?

    Also, on the “similar portfolio items” area and the footer portfolio list where are icon overlays of a writing pad and a film reel over the top of the images, how would I go about removing these?

    Also, a quick side question, no matter how long I wait, the twitter widget in the footer does not load my tweets. Any idea why?

    Many thanks

    #127452

    Hi,

    The best way to go about it, is to first install the Simple Image Sizes plugin ( http://wordpress.org/extend/plugins/simple-image-sizes/ ). The plugin will give you complete control over images: setting constraints for specific locations like blog, thumbnails, portfolio, gallery, shop, etc. along with the ability to set whether to crop an image or not in Settings > Media.

    Changing the dimensions of images does NOT automatically change all the images already uploaded but only affects new uploads. To change the sizes of images already uploaded, you will need to use the Regenerator – also a part of the Simple Image Sizes and found on the bottom of Settings > Media. Don’t forget that images scale down, so always upload images bigger (or the same) as the constraints you set in Settings > Media (with the plugin) or you will get blurry (stretched) or incomplete images.

    If all your portfoio images are about the same 500×210 you can make the following changes in Settings > Media .. http://www.clipular.com/c?9452053=5N15lmkbreObt9VJVc2IOteok_s&f=.png .. Please make same changes as the green line to width and height, and also turn off cropping . Button must not be blue color. You can then click update button which will appear below the line, and click save on the bottom of the page. You can either re-generate the portfolio images on the bottom of that page, or you can reupload the images one more time.

    if you don’t want the images on the individual portfolio pages from blowing up too much thus becoming blurry you can try this css code

    #top.single-portfolio .slideshow li img {
    max-width: 500px;
    }

    Thanks,

    Nick

    #127453

    1) You can deactivate the image cropping. In functions.php replace:

    $avia_config['imgSize']['portfolio'] 		 	= array('width'=>495, 'height'=>400 ,'copy'=>'greyscale');	// images for portfolio entries (2,3 column)

    with

    $avia_config['imgSize']['portfolio'] 		 	= array('width'=>495, 'height'=>400 ,'copy'=>'greyscale', 'crop' => false);	// images for portfolio entries (2,3 column)

    and regenerate the thumbnails with: http://wordpress.org/plugins/regenerate-thumbnails/

    2) Insert following code into the quick css field

    .post-format-portfolio .related_image_wrap {
    background-image: none !important;
    }

    3) Yes, Twitter started to shutdown the current api on June 11 ( http://www.mediabistro.com/alltwitter/twitter-delays-api-shutdown_b41602 ) and our widget does not support the new api. Thus the widget won’t work anymore. You can use a plugin like http://wordpress.org/plugins/twitter-widget-pro/ which supports the new api or generate a widget here: https://twitter.com/settings/widgets . Because the new authentication process is very complex we decided that we won’t bundle a twitter widget with the theme anymore and we’ll remove it with the next update.

    #127454

    Hi Dude,

    neither seems to work for me, it seems. I replaced the code as you recommend, and then regenerated thumbnails, but nothing appears to be different.

    I added the code the quick css, but again, nothing.

    Thanks for letting me know about the Twitter switch, I set up my own through Twitter.

    #127455

    Hi,

    Instead of regenerating, please try to delete one of your images and reupload it. Please use the plugin , it will make your life easier in the longrun.

    Thanks,

    Nick

    #127456

    Hi Nick,

    ahh, that plugin is perfect, thank you very much. My archive page works perfectly now. Now I just need to fix the icon overlays :)

    Many thanks

    #127457

    Hi,

    It is a useful plugin.

    I am not sure what problems you have with icon overlays. Can you provide a url to the page? You can mask the url inside with http://www.goo.gl if you want.

    Thanks,

    Nick

    #127458

    My site is http://www.fortknightstale.com/

    If you look in the footer you’ll see portfolio widgets – the images have some sort of overlay over them. I want to remove that, if possible.

    EDIT – Ah, good old Firebug. Found the image in question in the css -

    format-standard .news-thumb {

    background-image: url(“../images/icons/icon-format-standard.png”);

    }

    Removing it altogether makes it look awful, so I’ll try replacing it with a blank grey image.

    #127459

    Hi,

    You can just add this css to override the image ( i am assuming the css you posted is correct)

    .format-standard .news-thumb {
    background-image: inherit !imporant;
    }

    Thanks,

    Nick

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Portfolio image cropping and image overlays’ is closed to new replies.