Tagged: ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #15171

    I searched this and found this question asked a few times but did not find a clear answer. please help! the portfolio item photos, which must be in the slider to be a featured image, are being resized to a huge image for the item page. thumbnail looks great on main portfolio page but on item page the image it is way too big. It takes up the whole screen and you have to scroll down to see all of it. how do we control the image size? edit the image does nothing because this seems to be controlled by the slider.

    What is the solution to this? I can’t find it on the forum. thanks!!

    #86514

    Hey alisewski,

    Typically, the image will get stretched if it isn’t large enough to fit the width of the main slider area. Forcing it to take up a smaller area can be quite problematic and the best solution is to just use a larger image. For an image that will be taking up the full width of the page thats 930px wide and for one with a sidebar its 690px wide.

    Otherwise, once the image gets shrunken to its normal size the whole layout looks off as you have this image just sort of floating out there by itself.

    Regards,

    Devin

    #86515

    Is there option not to show the picture as the header at the portfolio page? I would just like the thumbnail. Otherwise, can the image be at the sidebar inline with its title below?

    #86516

    Hi,

    @alisewski Please install the ‘Simple Image Sizes’ plugin ( http://wordpress.org/extend/plugins/simple-image-sizes/ ) which will centralize every image size in the theme on the Settings > Media page, as well as regenerate the thumbnails/images. In about 5 minutes of playing with its awesome controls you will be able to get those images doing back-flips in any size you want.

    @nvd80 Please download the same plugin i suggested above ‘Simple Image Sizes’ plugin ( http://wordpress.org/extend/plugins/simple-image-sizes/ ) and play around with the settings. You will see the image size 930×340 (featured image). This is where you can change it’s size, crop it, etc..

    Please let us know how things went.

    Thanks,

    Nick

    #86517

    I’ve been trying for 6 months to get rid of the HUMONGOUS images on each of my portfolio entries. Every month or so, I scan forum for a solution, and make another failed attempt to resize the gigantic images in the Propulsion Theme portfolio. Nothing works, including this simple image size plugin. No matter what I do, or what file I edit, settings I change or plugin I install .. the portfolio image fills my entire 27″ monitor screen and I have to scroll down to even get past the bottom of the image.

    It’s ridiculous the hoops people (buyers) are jumping through to find a solution. But it doesn’t seem like the author has any interest in working on a fix. I may abandon Propulsion, as much as I love the theme. But I sure won’t purchase another Kriesi theme to replace it. I don’t have the time or patience for another headache like this one. Like others, I don’t have this problem with any other wordpress theme I work on. The problem is with the theme.

    #86518

    Something just hit me: This is probably the first responsive theme I’ve used. Is the fact that it’s responsive, and is designed to “fill the screen” no matter how big or how small … is that why we don’t have control over the size?

    #86519

    Hi,

    Yes. The theme is responsive and uses media queries to determine the screen size and then shows the correct css for a number of predetermined screen sizes (smart phone, tablet, monitor). If you use pixels , you need to make sure you are hitting the correct media query, otherwise it will not be compatible. Try to shrink your browser window by making it the size of a tablet then the size of an iphone and you will see everything rearranging , the images shrink proportionally etc…that is why almost everything has width:100%; and height: auto;

    If you look at your grid.css file , you will see media queries encompass blocks of css and look like

    @media only screen and (min-width: 768px) and (max-width: 959px) {

    /* some css that only is read when screen size fits above constraints */

    }

    Thanks,

    Nick

    #86520

    Thank you for your reply. I will take another shot at this and report back. My apology to nvd80… I’m sorry I hijacked your thread! I would also like to know the answer to your question (above):

    Quote:

    Is there option not to show the picture as the header at the portfolio page? I would just like the thumbnail. Otherwise, can the image be at the sidebar inline with its title below?

    If anyone can tell us what file to modify that will remove the large picture altogether; that would be an acceptable solution.

    #86521

    Hi Nick and nvd80 … I scanned this forum a little more and found Nick’s advice on a similiar topic, from a few days ago. The solution is perfect! It looks wonderful!

    Here is where I found it: Controlling Portfolio Single Entries question:

    http://www.kriesi.at/support/topic/controlling-portfolio-single-entries

    I followed his instructions to a “T” including updating to the latest version of the theme, then editing just 3 files … and ..voila! … the problem I’ve been trying to solve for months is resolved once and for all (I hope!).

    Now each single portfolio page no longer shows a huge image at the top of the page. Just a small 1/3 sized image or slideshow displays. If I click on it, THEN a larger version pops open in another window. Ahhh! Now that’s how it should be!

    Thank you so much, Nick, for your carefully laid out instructions. You rock! I’m sure many people will appreciate the time you took for that helpful reply. I hope there is a way to make that response a FAQ or sticky or something.

    #86522

    Hey,

    Glad it is fixed.

    Regards,

    Ismael

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘portfolio item image way too big’ is closed to new replies.