Tagged: , , ,

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
  • #202209

    Hi, We’re using wordpress 3.8 and Enfold 2.4.4 and we’re currently having a problem with the rewrite rules for portfolio-items. All plug-ins have been deactivated and rules flushed many times to no avail. Rewrite Rules plug-in show the following:

    Here’s an example page: http://percolab.com/blog3/portfolio-item/test-de-permalien/

    categories/([^/]+)/?$	index.php?portfolio_entries=$matches[1]	missing
    categories/([^/]+)/page/?([0-9]{1,})/?$	index.php?portfolio_entries=$matches[1]&paged=$matches[2]	missing
    categories/([^/]+)/(feed|rdf|rss|rss2|atom)/?$	index.php?portfolio_entries=$matches[1]&feed=$matches[2]	missing
    categories/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$	index.php?portfolio_entries=$matches[1]&feed=$matches[2]	missing
    portfolio-item/[^/]+/([^/]+)/comment-page-([0-9]{1,})/?$	index.php?attachment=$matches[1]&cpage=$matches[2]	missing
    portfolio-item/[^/]+/([^/]+)/(feed|rdf|rss|rss2|atom)/?$	index.php?attachment=$matches[1]&feed=$matches[2]	missing
    portfolio-item/[^/]+/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$	index.php?attachment=$matches[1]&feed=$matches[2]	missing
    portfolio-item/[^/]+/([^/]+)/trackback/?$	index.php?attachment=$matches[1]&tb=1	missing
    portfolio-item/[^/]+/([^/]+)/?$	index.php?attachment=$matches[1]	missing
    portfolio-item/([^/]+)(/[0-9]+)?/?$	index.php?portfolio=$matches[1]&page=$matches[2]	missing
    portfolio-item/([^/]+)/comment-page-([0-9]{1,})/?$	index.php?portfolio=$matches[1]&cpage=$matches[2]	missing
    portfolio-item/([^/]+)/page/?([0-9]{1,})/?$	index.php?portfolio=$matches[1]&paged=$matches[2]	missing
    portfolio-item/([^/]+)/trackback/?$	index.php?portfolio=$matches[1]&tb=1	missing
    portfolio-item/[^/]+/attachment/([^/]+)/comment-page-([0-9]{1,})/?$	index.php?attachment=$matches[1]&cpage=$matches[2]	missing
    portfolio-item/[^/]+/attachment/([^/]+)/(feed|rdf|rss|rss2|atom)/?$	index.php?attachment=$matches[1]&feed=$matches[2]	missing
    portfolio-item/[^/]+/attachment/([^/]+)/feed/(feed|rdf|rss|rss2|atom)/?$	index.php?attachment=$matches[1]&feed=$matches[2]	missing
    portfolio-item/[^/]+/attachment/([^/]+)/trackback/?$	index.php?attachment=$matches[1]&tb=1	missing
    portfolio-item/[^/]+/attachment/([^/]+)/?$	index.php?attachment=$matches[1]	missing

    Hey percolab!

    You can try to flush the permalink settings a few times. Change it to something else, save changes. Revert it back to your default settings then save changes again. Add this on .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Best regards,


    Thanks Ismael for your response,
    Tried that, but no joy, been trying multiple things all day.

    Any other ideas? P



    Are you using WPML? If yes this thread: http://www.kriesi.at/support/topic/wp-3-8-with-wpml-3-0-1-creates-404-errors/ may help you.

    Best regards,


    Hi, Thanks for the reply, tried that (re-freshed the permalinks as well) still no joy.

    BTW – We had previously WPML installed and de-activated it for the update to 2.4.4. So I re-activated WPML and added that code to our child-theme functions file.

    Would love to have this cracked asap.

    Thanks, Paul



    I just noticed you already updated Enfold to verion 2.4.4. Since Enfold 2.4.4 you should be able to change the portfolio permalinks settings on the Settings > Permalink page. You don’t need to use the code I posted here ( http://www.kriesi.at/support/topic/wp-3-8-with-wpml-3-0-1-creates-404-errors/ ). If you want to translate the slugs with WPML you can use the “String Translation Management” extension for the slug translation.

    If the permalink rules don’t work try to delete the theme folder, then re-upload all themes files (v2.4.4), go to Theme Options and save the theme settings, then go to Settings > Permalinks and save the permalink options.

    Best regards,


    Hi Peter,

    I added a new theme and the portfolio items worked (nearly all, one or two gave 404 errors), but all the pages ended up as 404 errors.

    If I add the following to functions.php: flush_rewrite_rules( false ); the pages work, but the portfolio items don’t. Do you want to have a poke around the admin?

    Really need to get this cracked as the site should be live and this is holding us back. Thanks for any support.

    Best wishes, Paul



    Yes, if you can respond here with a private reply (the set as private reply check box) and giving the needed credentials to look at it live that would be great.


    This reply has been marked as private.


    Please update your WPML version to 3.0.1. 2.4.2 is outdated and it may not work with WP3.8 or Enfold.



    Same issue here, all portfolio feeds end up with error 404.
    Only changed the permalink item base to “referenz”.

    Enfold v2.6.1, not using WPML



    I checked all portfolio entries and the links work for me – did you solve the problem?

    Best regards,


    Sorry, forgot to mention that the Feeds are not working, entries are just fine.
    For example: http://www.chris-kettner.de/referenz/lamar-lowery-functional-training/feed
    Discovered the problem in the broken links section of Google Webmaster Tools.

    Thanks for your help!


    We fixed ours by…

    Change theme to standard theme (like thirteen)
    Deactivate WPML
    Save permalinks – check it works
    Change theme back to Enfold
    Activate WPML
    Save permalinks


    WPML isn’t running, tried to change the theme and save permalinks though.
    Unfortunately, nothing has changed.



    You can’t great a feed of a single portfolio entry – i.e. http://www.chris-kettner.de/referenz/lamar-lowery-functional-training/feed is not a valid feed url. If you need a category feed use the archive url (i.e. http://www.chris-kettner.de/category/allgemein/ ) and add /feed/ to it:


    If you need a feed of all portfolio entries use this url: http://www.chris-kettner.de/feed/?post_type=portfolio

    Best regards,


    it’s not that i need the feed, but it seems to be automatically generated in the source code (line 32).
    How to avoid that behaviour?

    Thanks for your effort



    You can remove the feed links. Just insert this code:

    remove_action( 'wp_head', 'feed_links', 2 );

    at the very bottom of your child theme functions.php or enfold/functions.php



    Hi Peter,
    your Code Snippet removed the Page and the Comment Feed, but the portfolio item feed remained in the code.

    I found some similar snippet that did the trick:

    remove_action( 'wp_head', 'feed_links_extra', 3 );

    I only wonder if that snippets affects other than the portfolio feeds.



    Yes, it will disable category as well as comment feeds as believe.



    Good luck :)



    Yes, it will affect all feeds. If you don’t want to remove the feed of pages/posts replace:

    remove_action( 'wp_head', 'feed_links_extra', 3 );


    add_action('wp_head','avia_remove_feed', 1);
    function avia_remove_feed(){
    if(is_single() && get_post_type() == 'portfolio') remove_action( 'wp_head', 'feed_links_extra', 3 );

    Best regards,


    Perfect, thank you Peter!
    That’s exactly what I was looking for.

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘Portfolio items all 404's Rewrite rules missing?’ is closed to new replies.