Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #209340

    Hi Support Team
    Se previous request: http://www.kriesi.at/support/topic/portfolio-items-slow-or-do-not-load/#post-185770
    We have received a response from our hosts that describes the issue as a theme problem with image calls. Can you please advise what can be done for this issue? We would prefer not to have to re-setup a replacement theme for the site.
    There is a staging non-CDN enabled version of the site that is experiencing slowness http://wildmob.staging.wpengine.com/

    ====== FIRST RESPONSE ======
    I’ve taken a look at the issue with the loading speed on your site and it appears that while yes, the issue does have to do with the images on your site, it’s not actually a result of the CDN. On first load the homepage makes a exorbitant amount of calls to outside files including CSS but primarily images. On my last check 249 requests were made for mostly images. You can see that speed test here: http://www.webpagetest.org/result/131110_F9_MT1/.

    I would like to test this issue further from the staging environment so that we can get a better understanding of why so many images are called to load on the page as it does not seem they are all necessary. If possible I’d like to make some changes to the staging area (such as disabling plugins and your theme) for testing purposes but I’m hesitant to do so without permission as I don’t want to lose any possible changes you’ve made there.

    Would you mind creating a fresh instance of the staging site on your account please? We can also do this for you if you like but, for security purposes, we’ll need to verify the last four digits of the card on file in order to proceed. Please keep in mind that if we copy the live site to staging it will permanently overwrite all content currently in the staging area as we do not maintain backups of that area.
    ======END=======

    ====== SECOND RESPONSE ======
    After testing with staging looks like the theme is calling the bulk of the images. I just turned on a default theme in staging and now the only long load time is a few very large images. Check out this test: http://www.webpagetest.org/result/131111_JG_55Q/

    If you reduce the image file size of what is being currently called it should make a huge improvement for the staging site. Remember we do not cache the staging so that will severely affect any tests for staging. At this point I would recommend trying another theme and compressing your images more. That should make the best improvements. From there, we can look at what else can improve the speed of your site. Let us know if we can answer any more questions or concerns regarding this issue.
    ======END=======

    Many thanks,
    DGM171

    #209343

    Hey DGM171!

    If you are experience a slow loading time from loading too many images the answer is to decrease the number of images via the theme settings that you want to show on the home page.

    You as the user have the choice on how you want the site to look and work. You can easily choose to hobble your loading speed by selecting too many images of large size or just too many in general to load on the page.

    So instead of showing the portfolio items with all of the slideshows for each portfolio item on the home page instead just show a few single images that link to the pages you want to show. You could also change the settings to only show a single image instead of the full slideshow.

    Best regards,
    Devin

    #209771

    Thanks Devin. That makes sense. Please close this request.
    Cheers DGM171.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Portfolio items slow or do not load v2’ is closed to new replies.