Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6508

    Basically what I’ve written in the title.

    I’m using a custom permalink structure: /%postname%/ as this provides an SEO friendly URL. However, when I click on an item in the portfolio I’m getting a 404 page not found error.

    I’ve checked the URL and the theme is generating the correct URL, e.g. http://www.mywebsite.co.uk/portfolio/my-portfolio-item/ but it’s not displaying the page. Even when I try and view the portfolio item directly from the WordPress admin ‘view portfolio entry’ button it goes to an error page.

    If I use the default permalink structure then it works, but I don’t want to do this as it’s rubbish for search engine performance.

    Can you provide an SEO friendly permalink structure I can use? This theme is pretty useless for me if I have to resort to the default permalink structure.

    Thanks.

    [update] By hitting the ‘save’ button a couple of times in the permalinks section I can now see individual items when I click on them. However, now the pagination isn’t working. Urgh. There’s something amiss here somewhere.

    #54451

    Hey,

    this sounds like your wp installation has problems with the permalink (slug) rewrite. I’d contact the hoster and ask if they’re aware of any problems, especially with the htacess file: http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks

    #54452

    Thanks for the reply – impressed with the support!

    The posts are linking ok, but paged navigation for the portfolio section doesn’t work. I’ve gone through the link you’ve supplied and tried all the suggestions but it’s still not working. I’ve installed a copy of the site on another (better quality) server but I’m having exactly the same issue.

    However I’ve just tested the blog section, added a few test posts and paged navigation is working perfectly in this section on both servers.

    I can see the portfolio pagination is working in your demo – what permalink structure have you used? It’s very strange that I can’t get it to work on my own site.

    #54453

    I’m having the same exact problem. I’m testing the site locally on my machine using MAMP, so I can’t provide a link.

    But I can’t use the default permalink structure with my theme (Angular), I need my links to be SEO friendly too. When I try changing it to show: mywebsite.com/about it works fine, but if I try using a child it shows a 404 error! ex: mywebsite.com/about/services

    If I change it back to the default permalink structure both work fine, but like I said, is NOT SEO friendly.

    It’s driving me insane as I’ve never had this problem before.

    Can you please help?

    #54454

    Sorry! I figured it out. I had my custom portfolio single items named “work” and I also had a page named “work”

    I should read the print right next to the customization options that says “Dont use characters that are not allowed in urls and make sure that this slug is not used anywere else on your site (for example as a category or a page)”

    WHOOPS!

    All figured out!

    Thanks for the crazy awesome documentation!

    #54455

    Hey wildefranz,

    I’m glad you were able to figure out and Thank you for posting the fix and update! Its really helpful to others who might have been having the same issue.

    Thanks again :)

    Devin

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Portfolio not working properly with custom permalinks’ is closed to new replies.