Tagged: 

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #4920

    I’ve created a portfolio page and now whenever I add a new Post its displays the entire article with no read more. I would like it to display the way you have on your live preview of CUBIT…Part of the article with a “read more”

    Can you please advise how to fix this problem

    Thanks!

    #48131

    Hey,

    1) You can use the read more tag if you want to control the excerpt lenght/content.

    2) or you can modify the template a bit – wordpress will generate the excerpt automatically if you don’t use the excerpt field:

    In template_portfolio.php replace:

    <?php the_content('read more'); ?>

    with:

    <?php the_excerpt();
    echo "<a href='".get_permalink()."' class='more-link'>Read more</a>"; ?>

    #48132

    HI there,

    I have the same problem with blog section posts. I have replaced the code as per your mail above, but now there is text appearing at the end of the entry saying “write your sentence her”.

    Also, I have entered an image to appear as a thumbnail the same as the posts on your live demo, but there are not appearing. I would appreciate any help.

    Thanks

    /Deirdre

    #48133

    Hey,

    1) Do you use Cubit?

    2) Can you post a link to your website please?

    #48134

    Hi there,

    Yes it is the cubit theme – have already posted to the forum previously – please see http://www.pcheating.ie

    If you look under the Heating Hints & Tips (which is essentially the blog) you will see what I mean. let me know if you need FTP or WP access to find out more. Thanks for your help.

    #48135

    Can you create me an admin account and send me the login details to: (Email address hidden if logged out) – I’ll look into it.

    #48136

    Thanks Dude, I set an admin account up there for you now – you should get an email shortly with login and password. /D

    #48137

    I fixed it :) – seemed to be a leftover text in comments.php

    #48138

    Thanks Dude, that’s great. Would never have found that.

    But to answer the second part of my question – do you have any idea why the thumbnail pics are not appearing in the blog summary the same as the demo you have on Themeforest.? Example, see the first blog entry which has a pic uploaded to the section on the backend. I have added a pic in the size required but it’s not appearing in the summary for some reason. Would you mind taking a look when you get a chance please? Appreciate your help. Thanks /D

    #48139

    You can use this plugin: http://wordpress.org/extend/plugins/advanced-excerpt/ – it helps you to display images in post excerpts. By default wordpress strips html tags + images from excerpts/summaries.

    #48140

    Thanks Dude. I downloaded this plugin you recommended and configured the settings. Is there code that I need to insert into the blogpost itself in the backend as the excerpt is not appearing in the post for me to amend it and add the pic.

    Sorry for all the questions, but when I saw the live demo of the Theme, I assumed that this functionality was provided out of the box.

    Thanks for your help.

    /Deirdre

    #48141

    Thanks for your help Dude it resolved my problem perfectly. Another question how do i replace the three smalll header pictures on the main page, can’t seem to find them ?

    #48142

    In index.php delete following code:

    <div class="box_image"><img src='<?php echo $preview_pic_mainpage; $preview_pic_mainpage =''; ?>' alt="" /></div>

    #48143

    HI Dude,

    Can you pls let me know if there’s anything else I need to do to get the thumbnail pics working. I’ve done what you’ve suggested by installing the plug in but I can’t see anywhere to insert the pics. Is there something I need to do in the backend?

    Thanks

    /D

    #48144

    As far as I know the advanced excerpt plugin just avoids that wp strips html content. If your image is within the excerpt text it should be displayed automatically.

    #48145

    Ok thanks. I was expecting to see an excerpt under the main post but there was none there but seems to working ok now.

    /D

    #48146

    Glad that it works now :)

Viewing 17 posts - 1 through 17 (of 17 total)

The topic ‘Portfolio Page post showing full article with no read more’ is closed to new replies.