Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
  • #17099

    Hi all,

    I’ve got to the point where I’d like to add a second page on my front page for more portfolio items. I thought i’d sorted this by selecting Pagination to yes as below my portfolio items a link saying “page 2” is now there but when I click on it it just refreshes the page instead of showing me the remaining portfolio items in my portfolio…

    Anybody any clues as to how i’ve done something wrong here? I’m sure its prob an easy fix but I simply cannot figure it out, and after a while pulling my hair out I thought i’d ask for help!!

    Hope someone can assist, my website is at :

    Thanks a lot



    This sounds like a permalink issue. Go to Settings > Permalinks and check your slug/permalink rules (i.e. the structure %category%/%postname%/ is a good choice). Afterwards hit the save button one or two times and reload/refresh the option page. This will force wp to rewrite the permalink rules.


    Thanks Dude,

    I changed the permalink settings like you suggested, but now instead of the page refreshing like before it displays an ‘Error 404’

    Any ideas on this next step??



    This is the new page I am getting now after the permalink change… Not sure why?


    Update: While trying to solve the issue with pagination I ran into multiple error 404 for each separate page, and nothing I could do would get the separate page system to work on the frontage.

    After adding the permalink change above the frontpage now just refreshes the page without displaying the remaining portfolio posts on the front page.

    What am I missing?

    Hope someone has a moment to help me out here




    Hi Darren,

    First try setting your permalink structure to default and then save. Test out your pages and see if you get the basic functionality.

    Then try going through the basic wordpress troubleshooting for permalinks here:

    Permalinks can often be a tricky issue depending on the server setup but many hosts are familiar with wordpress and permalinks these days so even just talking to your hosting provider may help.

    Additionally, try disabling any active plugins you have running while trying to fix the permalink issues so that there isn’t any outside interference possible.




    Hi Devin,

    Thanks for your reply. I’ve worked my way through the troubleshooting and everything seems to be fine with all the points there.

    I also tried restoring the permalinks to default, and that had no effect.

    Finally I tried disabling the plugins I have and testing it again and again no luck!

    Are there any settings in the theme options / template builder sections that I should or shouldn’t have activated. Or is there anything in those parts that would cause a second page of portfolio items not show up?

    I’m just guessing now!

    Thanks again for your help, hopefully theres something simple being missed here…



    Hi Guys,

    I’m suffering with the same problem and none of these tips helped so far. I get a 404 after clicking page 2 or 3..

    I think this problem might have appeared since last week, after updating WordPress to the latest version (3.4.2).

    The website is (portfolio on front page).

    Please help us to sort this out.




    I thought it was just me with this problem!

    Have you made any changes to any of the theme builder sections or options of the theme in wordpress?

    Its really the only thing I can think of that i’ve changed since noticing this problem, but having not had separate pages before now I didn’t know if it was something I had done or like you mention a problem since the wordpress update….





    Try to set the portfolio page as static front page – go to Settings > Reading and select the portfolio page as the static front page.




    Hi Dude,

    My portfolio / front page is ready set as a static page. I’ve not changed that setting since I installed the theme…

    Any other ideas?! :)

    Thank you for trying!





    No, it just seemed to appear one day, without any changes to the site. It might have been caused after updating WordPress, but me nor the client didn’t change anything to the website or the theme builder.

    Dude, that didn’t help either. I’m pretty sure that cannot be the issue, since it worked before and I changed nothing but a WP update. Could you guys please check if something is changed within WP, which caused this conflict?


    I just did a quick test. I re installed wordpress and the theme in a new temporary directory, and re created a couple of pages in the portfolio part.

    The pagination worked fine in this when when my reading settings were ‘Front page displays latest posts’ But when I changed this to ‘Static page’ the pagination stopped working.

    So I copied every setting in my test install over to my actual website hoping that would correct anything wrong but still it didn’t work!


    If you actually choose the portfolio (or whichever page that has a portfolio) as the frontpage in the Settings > Reading, then the pagination won’t work. If you select “Front page displays latest posts” it will work. I talked about this issue in this post ( (Purchase code hidden if logged out) -working-in-the-frontage), since I need to select the portfolio as the frontpage (either way you will see the portfolio as the frontpage, but this way WordPress knows it “officially” and there won’t be any problems with other plugins, such as WPML) but I didn’t really get a solution.



    @darrennewbery + @tjeerd

    @darrennewbery You are using version 1.22 of the theme., Please update to 1.4 . If you made modifications to your template files. you can use to directly compare an unmodified version 1.22 to yours and see all your modifications on a character by character basis scanning the entire theme folder at once and comparing.

    @tjeerd Please update as well as you are using version 1.11 of the theme while 1.4 is out . If you made modifications to your template files. you can use to directly compare an unmodified version 1.22 to yours and see all your modifications on a character by character basis scanning the entire theme folder at once and comparing.

    After updating would you both please install this plugin It allows control over total number of posts/portfolio items etc.. on first page and then a separate value for all additional pages in pagination.

    @tjeerd – i see 12 items on your portfolio’s first page. Could you lower it to 4, and see if pagination starts working. If it does start increasing until you run into failure. If you get positive result please let us know what the cut off point for number of portfolio items on a page is before pagination breaks.

    There are two theories as to why this is happening , so we will examine the easier one first outlined here, even though it deals with categories, the concept is the same. ( (Purchase code hidden if logged out) -404-on-category-pagination )




    Hi Nick,

    Thanks a lot! Updating the theme did work. Problem was, the programmer I worked with bought the theme, so I did not see the updates in my downloads on Themeforest. Bought it (since I don’t work with this programmer anymore) and updated the theme. With success!

    The modifications were all done in the Angular menu > styling, including the css mods. Works perfect. Thanks again!


    Glad that solved the issue for you tjeerd :)



Viewing 17 posts - 1 through 17 (of 17 total)

The topic ‘Portfolio Pagination question… help!’ is closed to new replies.