Viewing 30 posts - 1 through 30 (of 38 total)
  • Author
    Posts
  • #2567

    I am getting the 404 error when clicking on the read more or the item heading in the portfolio “Tuition – Fun” page on my site (www.ourgolftour.co.uk). Read more in the bolg “News – Blog” page are working fine. I have looked at suggestions regarding this and nothing has yet sorted the issue. Assistance will be much appreciated.

    Regards

    Proud

    #38479

    Hey,

    If you find you’re getting 404 Page Not Found errors, you sometimes need to flush your rewrite rules.

    To do this, you need to load (but not change or save) you Permalinks settings page (WP Admin -> Settings -> Permalinks).

    #38480

    Hi Dude,

    Yes I have tried that without success.

    #38481

    Hey,

    please create an admin account and send me the login info to (Email address hidden if logged out) – I’ll have a look at it.

    #38482

    Dude,

    Account created, if you don’t get the email with login details let me know.

    Thanks

    Andrew

    #38483

    Hey,

    I looked into it but couldn’t get it to work. Another user some time ago reported that WP didn’t modify his htaccess file right – he had to edit it manually. Have a look at this page: http://codex.wordpress.org/Using_Permalinks

    Under the headline “Creating and editing (.htaccess) ” you’ll find some code which must be included in your .htaccess file.

    #38484

    Thanks for taking a look Dude.

    I looked at the .htaccess file but it had the suggested code already.

    I have change permalinks back to the default and it all works fine.

    Can not figure out why the portfolio items cause the 404 error if using /%category%/%postname%/ for permalinks. Has any one got any suggestions?

    #38485

    I have spent the evening trying many things without any success. I am using /%category%/%postname%/ for permalinks and all works except articles in the portfolio pages. If I revert back to the default ?p=123 then the the items on the portfolio page open fine. I want to use /%category%/%postname%/ but the 404 error is driving me nuts!

    Suggestions please?

    #38486

    Hey,

    the problem is that the permalink settings don’t affect portfolio permalinks. The only option which has an impact is the “Category base” option.

    If you open portfolio.php located in the folder “theme_options” you’ll finf following two code lines which are responsible for permalink generation:

    $slugRule = get_option('category_base');
    if($slugRule == "") $slugRule = 'category';

    and:

    'rewrite' => array('slug'=>$slugRule.'/portfolio','with_front'=>true),

    So if you enter a category base under Setting > Permalink this base will be used instead of the word “category”. The second code line appends “/portfolio” to the permalink. So whatever you change under Permalink settings (except category base) doesn’t affect your portfolio entries but only your blog posts and pages. I played with the code lines I posted above as well when I looked into your problem but I couldn’t solve it eventually.

    I hope James can jump in – maybe he knows what’s going on.

    #38487

    Thanks again for looking at it Dude.

    Yes, it would be much appreciated if James can take a look.

    #38488

    Hey,

    I agree this is a bit of a strange bug.

    Can you forward the WP Admin account info to support {at} jamesmorrisondesign {dot} com and I’ll have a look. Just out of interest, if you change the permalink structure, for example to month and name based do the portfolio links work?

    James

    #38489

    Hi James,

    No, only the default ( http://www.ourgolftour.co.uk/?p=123 ).

    Email sent with Account Details. If you do not get it let me know.

    Andrew

    #38490

    I have also found that if I click preview on a slider page it also give the 404 error which I guess is the same issue. Not sure if this is any help with solving the problem.

    #38491

    I have just done a clean install of wordpress 3.0.4 on my PC using a localhost (wamp) and loaded the Avisio theme with dummy data and changed Permalinks to /%category%/%postname%/ No plugins and I get the same 404 error described above on clicking read more on a Portfollio item yet clicking read more on a blog item works fine.

    I am not sure if James has had a chance to look yet but thought it worth reporting this.

    #38492

    Hey,

    as far as I know James was ill the last two weeks. I think he will look into it soon.

    #38493

    No problem this can wait. Just hope James is feeling better soon.

    #38494

    Hey,

    Sorry for the delay getting back to you, I was not feeling well for a while…

    The login you sent me doesn’t seem to work, I get no error message but I’m definitely going round a redirect loop. Could you check my login details and let me know if you get the same problem?

    If you change the permalink structure to month and name based does this have any effect on the Portfolio links?

    James

    #38495

    Hi James,

    Pleased to hear you are feeling better.

    I have set up a new password and emailed it to you.

    Changing the permalink structure to month and name based appears to work fine.

    I have now changed it back to /%category%/%postname%/ and it is still working!!!!!!!!!!!!!!

    Strange but hey if it is fixed.

    I will leave your user account in place so you can take a look James.

    Cheers

    Andrew

    #38496

    Hey,

    The problem was that the permalinks needed flushing (non technical version: WordPress needed to rewrite all the internal links so the right page is shown based on the URL requested).

    This shouldn’t be a problem anymore and you can change your permalink structure if need be.

    I’ve had look at the WP Admin section of your site and everything seems ok, feel free to remove my account.

    James

    #38497

    Thanks James.

    I will remove your account.

    Andrew

    #38498

    I am having the same problem, could you explain the procedure that you used to fix this bug?

    Thanks, Brian

    #38499

    Hi Brian,

    James asked me to change the permalink settings to “Month and name” which is one of the common settings, save and then see if that worked, which it did. I then simply changed permalinks back to my preferred custom structure /%category%/%postname%/ and saved that setting and it worked.

    Apparently the permalinks needed flushing which this procedure forced.

    I must add that I had tried previously changing back to the default and then back to the custom structure to try to flush the permalinks without success so it may be worth trying more than one of the common settings if it does not work first time.

    Hope this helps.

    Andrew

    #38500

    Thanks, that works good!

    Brian

    #38501

    Thanks Proud for helping us out.

    #38502

    No problem Dude, helping each other is how a community should work.

    #38503

    well, i have 404 issues – no custom permalinks are working at all – only default. it’s not just a portfolio issue. i am hosting this particular site at yahoo and have not used yahoo hosting before. i tried their automated wp install tool and that forced wp to be in a subdirectory and all permalinks for pages had ot have that subdirectory. so i deleted that and installed wp fresh via ftp in the root and everythign is working fine except custom permalinks.

    i suspect this is nothing to do with the theme (avisio) that i am using since it happens with 2010 also. but any troubleshooting ideas are appreciated. i have installed wp many many times on other servers without permalink issues. i tried setting all version of permalinks and back to default many times.

    again: pages load fine with default permalinks but any custom permalink structure gives the default yahoo 404 error.

    #38504

    Maybe WP can’t modify the htaccess file. Try do modify it manually by following the instructions here: http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

    #38505

    Help! My website http://manobyte.com/ is now getting 404 errors on the read more button for portfolio pages. When I change the permalinks to the default setting it works but it does not work any other way. I tried the flushing suggestion but that did not work.

    #38506

    Can you create me an admin account and send me the login details to: (Email address hidden if logged out) – I’ll look into it.

    #38507

    I looked into it and discovered that your theme files aren’t updated (i.e the portfolio php files or lightbox files). Please try to update again or manually via ftp. Another strange behaviour is that WP attaches index.php to the link path. I never have seen this before so I can only guess but I think it’s a problem with the htacees file. Make a backup of it and delete the content – WP will write the htaccess rules again if you save your permalink settings.

Viewing 30 posts - 1 through 30 (of 38 total)

The topic ‘Portfolio Read More 404 Error’ is closed to new replies.