Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #200511

    Hello,
    I like Angular very much! However since I integrated WPML for a clients website I have a lot of problems getting the thing working fine.
    Default language works fine, but as soon as I add 2 more languages these main issues happen:
    1. Portfolio page (Set to homepage) shows always same default language version(in my case DE) with the portfolio items pointing to the DE versions.
    2. Editing Portfolio items do not accept adding photos nor filling out the Meta Fields

    I’ve deleted everything to start from scratch(the other language versions), but this doesn’t help.
    I’ve spend quite some time on your support blog finding similar issues & solutions, but without success.

    Thank you for your rapid response,
    Jan

    #200513

    Another related problem:
    3. It does also NOT SAVE the Layout settings of a static page: Dynamic Template & Template page for the language. (jumps to empty field…)

    #200620

    Hi!

    Try following fix – open up angular/functions.php and replace

    
    if(isset($avia_config['use_child_theme_functions_only'])) return;
    

    with

    
    if(isset($avia_config['use_child_theme_functions_only'])) return;
    add_theme_support('avia_post_meta_compat');
    

    This code should force WPML to read the post meta data.

    Cheers!
    Peter

    #200682

    Thank you Peter for the fast repsonse!

    Unfortunately I already tried this without success… ;-(

    Is there a way I can “reset” the language versions of the angular theme? & the portfolio items
    I’ve changed/tried so many things that I don’t know if this influenced the functionalities…

    Jan

    #200716

    Hi Peter,

    I figured out that:
    Leaving the line
    if(isset($avia_config['use_child_theme_functions_only'])) return;
    in functions.php is fine
    but you need to uncheck all synchronising options in
    WPML Posts and page synchronisation
    so that Portfolio Meta Information can be edited

    However the main problem is now the Angular Main Menu:
    When checked one language-menu this language version is visible in all languages pages.
    The one that is checked remains “default” for the other language versions…

    thank you for your help!
    Jan

    #200737

    Hi Peter,

    The menu works after I synchronised them and deleted the old ones.

    The last problem that remains is the portfolio page as homepage for all 3 languages:
    When changing language menu and wdgets are fine, but it shows the portfolio part always in default language (DE). The link to the portfolio-item in respective language is right: http://paschu.com/wordpress/portfolio-item-fr/showroom-baindouche/
    is FR link, but jumps to DE version of the item
    website: http://www.paschu.com

    What can this be?

    Thank you for your help!
    Jan

    #201013

    Hey!

    Did you select the translated pages as front page on the theme option page? As soon as WPML is activated the theme will use separate options and templates for each language. The advantage is that you’ve full control over all options (you can use different portfolio pages for each language, you can use a different logo, you can set different widget areas, etc.) but the drawback is that you need to configure everything for each language. Use the language selector on the admin screen to switch from one language to another. You’ll notice that the “Angular” menu item (admin page) changes the name based on the current language (eg to Angular (EN) or Angular (DE), etc.). Select a language and go to Angular (XX) > Theme Options and configure all options for the language XX (i.e. the frontpage). Then switch to YY and go to Angular (YY) > Theme Options to configure the options for YY. Repeat this process for each language.

    Regards,
    Peter

    #202135

    Hi Peter,

    Thank you for the answer.
    The different Angular Theme option pages are already setup as you indicate, but this does not help.
    Please see paschu.com (I dis-activated FR & EN languages)
    Something with default language settings in the Angular theme… related to portfolio item?
    But I’am not a programmer…

    Let me know if you want to see the hidden pages and receive acces Backoffice!

    Best regards,
    Jan

    • This reply was modified 11 months, 1 week ago by  janglas.
    #202136
    This reply has been marked as private.
    #202201

    Hello again,
    I can not edit the Meta Information anymore from the “translated” versions of a portfolio item…
    nor add new images. in all language versions…
    thank you for your help!
    Jan

    #202208

    There seems to be a problem between the language versions of the portfolio items.
    This causes probably also the problem for viewing the portfolio on Homepage…

    Jan

    #202488

    Hi!

    Yes, please create me an admin account and post the login data as private reply.

    Best regards,
    Peter

    #202491
    This reply has been marked as private.
    #202513
    This reply has been marked as private.
    #204034
    This reply has been marked as private.
    #204052
    • This reply was modified 10 months, 3 weeks ago by  janglas.
    • This reply was modified 10 months, 3 weeks ago by  janglas.
    #204448

    Hi!

    No, as far as I know Kriesi didn’t look into it yet. I send him another notification and asked him to look into it asap.

    Regards,
    Peter

    #204552

    Hello,
    Thank you for the update.

    I managed to solve the problem with a complete reset of the WPML translations AND de-activating auto-translations settings. After relinking all posts/portfolio items/ pages to the respective language it seems to work!!
    (I will not use translation features of WPML anymore, because creates links between the items that are difficult to remove…!!!)

    However I still have a problem with:
    - showing the portfolio on homepage for the non-default languages (EN,FR)
    -> “Nothing found page”
    When changing the settings ANGULAR: Appearance/Customize: static frontpage: “HOME” for EN & FR it works only for the last changed language (The other languages do not work anymore…)

    Thank you
    Jan

    #204580

    Hello again,

    I solved the problem:
    - For normal pages & posts the theme Angular accepts the WPML-translations (inter-links)
    - For the portfolio-items NEVER USE WPML translations(links). Make separate items.

    Best,
    Jan

    #204718

    Hi!

    Great – I’m glad it works now.

    Best regards,
    Peter

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.