Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23753

    Hi there.

    I am experiencing an issue where I create a blog post in WordPress, and I can see it on my Blog page when I am logged in to WordPress.

    However, when I am not logged in to WordPress the post is not visible.

    The blog page: http://www.clairearroyo.com/blog

    The post does exist as it can be accessed via its direct link: http://www.clairearroyo.com/success-transform-awards-2013/

    The post itself should be visible:

    Status: Published

    Visibility: Public

    Published on: May 9, 2013 @ 7:26

    This is the third post on the blog. The first two posts do not have this problem and appear normally. The second post was published on 11 March 2013. The third post was created in the same way as the previous posts and no other changes have been introduced in the meantime.

    I am running WordPress version 3.5.1.

    Thanks

    Andre

    #121023

    Hi,

    You’re using the dynamic template, right? Check your Blog element, see if all categories under “Which categories should be used for the blog?” is selected. You can also leave it to show all categories.

    Regards,

    Ismael

    #121024

    Thanks for your response.

    Yes, I’m using the dynamic template (the responsive template).

    I’m afraid I cannot find the element with the option “Which categories should be used for the blog?”. Can you tell me where I’d find it?

    I’m not sure that the problem relates to the categories though, as the second post also shared the same category. I have set the post to “Uncategorized” (the default category) and the problem remains.

    Regards

    Andre

    #121025

    Yes, I think it’s a problem with the category because the “uncategorized” archive page displays just one post too: http://www.clairearroyo.com/category/uncategorized/

    Please try to assign the post to the “News” category too and check if it is displayed on the archive page: http://www.clairearroyo.com/category/news/

    If it’s not displayed on the archive page, delete the post and re-create it – maybe with a slightly different title if you created a page/portfolio item or category with the same title/name.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Post not appearing on blog page’ is closed to new replies.