Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17596

    Hi Guys,

    I just created a new post with a 3-image slideshow, and I noticed that it isn’t sliding automatically on the homepage blog. Once the post is opened into a single page entry it works fine. It’s just on the homepage.

    Any ideas why that is? I’m using Shoutbox v1.2

    You can see it here: http://sosgalgos.com

    It’s the post about Leena.

    Thanks

    rich

    #96055

    Hi,

    Try to set the “Autorotation active?” to Yes on the homepage itself.

    Regards,

    Ismael

    #96056

    Didn’t seem to work Ismael :/

    #96057

    Hey rumblefish,

    Try refreshing your W3 Total Cache page cache. It may have the home page version saved that does not have the autorotation active that you just changed.

    Also make sure to update to the newest version of shoutbox available from your downloads on Themeforest. There was a security update in to the framework and a small change to front page options as well.

    Regards,

    Devin

    #96058

    Hi Devin,

    I emptied the cache but it made no difference.

    Could someone try making a slider post on the default shoutbox theme (a blog post) and see if it does actually work, and it’s not just something wrong at my end? It’s not the end of the world, it’s just one of those annoying little things that you want to resolve!

    I’ve changed a lot of the php files in my site, so updating to new versions of Shoutbox always takes a long time. I want to be sure there are no more updates coming (someone mentioned unresolved iPad problems before with v13) before I update it all.

    Thanks

    rich

    #96059

    Hey Rich,

    After a bit of testing and checking past version I don’t think the autorotation has worked this way in a long time (if ever). Example is this post on the demo site: http://www.kriesi.at/themes/shoutbox/2011/03/31/this-is-a-nice-post/ .

    The wording for that meta area on the actual blog post also leads me to believe those may only be settings meant for the single page view.

    I’ll tag Kriesi on this post to check if this is the case or if this is a bug that needs to be looked at. If not, maybe we can get the description of the setting updated to reflect it.

    Regards,

    Devin

    #96060

    Hi Devin,

    Thanks for looking into it. Yes, that example you posted is a slideshow on a single page. My slideshow also runs automatically on a single page, it’s just on the homepage/blog it doesn’t (unless you click “play”).

    Maybe the default setting is “off” when it should be “on”. If Kriesi can look into it or provide a fix, that would be cool!

    Thanks for your help!

    rich

    Whilst we’re on the subject, I mentioned ages ago that some of the slider controls are actually in the wrong places in some posts. You can see on that example you posted. The controls should be aligned right, but they are floating slightly to the left of the edge of the post. It’s easy to fix with css, but it should really be corrected in the theme if it’s going to be updated again.

    #96061

    I think the controls alignment is actually on purpose as part of the design. Its not a single container with a bit of incorrect padding but each one of the buttons has specific positioning to be where it is.

    #96062

    Hey both of this is default behavior. You typically want slideshows to autorotate on single pages but most of the time its absolute overkill if you are located on the overview page and every post has a set of images that autorotates. Drives me as a user nuts.

    If you really want that you can change that by opening includes/helper-slideshow.php, and search for


    if((avia_is_overview() || avia_is_dynamic_template()) && !$this->force_slider)

    around line 92. change it to


    if((avia_is_dynamic_template()) && !$this->force_slider)

    and it will accept the setting that you apply in your backend

    PS: buttons are not mis aligned, thats a styling choice ;) Sometimes I want to escape those boring patterns with little changes…

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Post Slider not sliding on Home Page’ is closed to new replies.