Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #19058

    Hi, I have a big problem that I tried to solve myself reading topics in this forum and WPML forum, but I can’t.

    I have problems, as many others with permalinks activated and WPML activated. It works for profolio but not for pages or products. I’ll explain you witch actions I did to solve the problem.

    1- I ask in this forum and an agent give me a wordpress permalinks protocol about .htaccess and server. I’ve checked all the information and the server and htaccess are ok

    2- Then I activate and deactivate all plugins in my site. I discover If WPML is desactivated permalinks work ok.

    3- I search in kiresi forum and WPML forum solutions for this problem. And I found the solution. One person with the same problem solved the problem adding this code to functions.php (flush_rewrite_rules( false );). I aded this code and the pages starts to work with permalinks and WPML activated. Then I was so happy but was not the end

    4- Then I discober that the pages work but the products don’t work. When I try to go to a product with permalink activated I have 404 error.

    5- I try to find the solution. In WPML forum it says I have to install a new version of woocomerce pached for WPML developers. I did it but it doesn’t work. I have the same problem. Permalinks with WPML activated doesn’t works.

    Please, I’m not in the first steps. And I see there are lot of people with problems between WPML, woocommerce and permalinks. I tried to solve this in all ways before I write this post, so please don’t throw balls out and please help me to solve that problem as soon as possible. This website had to go life past 31 december but still not life only for permalinks problems.

    I think the best is to give to you ftp access and you can check what happens.

    Kinds Regards

    #102000

    Hi, think I found the solution but I need some help.

    - With WPML, permalins activated porfolio items, post and products works but pages doesn’t works (error 404)

    - If I ad this code at the end of functions.php:

    flush_rewrite_rules( false );

    With this rule the pages work ok but products and porfolio items doesn’t work.

    So probably the solution is put this rule only affecting to pages. But I don’t know how to do it.

    #102001

    Hi!

    You can try to use conditional tags: http://codex.wordpress.org/Conditional_Tags – i.e. the code would look like:

    if (is_page()){
    flush_rewrite_rules( false );
    }

    Regards,

    Peter

    #102002

    Hi Dude. I add this code at the end of functions.php but this create a error. The pages don’t load.

    I check with dreamweaver and in the first line:

    is_page(){

    dreamweaver says there is a syntax error

    So, I delete the code and the pages work again

    ¿Do you know with syntax error can I have in this first line of the code?

    #102003

    Hi,

    I think the editor stripped out a part of what dude pasted. please try dude’s code again.

    Thanks,

    Nick

    #102004

    Hi Nick. I pasted the code again. And now the code is ok. no syntaxis errors but don’t work to solve my problem.

    1- When I put Dude’s code and activate permalinks. Porfolio and products work but pages doesn’t work. Is the same that happens without any code aded.

    2- If I I put only the code without the conditional:

    flush_rewrite_rules( false );

    The pages work but It doesn’t work porfolio and products. Just the opposite

    I think dude’s code is not working because the page has the same response as leave it original. I read the link that dude’s give in their message and provably don’t work because this reason:

    Warning: You can only use conditional query tags after the posts_selection action hook in WordPress (the wp action hook is the first one through which you can use these conditionals). For themes, this means the conditional tag will never work properly if you are using it in the body of functions.php, i.e. outside of a function.

    #102005

    Hi,

    Please set up a temp account for me so that I can get you back on track. My email is (Email address hidden if logged out)

    Thanks,

    Nick

    #102006

    Hi,

    Have the same problem when pretty permalinks enabled then woocommerce cart and products pages do not show up. also using all the latest WPML, woocommerce and added woocommerce multilingual plugin.

    What is the right solution?

    #102007

    Hi,

    What is the url to the site. You can use goo.gl to mask the url.

    Thanks,

    Nick

    #102008

    offline instant wordpress.

    #102009

    Hi,

    I remember you from before but you had a site up live. Would you put this one as well live, so that we can help you.

    Thanks,

    Nick

    #102010

    ok ill come back to the issue after its uploaded.

    #102011

    Hi,

    Try this. When WPML installs, dont touch any settings and go to add new page. fill out all the fields and upload the image/slideshow, then click the two check boxes for duplicate, then save the page. at this point you should get right above save button another checkbox which asks if you want to duplicate (this time its alone) and when you check it a button appears bellow it.

    When you click it nothing seems to happen. Click Update button and then switch to the ‘second language” (don’t click the checkboxes on bottom that ask if you wish to copy, ignore, or translate) Now on translate page, you should have a complete duplicate of the original page including all the images etc and settings. On the translation page just click update when you enter it. On the very top right corner of translation page you will see WPML asking if you want to stop synchronizing the translation to the original and you click that button. Now go and test if pages are found.

    If they are not, please install this plugin http://wordpress.org/extend/plugins/rewrite-rules-inspector/ .. It will create a link in the Tools menu > Rewrite Rules. Now the first time you enter that page (rewrite rule plugin), keep your eye on the total number , if any are red, location : other.

    Now copy the url to a page on the site that is not loading (showing 404) and paste the url of that page into the text box on top of the rewrite rule page and see if there is a rule that matches. Flush the rules and compare how the new regeneration list looks with the original one the first time it loaded .. same number of rules, etc…

    Nick

    #102012

    hi, my site is up and runnig, but there is still the problem with permalinks they dont display correct and give me 404 error.

    what setting should iwrite in wordpress permalinks settings?

    and what settings in WPML permalink settings?

    http://www.maxolen.ee

    #102013

    Hi,

    Please try to flush the permalink settings a few times. Sometimes it takes a few tries before they work.

    Regards,

    Ismael

    #102014

    404 error comes back, every time I save wp or propulsion theme settings.

    then I have to to the foolwing:

    deactivate WPML multilingual CMS plugin

    go to wp permalink settings and save couple of times:

    then the page starts to work again.

    and then i activate the WPML multilingual cms again.

    It works until the next time i save some setting in wp options or in theme propulsion options.

    #102015

    You can try to set the file permissions of the htaccess to 0444 – then wordpress can’t rewrite the rules. I’m not sure if this will fix the issue though because the slug rules rewrite rules are stored in the database.

    #102016

    I did as you advised (444) but it does not help.

    #102017

    You can also remove the “permalink flush” function from the theme settings file. Then wp won’t flush the permalinks every time you save the settings. Open up wp-contentthemespropulsionframeworkphpfunction-set-avia-backend.php and remove following line:

    add_action('wp_loaded', 'avia_flush_rewrites');

    #102018

    Warning: Cannot modify header information – headers already sent by (output started at /www/apache/domains/www.maxolen.ee/htdocs/wp-content/themes/propulsion/framework/php/function-set-avia-backend.php:1) in /www/apache/domains/www.maxolen.ee/htdocs/wp-content/plugins/woocommerce/classes/class-wc-session-handler.php on line 63

    then the page wont work.

    #102019

    Hey!

    Very strange – try this file: http://www.mediafire.com/view/?n88x0q7xbshiseq

    Regards,

    Peter

    #102020

    thank you-thank you, Peter

    Just changed the file and now it seems to work!! what did you change?

    #102021

    SAGA continues:

    now it seems the same problem is with saving woocomerce settings. If I make some changes in woo commerce settings I get the 404 page not found error in all pages besides shop catalogue. Then I have to to the trick again with with WPML off and save permalinks and WPML on again then its cool. There is no problem with other setting saving beside the woocommerce.

    It seems there is some kind a conflict between the WPML _ wp _ and woocommerce.

    More..

    the error

    #102022

    In this case I’d recommend to contact the WPML devs – it seems like WPML can’t rewrite the permalink rules on your server and I don’t know why it doesn’t work. A handful of other users have a similar problem and it it’s probably server related.

Viewing 24 posts - 1 through 24 (of 24 total)

The topic ‘Pretty URL at products not working with wpml activated. Propulsion’ is closed to new replies.