Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #21328

    Hi!

    I have a problem with the Replete Theme which gets me mad:

    Link to portfolio items get broken, and to solve it I have to disable WPML plugin, save permalink settings (which are defined to “Post Name” ) and enable WPML again. I don’t know what is the cause of permalinks for portfolio items getting broken, but it is really anoying to check it all the time and repair it. Mainly because the site is actually under production.

    Please, I would appreciate any help you could provide me.

    Best regards,

    Marc

    #111388

    Did you try to activate WPML first, then go to Settings > Permalinks and hit the “Save” button. This will flsh the permalinks and WP should rewrite all rules (including the new page slug which is required for WPML). Make sure that you’re using the latest version of Replete (v1.3.1).

    #111389

    Thank you Dude,

    If I save the permalink after WPML activation I get the error on portfolio items. I have to disable WPML, save permalinks and activate WPML.

    Thank you.

    P.D. Have last version of Replete

    Marc

    #111390

    Hi,

    Are you using WooCommerce? At the moment the additional plugin you need (WooCommerce Multilingual) http://wordpress.org/extend/plugins/woocommerce-multilingual/ will not work with the 2.x version of WooCommerce but any day we are looking forward to its release. For the moment there will be minor inconveniences like this as the plugins stabilize. It is hard to help without seeing the site. Do you have a url? If you want it private you can use http://www.goo.gl to mask it.,

    Thanks,

    Nick

    #111391

    Hi Nick,

    Yes, I’m using WooCommerce and WooComemrce Multilingual. I will keep alert for Multilingual updates.

    You can find the website in http://goo.gl/Ohecx You can find the Portfolio items into the “ideas” folder. I have noticed that permalink break every time I save someting in the Avia Framework (Theme options or Template Builder)

    Thanks for your help!!!

    Marc

    #111392

    Hi Marc,

    WooCommerce Multilingual does not work with WooCommerce version 2+. Having a plugin that doesn’t work activated is not a good idea. WPML and WooCommerce have not released WooCommerce Multilingual. That means that if you want to stop experiencing errors, please downgrade to WooCommerce 1.66, which is the last version supported by WPML . Please read the following : http://wpml.org/2013/03/woocommerce-multilingual-1-5/ and check that the version numbers you are using are supported.

    I installed latest Replete and used last wpml and last woocommerce without woocommerce multilingual. I had no issues. Please make sure that you also configured the copy/translate/do nothing radio buttons https://www.diigo.com/item/image/318y0/hkor … Because what is most likely happening is that you have a configuration where the translation copies the settings so after you set them, they disappear because it was not set to translate but was set to copy.

    Thanks,

    Nick

    #111393

    Dear Nick,

    Thank you for you patiente and kind attention. I have been following your advices: have disabled the WooCommerce Multilingual plugin, and have checked WPML radio buttons as you suggested in the image attached. However, my issue still happens:

    “Potfolio items” Permalink break every time I save someting in the Avia Framework (Theme options or Template Builder).

    Do you have any other idea what may cause this problem?

    Thank you again.

    #111394

    Hi,

    Besides the fact that the current version of WPML is not compatible with WooCommerce 2.x until an update of WooCommerce Multilingual is released (which is needed to get WooCommerce and WPML to work correctly, and without which all kinds of problems should be expected) I am at a loss. In the future, please make sure that you never ever hit the update button on any plugin on a live site before making certain that everything works on your development area. There is absolutely no reason for anyone to update wordpress framework, a theme or a plugin as soon as it is released.

    Like a fine wine, sometimes its better to let it sit a few month and let other adventurous types of people pave the way by uncovering and finding fixes for such problems so that you don’t have to. I would recommend for you to keep using woocommerce 1.66 until WPML/woocommerce sort things out.

    or

    you can try installing this plugin http://wordpress.org/extend/plugins/rewrite-rules-inspector/ .. It will create a new menu item under Tools > Rewrite Rules. When you change your permalinks. Make sure you go here and flush them. If a url is not rewriting. you also paste the url into this page to see what rewrite rules (if any) exist for it. If you see anything in red on the new rewrite rules page, make sure to flush the rules. For me when I flush them, the rules do not return in red and all is well.

    How does your Settings > Permalinks page look like. ( http://www.clipular.com/c?3318005=oi1eEio7SeZrHEtqL8AaK52_6NY ) Please take a snapshot of the page and post on imgur.com. or elsewhere.

    Thanks,

    Nick

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Problem Replete theme with WPML – Permalinks break’ is closed to new replies.