Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #218897

    Dear Kriesi,

    Your themes are great, I’ve bought Angular and Coherence. However, I’ve been having some trouble with Coherence.

    The most important problem is the following: I’ve been using Adsense Ads on my website to earn some income. However, some ads aren’t displayed correctly. There’s a script somewhere that adds a height or width that’s below the actual ad height or width. This causes ads to be cut off.

    Now, I’ve used about 5 different plugins to insert the Adsense ads, I’ve deactivated all plugins as well, to check if any of those are responsible. The code that’s being output is:

    <iframe width="300" height="250" frameborder="0" marginwidth="0" marginheight="0" vspace="0" hspace="0" allowtransparency="true" scrolling="no" onload="var i=this.id,s=window.google_iframe_oncopy,H=s&&s.handlers,h=H&&H[i],w=this.contentWindow,d;try{d=w.document}catch(e){}if(h&&d&&(!d.body||!d.body.firstChild)){if(h.call){setTimeout(h,0)}else if(h.match){try{h=s.upd(h,i)}catch(e){}w.location.replace(h)}}" id="aswift_1" name="aswift_1" style="left: 0px; position: absolute; top: 0px; width: 728px; height: 89.99876375324514px; "></iframe>

    With the corresponding css:

    element.style {
    left: 0px;
    position: absolute;
    top: 0px;
    width: 728px;
    height: 89.99876375324514px;
    }

    URL: http://www.ouderwetsbreien.nl/leuke-truien-breien-voor-de-hond-misschien-zelfs-de-kat/

    I’ve added the following custom CSS:

    ins.adsbygoogle ins ins#aswift_0_anchor iframe#aswift_0 {
    	height: 250px !important;
    }

    What script is causing this? And how can I solve this? I know there’s probably a way with css, but I can’t the specificity right.

    On this WP install I have the following Plugins installed: Akismet, Google Analytics by Yoast, Jetpack, Quick Adsense, TablePress, WordPress SEO.

    Yeah I know, you’ve added a shortcode for tables, but I like the sorting function of TablePress.

    So can you help me?

    Second problem is related, the same happens to Youtube movies. I removed all Youtube embedded links, because it was driving me crazy.

    Theme Version of Coherence is 1.5

    Thanks in Advance!

    • This topic was modified 7 months, 2 weeks ago by  nipoma.
    #218900

    I managed to overlook something, sometimes aswift_0 is being output and sometimes it’s aswift_1. I’ve added both to the custom CSS and it seems to be working now.

    Really curious which script outputs thoses styles though!

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘Problem with element.style’ is closed to new replies.