Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15358

    Hello enveryone!

    I don´t know why but, at the begin, in the main page, I could see some full size articles and below little articles. Unfortunatly, now I cannot. I installed a plugin `Advanced Excerpt´ to control the size of text of post in the main page. I guess, more less from that moment, I can´t see the little articles.

    And of course I was checking: General Options > article apparence > …

    Where I have tried several options.

    Any ideas???

    #87181

    Hi antoniocansinos,

    Try to disable that plugin, that might have caused some plugin conflict as you said that the little articles were gone after you have enabled it. To change the size of the excerpt, open functions.php and below it add this code:

    function custom_excerpt_length( $length ) {
    return 20;
    }
    add_filter( 'excerpt_length', 'custom_excerpt_length', 999 );

    This will return only 20 words, just replace it. (Default is 55 words). Then in your WP Dashboard, go to Settings > Reading > For each article in a feed, show and choose “Summary”. Hope this helps. :)

    Regards,

    Ismael

    #87182

    Hi Ismael,

    Strangely it doesn´t work. But I can see the small articles in the second page. And I have configured it, for example, to show small articles before 2, after 3, after 4… So, I think, maybe I took the code of the main page maybe.

    Any other idea?

    #87183

    Hi antoniocansinos,

    That’s really weird. Try to get the latest update of the Newscast theme(newscast_2.0.3) in Themeforest and check if it fixes the issue.

    Regards,

    Ismael

    #87184

    Hello Ismael,

    I solved it. I have some plugins and uninstalling all of them it didn´t fix. So, I take a code compare plugin for Notepad++. This is the URL, maybe someone is interested:

    http://sourceforge.net/projects/npp-plugins/files/ComparePlugin/

    After choose: Compare 1.5.6_Unofficial > Compare_1_5_6_UNI_dll.zip

    I compared both codes, the original Newscast code (from Index.php -Main Index Template in WordPress-) and my code in WordPress. I found the different in line 144.

    My code in WordPress had: $limit–;

    The original code has: $fullsized–;

    I changed it, from the origina Newscast code to my code in WordPress and it fixed.

    I don´t know how it changed or what, but… It´s ok.

    In any case, thanks Ismael for your help. This forum is the best, and you are helping us a lot.

    Bye!!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Problem with half sized articles below’ is closed to new replies.