Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #22198

    Hello,

    I’ve a little problem with jquery, suddenly the plugin lightbox evolution ( http://codecanyon.net/item/lightbox-evolution-for-wordpress/119478 ) that i installed in the site stopped working, i also tried other gallery plug in but nothing worked so far.

    The support of one of this plug in (all in themeforest) told me:

    Hi,

    The problem is a jQuery problem. To solve it please delete this line:

    <script type=”text/javascript” src=”http://www.floccaturasaplast.it/wp-content/themes/cubit/js/jquery-1.3.1.min.js?ver=3.3″></script>

    The proper way to load jQuery into your theme or plugin is the following (your add it into your theme’s header):

    if (!wp_script_is(‘jquery’, ‘queue’)){

    wp_enqueue_script(‘jquery’);

    }

    After some search i found that line in the function page, deleted it and put the other line of code in the header.php file at the end of the head but the problem remain so… what can i do?

    Thanks in advance for any help

    #114849

    I add that i was wrong, i didn’t find the:

    <script type=”text/javascript” src=”http://www.floccaturasaplast.it/wp-content/themes/cubit/js/jquery-1.3.1.min.js?ver=3.3″></script>

    line :(

    #114850

    Open up functions.php and delete following code:

    $my_jquery = get_bloginfo('template_url'). "/js/jquery-1.3.1.min.js";
    wp_deregister_script( 'jquery' );
    wp_register_script( 'jquery', $my_jquery, false, '' );

    This will remove the custom jquery script and WP will load the standard jquery script which is bundled with WP. However there’s still a good chance that it won’t work because Kriesi didn’t update the custom.js script for a while and I’m not sure if it’s compatible with jquery 1.8 (jquery version which is bundled with wp3.5) or 1.9.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Problem with lightbox’ is closed to new replies.