Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #3027

    Hi, I tried to insert a photo to my post using the “Set featured image” option. I can see the image while I’m in “Edit Post.” But the image doesn’t appear in the homepage slider and in the post itself when I view the site.

    Here are links to my homepage and the post:

    http://linuxforartists.com/

    http://linuxforartists.com/2011/02/07/how-to-turn-ubuntu-into-a-multimedia-studio/

    Here’s the image I wanted to insert:

    http://www.flickr.com/photos/ranchrecords/4174872090/

    The good thing is that the image is there. I can see that it’s taking up space in the post and the slider is trying to load the image. But it’s not appearing.

    If you could please give me a step-by-step procedure, I would appreciate it. Thanks for your help.

    #40307

    Hey,

    When you set the featured image, did you use the http://www.flickr.com/ URL you posted above or directly upload a copy of the image?

    WordPress resizes the image to several different sizes to display the image efficiently in different areas (rather than use a memory heavy dynamic resizer) – as far as I know this isn’t possible for external URL’s.

    If you did use the http://www.flickr.com URL, please try saving and uploading a copy of the image, if you didn’t further investigation will be necessary.

    James

    #40308

    Hello James,

    From that Flickr URL, I clicked on the photo, went to “View all sizes,” and chose “Medium 640″ and right-clicked “Copy Image Location.” I pasted that URL into the WordPress “add an image.” I’ve done that technique many times with another WordPress blog I write for, http://www.vagablogging.net.

    I tried the way you suggested. I saved a copy of that recording studio image to my computer. Then I went to “add an image” again, then selected the image from my computer.

    Sadly, the result was the same. On the homepage, the image in the slider looks like it’s loading, but the image never appears. In the post itself, there is just a blank space where the photo is.

    I wonder what I’m doing wrong? Please advise.

    #40309

    Hello James,

    I was just wondering if there was any update on how to insert images? I tried linking and uploading, and neither worked. Is there some setting I need to change? Or is there another method I’m supposed to use instead?

    #40310

    Hey,

    Sorry for the late reply, this topic slipped past me somehow.

    I’ve looked at the page source and no image code is specified. Could you set me up a WordPress admin account and email the details to support {at} jamesmorrisondesign {dot} com with the subject:

    Kriesi | Newscast | Missing Slider Images

    and a link to this topic and I’ll take a look at what’s going on.

    James

    #40311

    I have this same problem. I have both downloaded the images to my computer and sent a direct link to the image tried both ways from the source that I got the image and a link to the image from my own url and the slider still will not pick up the image. Then I tried the other way to use the image as a featured image but in other post it says that the button for use as featured image is next to the insert into post button but it is not! I have been playing with this slider for a couple of hours yesterday and most of today both going through this forum for answers and trying to do myself. I run a business from this website so I really need some help here!

    Thanks,

    Bryce

    #40312

    I figured it out.

    #40313

    Glad that you solved the problem :)

    #40314

    Can you tell us what the solution was.

    I am new to Newscast and have the same problem with the slider not displaying images

    #40315

    Did you add featured images? Go to your post/page editor and search for the featured image option on the right side.

    #40316

    yes we did add featured image to some of the posts.

    it seems like we are missing a plugin ,

    but we followed your doco closely

    unbuntu 9.10

    wordpress 3.05 ( we tried 3.1 but went back to 3.05)

    firefox 3.6.13

    #40317

    ps it works on a macbook osx but not ubuntu ??

    #40318

    It seems like newscast works fine with a new install of wordpress and a clean database.

    In the first case we had tried every available theme before we tried newscast and the accordion didn’t work

    So it seems some content in the database upset the newcast theme

    Would love to know why but its working so never mind

    #40319

    Glad that you solved the problem :)

    #40320

    The thing that fixed the problem was

    Settings/Reading /Your latest posts/

    It had been set to a static page form another template

    #40321

    I hadn’t realized that this thread had continued without me. Congratulations to those who solved the problem. Could bryce84 outline the right steps to inserting an image?

    Alas, I’m still having trouble. :(

    I tried using “Featured Image > Set Featured Image.” I linked to the Flickr photo and I got the same result. The photo is taking up space in the blog post and I can see the caption, but not the actual photo.

    Here’s the link to the post:

    http://linuxforartists.com/photo/how-to-turn-ubuntu-into-a-multimedia-studio/

    The photo I want to insert:

    http://www.flickr.com/photos/ranchrecords/4174872090/

    As nra19 suggested, I went into the Reading Settings. I have “Front Page displays > Your Latest Posts.” So that seems okay.

    I’m using Firefox 3.6.13 and Ubuntu 9.10, if that’s relevant. The photo appears in Google Chrome 8 and Opera 11, so that’s good news! Has anyone found a way to get their photos to appear in Firefox?

    Hmm, the other problem is that my photos aren’t appearing in the slider – on all 3 browsers. I have it set to “News Slideshow.” I’ll look through the support forum first before posting a new thread on that problem.

    You guys have been really helpful!

    #40322

    Hey,

    I think the image display problem is caused by the display:block attribute. Try to replace following line in custom.js:

    images = imageContainer.find('img').css({opacity:0, visibility:'hidden',display:'block'}),

    with:

    images = imageContainer.find('img').css({opacity:0, visibility:'hidden',display:inline'}),

    #40323

    Progress! I edited the display:’block’ attribute like you said. In Firefox, the photos now show up in the posts:

    http://linuxforartists.com/photo/how-to-turn-ubuntu-into-a-multimedia-studio/

    http://linuxforartists.com/photo/pinta-like-gimp-but-friendlier/

    Hmm, but the photos still don’t show up in the slider on the homepage:

    http://linuxforartists.com/

    Any suggestions? You’ve been super-helpful.

    #40324

    The source code:

    <div class="featured featured1">
    <a href="http://linuxforartists.com/photo/pinta-like-gimp-but-friendlier/">
    <span class='feature_excerpt'>
    <strong class='sliderheading'>Pinta: Like Gimp but Friendlier</strong>

    <span class='sliderdate'>Feb 13, 2011</span>
    <span class='slidercontent'>
    Pinta is a new program that aims to be a clone of Microsoft’s popular Paint.NET. (“Pinta” is an anagram of “paint.”) This is great news </span>
    </span>
    </a>

    </div>

    doesn’t show an image url (so the slider can’t display an image but just text). Maybe it’s related to the featured image function ehich doesn’t support external images (i.e. provided by flckr). Try to upload an image to your media gallery and try to use this image as featured image (for a slider entry).

    #40325

    Yea! At long last the photos are appearing! In both the slider and the posts:

    http://linuxforartists.com/

    Thanks to James and Dude for all their help.

    I’ll write out the steps for setting the slider photos, for the benefit of anyone else reading this.

    Find a photo you like online. Right-click “Save image as” and save it to your desktop. (I won’t get into photo rights, but you should only use photos you’ve taken yourself or photos under a “Creative Commons” license. Always give credit to the photographer.)

    Now go to your post.

    On the bottom right, you’ll find “Feature image.” Click on “set featured image.” You should automatically be on the “From Computer” tab. Click “select files.” Choose the photo you saved to your desktop. Click “OK.”

    The photo should have uploaded and you’ll see it in the window. Scroll down to the bottom and click on “use as featured image.” It will take a few seconds to load.

    When done, click on “Save all changes.” Close that window.

    Should take you back to your post. Click on “publish” (it will say “update” if you’re revising a post).

    Now go to your homepage. The photo should appear in the slider.

    Dude or James can correct me if I missed any steps. Hope this helps!

    I was wondering, is there a way to edit the size of the featured photo in the post? I like the photos to be thumbnails on the homepage. But in the individual posts, I want the photos to be bigger and with captions. Like if I did a regular “insert photo.”

    I tried using “Full size pic or video for Lightbox.” The only problem is that I end up with two images in the post, which looks weird:

    http://linuxforartists.com/photo/how-to-turn-ubuntu-into-a-multimedia-studio/

    Can you suggest a solution where there’s only one full-sized photo in the post, it appears in the slider, and appears as a thumbnail on the homepage? Sorry for my ignorance.

    #40326

    Hey,

    Awesome, I’m glad you got this resolved in the end!

    James

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Problem with photo not appearing in post and slider’ is closed to new replies.