Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #10786

    I have a problem with my shop page

    I Have set on front page display 6 products,

    when I have 12 products, my shop page is displaying 6 products only but link or menu to the next page.

    as it can be seen here : http://www.hip-island.com/

    How can I fix that? Or is not an existing function?

    Thanks

    #69396

    Hey!

    I think you can adjust the number of items per page by going to WooCommerce > Settings > Pages and search for the “Column and Product Count” options.

    Regards,

    Peter

    #69397

    Hello,

    This is exactly what, I have done, and where the problem is : if I adjust it to for ex :6 products per page : I cannot see a next page link to products number 7 to 12 .The only way to see all the products, is to set it to all. But what I want to do, is to have numerous pages of 6 products.

    Thanks

    Patrice

    #69398

    Hi Patrice,

    Flashlight has pagination for the product pages by default. It looks like maybe a plugin is preventing the default functionality. Try turning off all plugins besides WooCommerce and see if the issue is resolved.

    I’d also recommend updating the theme to the most recent version as there have been a number of fixes since 1.4. You can download version 1.6 by going to your Downloads in Themeforest and re-downloading the theme from there. Then install the theme in the same you have done previously (either FTP or by uploading the zip). If you have done any customization to the theme files directly, backup those pages and check the change log to see if you need to re-add them in or if you can exclude them from the update.

    Regards,

    Devin

    #69399

    Hi,

    I have tried everything you told me to do, even with only woocommerce plugin activated, and after changed version of flashlight : no result,

    I even tried too, to erase all custom css in flashlight (in case may custom changes would erase this pagination thing)

    still no result!

    But : last min. miracle, by deactivating option : woocommerce>settings>general>Styles and Scripts>Output WooCommerce JavaScript in the footer : It is working back!

    Many thanks for your help

    Patrice

    #69400

    Glad its working for you now Patrice. Thank you for letting us know the fix that worked for you. I’ll report the conflict with Kriesi as maybe it needs to be turned off view the theme config files to prevent this kind of thing for anyone else.

    Regards :)

    Devin

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Problem with shop page not displaying link to products pages.’ is closed to new replies.