Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #19349

    I’m having problems getting the background image for specific blog posts to be different than the default image set in the Flashlight general settings.

    I upload an image for each blog post using the Image Gallery upload button, and go through the save process. However, frequently the image then disappears from the Image Gallery preview section after I “Save Draft” of the post. That’s the first problem. Any ideas how to fix this?

    The second problem is that in some instances, but not all, when I set the image gallery image for a specific blog post, that image does NOT become the background image for that posts page. For example:

    http://jeffhenry.me/2013/01/happy-new-year/ – The image of the post, set as featured image and added to image gallery, appears as the background for the page.

    http://jeffhenry.me/2013/01/the-holiday-birds-nest/ – The image of the post, again set as featured and added to image gallery, does NOT appear as the background for the page.

    I’ve tripled checked that everything is the same for both posts, but still the background image reverts to the default. In fact, for most of my blog posts–but not all–I can’t get the image gallery image to be the background image.

    Any advice of fixing this problem would be appreciated.

    Thanks,

    Jeff

    #103366

    Hi Jeff,

    As a quick aside, the WordPress “Featured Image” setting doesn’t effect the Flashlight theme settings at all. The theme uses its own gallery alone.

    For the actual setting of the Image Gallery images, there may be a plugin conflicting with the theme. I know Jetpack specifically tends to cause issues depending on the extensions being used with it but try deactivating all plugins and then adding images again.

    Additionally, try fully publishing a post to see if that helps save the image gallery images to the meta box.

    Regards,

    Devin

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘Problems with Blog Post Background Image’ is closed to new replies.