Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #15822

    Hi,

    Thanks for the fantastic theme (Coherence). And the support forums have been so helpful so far. You guys are great!

    1. On Firefox (many versions ranging from 3.6.13 Mac OS X 10.7 to version 15 on OS X 10.8 and version 15 on Win7), when I roll over the Facebook “Likes” link on any post, the link text disappears, rendering it non-clickable (as well as invisible).

    The FF error console gives me: Error: uncaught exception: [Exception... "Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]" nsresult: "0x80570018 (NS_ERROR_XPC_BAD_IID)" location: "JS frame :: chrome://webdeveloper/content/tools.js :: webdeveloper_isJavaEnabled :: line 4" data: no]

    2. On Safari (5.1.3 on OS 10.7 and iPad (very recent)) and Chrome (Mac OS 10.7 versions 19 and 21, OS 10.8 version 21), rolling over the Facebook “Likes” link on any post, the FB Like click registers and the counter eventually updates, however, the little pop-up “window” that shows your FB profile pic is very cropped so that you can’t see whatever content is supposed to show up there. I see it on the Coherence and Choices demo themes, so not just on my WP install. Chrome’s javascript error console give me this message upon click:

    Unsafe JavaScript attempt to access frame with URL http://static.ak.facebook.com/connect/xd_arbiter.php?version=10#channel=f2398a8f4c&origin=http%3A%2F%2Fwww.kriesi.at&channel_path=%2Fthemes%2Fcoherence%2Fblog%2F%3Ffb_xd_fragment%23xd_sig%3Df3525c782c%26 from frame with URL https://www.facebook.com/plugins/like.php?channel_url=http%3A%2F%2Fstatic.ak.facebook.com%2Fconnect%2Fxd_arbiter.php%3Fversion%3D10%23cb%3Df3e8da869%26origin%3Dhttp%253A%252F%252Fwww.kriesi.at%252Ff2398a8f4c%26domain%3Dwww.kriesi.at%26relation%3Dparent.parent&extended_social_context=false&font=arial&href=http%253A%252F%252Fwww.kriesi.at%252Fthemes%252Fcoherence%252F2011%252F12%252F17%252Fkriesi-at%252F&layout=box_count&locale=en_US&node_type=link&sdk=joey&send=false&show_faces=false&width=250. Domains, protocols and ports must match.

    Please advise on how I can get the Facebook Likes functioning on all platforms. I’d really like to avoid stripping out the FB functionality here and having to add in use of a social plugin. Thanks (the site is http://www.zshiftgroup.com)!

    #89154

    Hi!

    I marked this request for Kriesi because imho he needs to update the facebook api methode and this needs to be done for all newer themes.

    Best regards,

    Peter

    #89155

    Thanks, I’ll stay tuned…

    #89156

    I’m going to Soft close the topic for now which will allow Kriesi or one of the support staff to update as soon as we have an update but keep it clear from the normal Queue.

    Hopefully we’ll have an update for you very soon.

    Regards,

    Devin

    #89157

    Hi,

    Just wondering if Kriesi has been able to evaluate when this fix might make it into his schedule?

    #89158

    Hey kerrycrocker,

    Not that I know of no. This is a bit more in depth fix but the way he usually works is to do his entire list of updates at once (usually at the end of the month) and then release theme updates.

    Regards,

    Devin

    #89159

    Hey! I have made some improvements to the script but actually I couldnt reproduce the issue you ware encountering on firefox. maybe it was fixed by facebook or mozilla. If you want to feel free to test the newest version and let us know your findings ;)

    Cheers

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Problems with Facebook Likes link on Firefox and Chrome and iOS’ is closed to new replies.