Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #6539

    I have a problem with the flexible grid gallery of Flashlight . Sometimes I get the Grid View Gallery is as it should and other times the message “No more images available”.

    See the screenshots:

    http://www.urbannature.nl/_div_/Flashlight_1.jpg

    http://www.urbannature.nl/_div_/Flashlight_2.jpg

    What might be the problem? The settings?

    #54558

    Hey,

    I wasn’t able to reproduce your problem, could you link to a page where this problem is occurring?

    #54559

    Here is the link:

    http://www.urbannature.nl/?portfolio=trouwen

    It seems to be a problem in Internet Explorer 9 (32 and 64 bit). In Firefox, Opera and Safari it works fine.

    This works not in IE9:

    http://www.urbannature.nl/?page_id=407

    This works fine (I think) in IE9:

    http://www.urbannature.nl/?page_id=395

    #54560

    I’m having the same issue, I’ll report it to Kriesi :)

    #54561

    Ok, I’m facing the same problem. I googled a bit and found that it’s an IE problem (what else)

    http://sickdesigner.com/index.php/2011/html-css/masonry-css-getting-awesome-with-css3/

    Could you pls check and do you recommend the scripting mentioned there? And: where to insert the script to?

    Thanks for looking into this.

    #54562

    As I have indicated, the problem is not always in IE9. The live preview on the site of Kriesi works as it should. After deleting cookies and cache the first time it lets see all the images.

    @ Chris Beard

    When can I expect a reaction from Kriesi?

    #54565

    Hey,

    excuse us for the delay, I’ll check again with Kriesi if he received the notification.

    #54566

    Hi!

    I can read only two first messages in this topic (only me or other visitors also can’t??) – maybe, some problems with formating of messages by reason of posting of screenshots. The view of this topic is likes here: http://fotoetude.com/images_for_support/the_view_of_topic.jpg

    Anyway, the problem with the flexible grid gallery seems me as the same with mine: http://www.kriesi.at/support/topic/flexibly-masonry-the-problem-with-view-of-photos . This kind of gallery cannot work properly with 100+ images, and also doesn’t like the well-quality images too (more than 250-300 kb each). And I figured out one more thing – if the background slideshow plays images together with lightbox, the famous error “No more images available” appears after loading a few images… I will be happy, if the support team will repair this moment in some day, because I still cannot use this theme now. They wrote: “That way you can share galleries with hundreds of pictures with a smooth user experience” here: http://www.kriesi.at/themedemo/?theme=flashlight , but I think, there is some mistake with description, because I can’t, and not only me.

    Try to turn off the background slider firstly (on the page with gallery).

    Regards.

    #54567

    Now the topic’s view is ok, I can read all messages!

    As I can see the slide-show http://www.urbannature.nl/?portfolio=trouwen – it works badly. Maybe, the following details will be helpfully for repairing.

    1. When the page with slideshow (http://www.urbannature.nl/?portfolio=trouwen ) opens in the first time, the images don’t play in the screen of browser (IE8, 9 and opera). It needs to push the “play” button two times, but I can see only next (number 2) images from 26 pcs of them (see the screenshot here: http://fotoetude.com/images_for_support/www_urbannature_nl_gallery.jpg ). Of course, I wait until all images upload in browser.

    It means, the slide show doesn’ play all 26 pcs of images automatically, as it should be. The buttons “>” and “<” work OK – it is possible to leaf through all 26 pcs (not so much, right?! Only 26 pcs of photos!).

    2. When I open urbannature’s slideshow again in new window, it works properly. But, if I clean the cookies for page (http://www.urbannature.nl/?portfolio=trouwen ) and reload it after that, the slideshow works badly again (see the item N 1 above).

    What is the case of such behavior? Can somebody explain me? My problem with gallery is the same.

    #54568

    Update for support team: the urbannature’s slideshow http://www.urbannature.nl/?portfolio=trouwen works well in IE (checked the IE8 and IE9). The problem is detecting in the opera (11.60). I’ve checked the working of the his slideshow again.

    #54569

    @ Fotomaster:

    I’m so sorry, I put the portfolio back into a slideshow so that photos can be seen again. The screenshot shows not the flexible grid gallery.

    To demonstrate the problem again, I put back the flexible grid gallery.

    @ Support:

    The problem is still there, see: http://www.urbannature.nl/?portfolio=trouwen

    #54570

    To Urbannature: Yes, I see about of the flexible grid gallery and fullscreen slideshow, just have checked it too and have found the same problem with mine. Now I’m checking updated http://www.urbannature.nl/?portfolio=trouwen . It works well in my browsers. Firstly I found there only 8 pcs of photos in the lightbox, but then I remembered about of strange feature of the algorithm – it requires to scroll down until “no more images” appears. Ok, I have found and viewed all 26 pcs of images – the lightbox works well in your site, but I’m not sure about of the 100+ images (not 26, much more).

    My advices (according to my experience) are following:

    1. Turn off the background slideshow for the flexible grid gallery – in order to be avoid of conflict during the lightbox slideshow is working.

    2. Make the sizes of images smaller and compress them as much as possible.

    The flexible grid gallery will work better with little quantity of pictures after this.

    B.R.

    #54571

    @Fotomaster

    As already mentioned, the first time loading the page, there is no problem when the page is reloaded, the problem is there. After clearing the cache, the problem is solved for once. This issue occurs in Internet Explorer 8 and 9.

    I did what you have described above.

    Now there is no background or slider background and the pictures are 430 px and the resolution is 72 ppi.

    Even so, the problem is not solved.

    #54572

    To Urbannature: yes, you right! The problem with “No more images available” is exist – I have found it in IE9 too. Firstly the browser tries to load images and the “No more images available” appears finally.

    Just inform about..

    Now I’m going to check the same page on my site for testing of Flashlight theme – will inform about of result asap.

    BTW, your lightbox’s slideshow works better now (checked in Opera 11.60) – without of delays. Cannot see it in IE (above is – why).

    #54573

    To Urbannature: sorry for delay, but I tried to upload the example of image’s set to my grid gallery many times. At least I found the way of uploading, and here are two flexible grid galleries for your reference:

    http://www.fotoetude.com/portfolio-item/testing_wedding_small/

    http://www.fotoetude.com/portfolio-item/testing_wedding_big/

    The small gallery works. But sometimes I get the problems with IE (see the alerting below of screenshot http://fotoetude.com/images_for_support/IE_problem.jpg ).

    The big gallery doesn’t work well. The light box stops working the slideshow after playing 60-100 images. The fullscreen slideshow stops playing too. I have tested both of slideshows separately and, of course, after loading all images into browser (scrolling down, down, down, down..). And, unfortunately, the IE doesn’t love this gallery’s script – working of it is rather slowly.

    But, I cannot see your problem, when I open and reopen my galleries.

    Please, inform – how my galleries work in your browsers?

    #54574

    To Fotomaster: First thanks for the effort you take to look into the problem.

    I have seen your galleries IE8:

    Wedding_small:

    Continues working as it should, both the flexible grid gallery as the lightbox.

    Wedding_big:

    The flexble grid gallery work as expected after leaving and return to the page.

    Only the lightbox has disappeared, I just keep a dark screen.

    My Wedding page now works properly in IE 8 but the lightbox is very small (I think 430 for images is to small).

    Without a background image appears an extra schrollbalk.

    Tonight I will look to your pages in IE9.

    #54575

    To Urbannature: Thank you for checking of the working of my testing galleries! Hope, it will helpfully for understanding – where are the problems with galleries. Maybe, the problem is with the server’s side too?

    Actually, in my experience some flash-galleries work well with 100+ images (like on the flickr, for example) for introducing of a big-size’ photo-sets to most of on-line visitors.

    I have checked your gallery once again in IE9. The link of your gallery is http://www.urbannature.nl/?portfolio=trouwen#!prettyPhoto . Please, make the link as permalink: http://www.urbannature.nl/portfolio_item/portfolio_trouwen/ or something likes that in admin panel – maybe, it can help to repair the problem. It is only small idea about.

    The other idea is: please, type some words into the html-section in your admin-panel (into editor’s field of gallery’s page). The text will be appear above of pictures in your gallery. Maybe, it also can help.

    BTW, what are the names of images in your gallery? May be, the names contain some “!”, “?”, “é” or something likes that? Just asking about.

    And yes, you right about of the light box in your gallery – now the size of your photos is too small. Actually, the flickr’s standard is 1024 pxs, but the users can use the size 1270 pxs too in order to provide the best possible quality inside of the slideshow section there (of course, each of users wants to increase the resolution of uploaded images for the slideshow – for example, to 1500, but now 1270 pxs size is maximal limit there for playing photos without of resizing). I suppose, you may use some 1024 pxs size around for your gallery in order to provide the comfortable viewing for visitors.

    #54576

    I’ve seen your examples in IE9. I am having the same problems as in IE8. until the third attempt did the lightbox works fine. You jused only landscape photos.

    In my portfolio I also use portrait and landscape together.

    I’ve adjusted my portfolio again:

    with text

    1270px photos 72 ppi

    The permalink is http://www.urbannature.nl/?portfolio=trouwen

    Still the same problem

    Tomorrow I try only lanscape or portret photos.

    #54577

    Dear Urbannature, thank you for information! Now I’m trying to see – where is the problem with the scripts of galleries of flashlight themes exactly. I’m going to understand – why some of flashlight-sites work absolutely correctly in my browsers and computers, but some of others are not (unfortunately, yours and mine don’t work well, but why???). Please, let me a little time in order to prepare some video for illustration of ideas about.

    I opened your gallery again and found the problem in IE, as usually (unfortunately). Also (it isn’t concern to problem with gallery) I may advice you to use the resolution of portrait orientation images a little bit smaller, because the size 1270 pxs is well for landscape’ images (for flickr player), not for portraits. Usually 800 pxs is enough for portraits in order to fit the images into the screens of most popular deck-top monitors.

    #54578

    As promised I have some different options tried.

    This portfolio http://www.urbannature.nl/?portfolio=trouwen I have:

    - Landscape 1270 px wide

    - Portrait 800 px high

    - No “foreign” characters in the filename.

    - Text in the content.

    - No background image or slider

    I also created a portfolio with only landcape pictures:

    http://www.urbannature.nl/?portfolio=test-only-landscape-kriesi-support

    And a portfolio with only portrait photos (looks a bit strange but it are the same pictures):

    http://www.urbannature.nl/?portfolio=test-only-portrait-kriesi-support

    Only the gallery with only landscape pictures works fine .

    The problem seems the portrait format.

    #54579

    Hi Urbannature!

    Thank you for updating of the information. I have already checked your idea “the problem seems the portrait format”. For this reason I upload the additional galleries with mixed type of images http://www.fotoetude.com/portfolio-item/test_gallery_middle/ and only portrait’s oriented gallery too http://www.fotoetude.com/portfolio-item/test_gallery_small_portraits/. Both of them work in IE correctly (unlikely your portraits grid galleries). It means, your idea maybe not right.

    BTW, it seems to me, I have concluded that my problem with galleries is inside of flashlight gallery’s script (not in my computers and not in the server’s side too). When the quantity of images is less than 100, all galleries works perfectly. The problem starts, if there are more than 100 images in the gallery. I think, the Kriesi uses the “z-index” value 100 in gallery’ pages (or something likes that). I’m going to change this value to 300 and look at what happen after that. The support team never helps me here – it means, I’m obliged to do it myself.

    #54580

    Could the problem as I have be the server / hoster?

    My hoster is http://www.mijndomein.nl/

    #54581

    “Could the problem as I have be the server / hoster?”

    When I thought to send the support-ticket with the same question to my hoster, I decided to prepare the video for the best viewing of problem. Please, show to you hoster’s support-team your http://www.urbannature.nl/?portfolio=test-only-portrait-kriesi-support and http://www.urbannature.nl/?portfolio=test-only-landscape-kriesi-support galleries and my examples too http://www.fotoetude.com/portfolio-item/test_gallery_small_portraits/ . It is interesting to know their opinion. Usually, they answer during 24 hours (not after 1 month like here) even at weekend, and their answers usually are more professional and helpful.

    #54582

    I have asked my hoster. I do not feel that they want to think about the problem.

    They indicate that it is a browser-related problem.I did my best to indicate that it may be a server related problem.

    I think that my search for a solution ends.

    Hopefully Kriesi comes with a solution.

    #54583

    Dear Urbannature, how do work now your galleries?

    I have found some new problems with the script and reinstall the wordpress once again. After the total reinstalling (with deleting of the databases too) the Flashlight theme works much better (everybody can see the working of theme here http://www.fotoetude.com ). So, maybe, the problems were in the server’s side – some conflict between themes (I have tested a few other themes together with the “Flashlight” theme, or from the dummy content, which was installed together with the Flashlight theme in the first time.

    Just informing..

    #54584

    This problem popped up for me as well. I’m using Safari.

    #54585

    Hi winstonsf,

    From what I remember, this is related to a permalinks issue as the page is unable to call the correct page name when trying to dynamically load in the next set of images from the next page.

    Try changing you permalinks to default and see if that works for you. Double check that the portfolio slug you have chosen in the theme options does not share the same name or slug as any other page in your site and finally go through the wordpress troubleshooting tips regarding permalinks if you’d like to have them: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    Regards,

    Devin

Viewing 27 posts - 1 through 27 (of 27 total)

The topic ‘Problems with flexible grid gallery’ is closed to new replies.