Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #21453

    Hello, i am unable to get to any of my product pages. I get this type of error below, I have tried to recreate the .htacess files and disable W3T Total Cache. I thought it might be a permalink issue but i can not tell.

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 64 bytes) in /home/jwt2030/public_html/PetShop/wp-includes/wp-db.php on line 1545

    Here is an image of what my product page looks like.

    portalcybermall.com/page.jpg

    #111854

    Hi jwt2030,

    That error typically means you need to increase the allowed memory for WordPress. WooCommerce on its own takes a good bit and any other plugins/services running just add to it.

    This has a good breakdown on increasing your memory though you may need to contact your host of the first few don’t work as some hosting services don’t allow you to modify this from your end: http://www.dailyblogging.org/wordpress/increase-wordpress-memory-limit/

    Regards,

    Devin

    #111855

    i have the memory set to 256M I have 5Gigs of to play with. I have my memory set high.

    #111856

    Hi,

    Have you tried creating .htaccess?

    Check http://www.dailyblogging.org/wordpress/increase-wordpress-memory-limit/.

    3. Modifying the .htaccess file to Increase the Memory Limit

    Regards,

    Ismael

    #111857

    In all the Woocommerce Settings it says i have 256M, and in the WordPress settings,

    Its trying to allocate 83 bytes, i clearly have more than that. When loading the product page my whole server spikes. and it waits 300 seconds until the script runs out of its time limit. This has to be something else i just cant figure it out :(

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 83 bytes) in /home/jwt2030/public_html/PetShop/wp-includes/wp-db.php on line 1545

    #111858

    If i turn W3T cache on i get blank product pages

    #111859

    Can you please take a look?

    #111860

    It was not until i updated my theme i started getting array errors

    06-Mar-2013 16:59:09 UTC] Array

    (

    [color_set] => Array

    (

    [header_color] => Array

    (

    [bg] => #ffffff

    [bg2] => #ffffff

    [primary] => #2997ab

    [secondary] => #55adbd

    [color] => #333333

    [border] => #e1e1e1

    [heading] => #000000

    [meta] => #808080

    )

    [slideshow_color] => Array

    (

    [bg] => #333333

    [bg2] => #f8f8f8

    [primary] => #2997ab

    [secondary] => #55adbd

    [color] => #ffffff

    [border] => #ebebeb

    [img]=> http://www.portalpetshop.com/wp-content/themes/replete/images/background-images/diagonal-thin-light.png
    [pos] => bottom center
    [repeat] => repeat
    [attach] => scroll
    [background_image] => #333333 url(http://www.portalpetshop.com/wp-content/themes/replete/images/background-images/diagonal-thin-light.png) bottom center repeat scroll
    [heading] => #ffffff
    [meta] => #999999
    )

    [main_color] => Array
    (
    [bg] => #f8f8f8
    [bg2] => #ffffff
    [primary] => #2997ab
    [secondary] => #55adbd
    [color] => #666666

    [border] => #e1e1e1

    [img]=> http://www.portalpetshop.com/wp-content/themes/replete/images/background-images/floral-light.png
    [pos] => center center
    [repeat] => repeat
    [attach] => fixed
    [background_image] => #f8f8f8 url(http://www.portalpetshop.com/wp-content/themes/replete/images/background-images/floral-light.png) center center repeat fixed
    [heading] => #222222
    [meta] => #8D8D8D
    )

    [alternate_color] => Array
    (
    [bg] => #ffffff
    [bg2] => #f8f8f8
    [primary] => #2997ab
    [secondary] => #55adbd
    [color] => #888888

    [border] => #e1e1e1

    [heading] => #444444

    [meta] => #A2A2A2

    )

    [footer_color] => Array

    (

    [bg] => #333333

    [bg2] => #222222

    [primary] => #2997ab

    [secondary] => #55adbd

    [color] => #aaaaaa

    [border] => #555555

    [img]=> http://www.portalpetshop.com/wp-content/themes/replete/images/background-images/diagonal-thin-light.png
    [pos] => top center
    [repeat] => repeat
    [attach] => scroll
    [background_image] => #333333 url(http://www.portalpetshop.com/wp-content/themes/replete/images/background-images/diagonal-thin-light.png) top center repeat scroll
    [heading] => #eeeeee
    [meta] => #919191
    )

    [socket_color] => Array
    (
    [bg] => #111111
    [bg2] => #000000
    [primary] => #ffffff
    [secondary] => #eeeeee
    [color] => #eeeeee

    [border] => #161616

    [heading] => #ffffff

    [meta] => #888888

    )

    )

    [style] => Array

    (

    [body_style] => boxed

    [body_color] => #2997ab

    [body_fontcolor] => #ffffff

    [body_img] => http://www.portalpetshop.com/wp-content/uploads/2012/05/animal-pet-shop-e1359245699508.jpg

    [body_pos] => top center

    [body_repeat] => repeat

    [body_attach] => fixed

    [body_background] => #2997ab url(http://www.portalpetshop.com/wp-content/uploads/2012/05/animal-pet-shop-e1359245699508.jpg) top center repeat fixed

    )

    )

    i keep getting errors on every one of my product pages, Its always one of these errors or the other.

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 72 bytes) in /home/jwt2030/public_html/PetShop/wp-includes/meta.php on line 571

    or

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 72 bytes) in /home/jwt2030/public_html/PetShop/wp-includes/wp-db.php on line 1545

    portalpetshop.com/wp-admin

    Here is what is on those lines that give me a fatal error,

    Line 1545,wp-db.php $new_array[] =

    Line 571,meta.php $cache[$mpid][$mkey] = array();

    #111861

    Try following – open up wp-contentthemesrepleteincludesadminregister-dynamic-styles.php and replace following code:

    error_log(print_r($avia_config['backend_colors'], true));

    with:

    //error_log(print_r($avia_config['backend_colors'], true));

    #111862

    Thank you so much for your help, but i couldn’t get it to work :(

    If i switch themes it works perfect. But i love this theme, its code is very optimized.

    Its alot faster than my old theme. The site im using your theme on is my largest site. Over 40K products, and a 400MB database

    Right now im in development, but this is my most important site, and will be launching it very soon.

    Yesterday i had my provider check all my memory and permission settings. I have 5G of ram, 1G for any script to consume.

    I have tried everything i can to get it to work, Please help, your theme rocks!

    #111863

    It works if i change themes. I have tried to delete the whole theme and replace all the files but still cant get it to work. I have tried to disable my plugins. I’m out of ideas?

    #111864

    Hey jwt2030,

    Can you try opening your plugins folder via FTP and delete the W3TC folder so that the plugin is completely uninstalled. There were some issues with the plugin recently and I know some users were having issues until it was completely deleted (even with it non-active in wordpress).

    Regards,

    Devin

    #111865

    Yes, i tried this a few days ago but still a no go. :( At first i was getting a W3TC error on the product pages. But then i deleted it and all its contents and started getting 2 other errors.

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 72 bytes) in /home/jwt2030/public_html/PetShop/wp-includes/meta.php on line 571

    or

    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 72 bytes) in /home/jwt2030/public_html/PetShop/wp-includes/wp-db.php on line 1545

    portalpetshop.com/wp-admin

    Here is what is on those lines that give me a fatal error,

    Line 1545,wp-db.php $new_array[] =

    Line 571,meta.php $cache[$mpid][$mkey] = array();

    #111866

    Its working again. I upgraded the php to the newest version, but i was getting internal server errors on the product page.

    Then i added some code to apache and now its working again. :)

    <IfModule fcgid_module>

    AddHandler fcgid-script .fcgi .php

    FcgidMaxRequestLen 100000000

    FcgidIOTimeout 600

    FcgidIdleTimeout 300

    FcgidIdleScanInterval 30

    FcgidBusyTimeout 3600

    FcgidConnectTimeout 120

    FcgidBusyScanInterval 120

    FcgidFixPathinfo 1

    #FcgidProcessLifeTime 0

    FcgidSpawnScoreUpLimit 10

    FcgidTerminationScore 20

    FcgidSpawnScore 1

    FcgidMaxProcesses 150

    #FcgidOutputBufferSize 131072

    #FcgidOutputBufferSize 0

    FcgidProcessLifeTime 3600

    FcgidMaxRequestsPerProcess 500

    FcgidMinProcessesPerClass 0

    FcgidMaxProcessesPerClass 6

    </IfModule>

    #111867

    Hey!

    Glad that it works now :)

    Regards,

    Peter

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Product Pages not working’ is closed to new replies.