Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #25376

    Hello, I’ve uploaded a youtube video for you understand the problems with the forms, can you take a look?

    Link: http://youtu.be/jscPA7LY2sM

    I sent to the quform’s author and he replied: “It is a theme issue. The theme is passing all HTML within the layout builder through the wpautop function which is adding <p> and
    tags all over the form which is causing the problem. You will need to contact the theme author to ask them how to display raw HTML while avoiding the wpautop function inside the layout builder.”

    #126716

    Hey!

    See http://www.kriesi.at/support/topic/quform#post-120391

    I’ll mark this thread for Kriesi – maybe he can improve the shortcode parsing.

    Best regards,

    Peter

    #126717

    Hi,

    Didn’t I fix this for you? There is one javascript block in a php file that needs to have empty lines taken out. Every other javascript block has them taken out in his code, except this one:

    In file wp-content/plugins/iphorm-form-builder/admin/admin.php between lines 1177-1235 there is javascript between <script> </script> tags. Please replace it all with the code below; i took out the empty lines.

    <script type="text/javascript">
    //<![CDATA[
    jQuery(document).ready(function ($) {
    function iphorm_generate_shortcode() {
    var formId = $('#iphorm-insert-form').val(),
    formName = $('#iphorm-insert-form > option:selected').text(),
    shortcode = '';
    if (formId) {
    if ($('#iphorm-insert-popup').is(':checked')) {
    shortcode = '[iphorm_popup id="' + formId + '" name="' + formName + '"]';
    $.ajax({
    url: '<?php echo admin_url('admin-ajax.php'); ?>',
    type: 'POST',
    dataType: 'json',
    data: {
    action: 'iphorm_set_fancybox_requested'
    }
    });
    shortcode += '<?php echo esc_js(__('Change this to the text or HTML that will trigger the popup ', 'iphorm ')); ?>[/iphorm_popup]';
    } else {
    shortcode = '[iphorm id="' + formId + '" name="' + formName + '"]';
    }
    }
    return shortcode;
    }
    function iphorm_update_shortcode_preview() {
    var shortcode = iphorm_generate_shortcode(),
    $previewArea = $('#iphorm-shortcode-preview > div');
    if (shortcode) {
    $previewArea.text(shortcode).parent().show();
    } else {
    $previewArea.text('').parent().hide();
    }
    }
    $('#iphorm-insert-form').change(iphorm_update_shortcode_preview);
    $('#iphorm-insert-popup').click(iphorm_update_shortcode_preview);
    $('#iphorm-insert-go').click(function () {
    var shortcode = iphorm_generate_shortcode();
    if (shortcode) {
    window.send_to_editor(shortcode);
    } else {
    alert('<?php echo esc_js(__('Please select a form first ', 'iphorm ')); ?>');
    }
    return false;
    });
    });
    //]]>
    </script>

    Thanks,

    Nick

    #126718

    Thanks for reply Nick and Dude, only worked the Dude’s post, look at my tabs:

    http://prntscr.com/1c838n

    On the first tab, everything OK…

    http://prntscr.com/1c83c6

    Thanks guys!!!

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Quform Inside the Tabs’ is closed to new replies.