Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #260154

    Hi,

    Probably a common question but I can’t get the blog with read more button. The full text is displayed right now. In the settings of wordpress I’ve selected the summery option. In the theme options I’ve selected the “Multi Author blog (displays the Avatar….)”

    I think I have to select “Use the advanced layout editor to build…..” But then I need to build the blog layout.

    Can someone tell me what items I need to add to the page with the advanced layout editor to show the blog like the “Multi Author blog (displays the Avatar….)” but then with read more

    Thanks a lot, love the theme, preview on http://gok.wpengine.com

    #260188

    Ok, done. I found it.

    http://gok.wpengine.com/nieuws/

    But I don’t see any read more text under the summery of the blog.

    Thanks

    #260233

    Hi!

    Please add following code to Functions.php file in Appearance > Editor

    function custom_excerpt_more( $more ) {
    	return 'Read more →';
    }
    add_filter( 'excerpt_more', 'custom_excerpt_more' );

    Best regards,
    Yigit

    #266281

    Still not satisfied :D

    I have some problems on the blog at the moment.

    http://gok.wpengine.com/nieuws/

    First problem: I’ve set the blog (settngs enfold) to “use the advanced layout……..” On the blog page i’ve added the “blog posts” element. I need to add all the categories to display all the posts. If I create a new categorie I will have to add this again to this page. Can’t I display everything?

    Second problem: There is one post that keeps displaying the featured image wrong ( to big). I’ve set the blog element to choose the preview image size manually, set to “entry with sidebar (710×270) The size of the featured image is 875×1241. Still it goes wrong.

    http://gok.wpengine.com/lustrum-grip-op-koolhydraten-gok-2009-2014/

    third problem: If I go to the second page of the blog I still get the posts from the first page. On the third page its the same again.

    http://gok.wpengine.com/nieuws/page/2/

    I’ve imported most of the posts from the old website (export/import function wordpress)
    Hope you can help me out.

    Rogier

    • This reply was modified 4 months ago by  rogierkoning. Reason: forgot url
    #266578

    Hi!

    Thank you for using the theme!

    First of all, you don’t have the latest version of Enfold. This might fix the pagination issue with the blog. If not, please try to reset the permalink settings. Go to Settings > Permalink then click the “Save” button once. Download the latest version 2.7.1 from your themeforest account then update the theme via FTP. Please refer to this link for more info: http://www.kriesi.at/documentation/enfold/updating-your-theme-files/

    If you want to show all categories on the blog posts element, don’t select any categories. Just leave it unselected. It will show all posts from different categories.

    Best regards,
    Ismael

    #266700

    Dear Ismael,

    Still no luck. I’ve updated the files to version 2.7.1 and I’ve clicked the save button of the settings/permalinks. Still I don’t get the second page of the blog posts and some images still display to big.

    On the front page I’ve placed a productgrid. when I want to see the next products, the page reloads completely. So I have to scroll back to the bottom again to see the next products. Any idea if we can avoid this. The post slider works nice. If i want to see more it just scrolls in front of me. Can the products be like that aswell?

    Rogier

    #267117

    Hi!

    Thank you for the update.

    Please post the login details here and set it as a private reply. We would like to check the blog page. If possible, please deactivate all plugins then delete the .htaccess file. Regarding the product grid, unfortunately, the element does not utilize any ajax script so you might need to use the product slider for that matter.

    Cheers!
    Ismael

    #274526
    This reply has been marked as private.
    #274913

    Hey!

    Thank you for the access.

    The pagination doesn’t seem to work when you use the advance layout builder, might be because you’re using 2.7.1. I reset the Blog Style to Multi author and the pagination works again. Please update the theme to 2.8.1. Check the page 2 of the blog here: http://gok.wpengine.com/nieuws/page/2/

    Cheers!
    Ismael

    #276909

    Hi Ismael,

    I’ve updated the theme by overwriting the old files. But now the links of the posts isn’t working anymore.
    You can see that some html code is printed under the post title and that the link doesn’t have the correct url to the post

    I also wanted to have the blog on summery, I want to have only a bit af the text visible with a read more link with it.

    http://gok.wpengine.com/nieuws/

    Hope you will help soon.

    Rogier

    #276952

    Ok,

    I found something. No solution but a bug

    The html code I see on the plog overview is only there when I change the propertie of a blog message to link. If I take away the propertie (notation) link and use standard, there is no problem. But like that I still see the whole message and not only a summery.

    Hope this helps a bit solving this problem

    Rogier

    #278532

    Ismael,

    Its been more than a week now. Is there somebody to respond to my questions?

    Rogier

    #279285

    Hey!

    The category/archive pages use the read more quicktag ( http://en.support.wordpress.com/splitting-content/more-tag/ ) to separate the excerpt from the content. You can also use the “excerpt” option field on the post editor page to insert a custom excerpt text but you need to add this code to your child theme functions.php file or enfold/functions.php:

    
    add_filter( 'post-format-standard', 'avia_category_content_filter', 15, 1);
    function avia_category_content_filter($current_post)
    {
    if(!is_single())
    {
    	$current_post['content'] =  get_the_excerpt();
    	$current_post['content'] .= '<div class="read-more-link"><a href="'.get_permalink().'" class="more-link">'.__('Read more','avia_framework').'<span class="more-link-arrow">  &rarr;</span></a></div>';
    }
    return $current_post;
    }
    

    to query the excerpt from the “excerpt” field.

    The html code I see on the plog overview is only there when I change the propertie of a blog message to link. If I take away the propertie (notation) link and use standard, there is no problem. But like that I still see the whole message and not only a summery.

    I guess you tested it with: http://gok.wpengine.com/galerij-van-succesverhalen/ ? The reason is that you wrapped your link into a “quote” tag. If you want to use the “link” post format please add the url of the link without any additional html tags to the top of the post content like:

    
    
    http://opgewicht.forum2go.nl/galerij-met-inspirerende-grip-op-koolhydraten-succesverhalen-f57.html
    
    <blockquote>Voor inspiratie en motivatie zie de <a title="Galerij van succesverhalen" href="http://opgewicht.forum2go.nl/galerij-met-inspirerende-grip-op-koolhydraten-succesverhalen-f57.html" target="_blank"> <strong>Galerij van succesverhalen</strong></a> op het forum (voor iedereen leesbaar).
    
    Bijvoorbeeld: <strong><a title="Drie generaties aan de GOK" href="http://opgewicht.forum2go.nl/3-generaties-aan-de-gok-t11919.html" target="_blank">Drie generaties aan de GOK</a></strong>
    
    &nbsp;</blockquote>
    

    Enfold will then strip the url http://opgewicht.forum2go.nl/galerij-met-inspirerende-grip-op-koolhydraten-succesverhalen-f57.html from the post content and use it as featured url/link.

    Cheers!
    Peter

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.