Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #23986

    Hi,

    When I see the source of the online enfold example and my local one I see a big difference.

    The online example has only 2 stylesheets http requests, nicely minified.

    When I watch my downloaded version I have like tons of requests in my header, mainly all avia css. I’d like it to be nicely compact like the online enfold example.

    A huge difference.

    How can I achieve it like in the online example? I have installed the latest 1.5

    like this:

    <link rel='stylesheet' type='text/css' media='all' href='http://www.kriesi.at/themes/enfold/wp-content/plugins/bwp-minify/min/?f=themes/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/css/avia-media.css,themes/wp-content/themes/enfold/config-woocommerce/woocommerce-mod.css,themes/wp-content/themes/enfold/config-bbpress/bbpress-mod.css,themes/wp-content/themes/enfold/config-layerslider/LayerSlider/css/layerslider.css' />
    <link rel='stylesheet' type='text/css' media='screen' href='http://www.kriesi.at/themes/enfold/wp-content/plugins/bwp-minify/min/?f=themes/wp-content/themes/enfold/css/grid.css,themes/wp-content/themes/enfold/css/base.css,themes/wp-content/themes/enfold/css/layout.css,themes/wp-content/themes/enfold/css/shortcodes.css,themes/wp-content/themes/enfold/js/prettyPhoto/css/prettyPhoto.css,themes/wp-content/themes/enfold/js/mediaelement/skin-1/mediaelementplayer.css,themes/wp-content/themes/enfold/css/custom.css' />
    <script type='text/javascript' src='http://www.kriesi.at/themes/enfold/wp-content/plugins/bwp-minify/min/?f=themes/wp-includes/js/jquery/jquery.js,themes/wp-content/themes/enfold/js/avia-compat.js,themes/wp-includes/js/comment-reply.min.js,themes/wp-content/themes/enfold/config-layerslider/LayerSlider/js/layerslider.kreaturamedia.jquery.js,themes/wp-content/themes/enfold/config-layerslider/LayerSlider/js/jquery-easing-1.3.js,themes/wp-content/themes/enfold/config-layerslider/LayerSlider/js/jquerytransit.js,themes/wp-content/themes/enfold/config-layerslider/LayerSlider/js/layerslider.transitions.js'></script>

    Thank you!

    #121884

    Hi!

    Kriesi uses http://wordpress.org/plugins/bwp-minify/ to compress the files.

    Best regards,

    Peter

    #121885

    Thanks Peter, works well. One problem with it though. It seems to break the google font. When I activate it everything renders well, except the font chosen in the style editor. How does he handle this?

    #121886

    Hey!

    I’m not sure – I’ll tag this thread for Kriesi.

    Best regards,

    Peter

    #121887

    ok, looking forward to a solution ;)

    #121888

    Hey!

    Actually I dont do anything in addition. the plugin works fine for me and so do the google fonts :/

    Not sure what is causing your issue for you. mind sending us a link to your site?

    #121889

    I’m working locally.

    Have you tried eg setting droid serif en than activating the minify plugin?

    I see both the google font requests are in my source (droid serif and open sans), not sure where it goes wrong.

    In which file is the font type written, Kriesi? Since this happens dynamically.

    So I can check in the minified css if the font type is declared ok, or maybe is in wrong order and gets overwritten.

    When I set the body font type as eg droid serif in the base.css and make it important it does render.

    …?

    #121890

    Hi!

    Maybe you forgot to hit the “flush the cache” button after you saved the new font settings?

    Regards,

    Peter

    #121891

    I’m using Open Sans, I see for some reason the space between “Open” and “Sans” is deleted so what should be:

    font-family: Open Sans,'Helvetica Neue','Helvetica Neue',Helvetica,Arial,sans-serif;

    }

    using bwp-minify gets:

    font-family: OpenSans,'HelveticaNeue','Helvetica Neue',Helvetica,Arial,sans-serif;

    }

    Any suggestion?

    Thanks,

    Francesco.

    #121892

    Try following – in wp-contentthemesenfoldframeworkphpclass-style-generator.php replace

    $this->output .= $rule['elements']."{nfont-family:".$rule_split[0].", 'HelveticaNeue', 'Helvetica Neue', Helvetica, Arial, sans-serif;".$font_weight."n}nn";

    with

    $this->output .= $rule['elements']."{nfont-family:'".$rule_split[0]."', 'HelveticaNeue', 'Helvetica Neue', Helvetica, Arial, sans-serif;".$font_weight."n}nn";

    #121893

    Thanks, Dude!

    Works like a charm now.

    #121894

    No way for me… :( still “OpenSans”…

    #121895

    Hi!

    Try to clear the browser cache & flush the minify plugin cache.

    Regards,

    Peter

    #121896

    Francesco, you need to recompile your style preferences, so the style generator does it work.

    #121897

    Thanks Spiv! Anything ok now!!

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘reducing http requests’ is closed to new replies.