Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #10986

    If there are no images added to the slideshow, the featured image function does not work for the related posts. That is, the related posts for all of my podcasts only display the gray default image.

    I add the image to the gallery, select “make feature image,” save, and then the image doesn’t show.

    However, if I have a slideshow enabled, the related images show up perfectly.

    Any ideas?

    #70130

    Hi mjcassel,

    The framework actually replaces the featured image option of wordpress so assigning the image that would wouldn’t have any effect. The image only comes from the Slideshow option for that post.

    I hope that clears it up :)

    Regards,

    Devin

    #70131

    Okay. So is it possible to add an image to the slideshow, but then suppress the display of the slideshow?

    For my podcasts, I don’t need a big image to appear, but I would like the logo of the show to appear in the related posts sections (rather than the gray default image). It would be great if the interface for the page had a “display” or “don’t display” slideshow checkbox.

    Is there code I could add to my podcast posts to not display the slideshow?

    Thanks for your help! I really love the theme.

    #70132

    Hi!

    You can hide the slideshow with following code:

    .category-podcasts .slideshow_container{
    display: none;
    }

    Regards,

    Peter

    #70133

    Thank you for the code. Where should I put this code?

    #70134

    Hey!

    I’d add it to css/custom.css

    Regards,

    Peter

    #70135

    Alright, so that worked for suppressing the slideshow when you click the “podcast” category. However, if I click on the individual post for a podcast, the slideshow still appears. If there a relatively easy way to disable the slideshow for specific posts?

    #70136

    Yes – you need to add the post id class to the css code – eg following code will hide the slideshow for the posts: 20,32,40:

    .postid-20 .slideshow_container, .postid-32 .slideshow_container, .postid-40 .slideshow_container{
    display: none;
    }

    #70137

    Thanks for your help. Your last advice is working perfectly for the actual posts. However, the slideshows still appear when people come to the main page of the site: http://www.indignantleft.com The main page shows the last four or five posts. Some of these should have a slideshow while others should not. Is there a way to have some posts on the main page show the slideshow and others to not display the slideshow? Some sort of if/then type of statement. If .postid=X on mainpage, then no slideshow. I hope this makes sense.

    (Remember, the idea here is that I want an image to appear in the “related posts” section without having a slideshow)

    #70138

    Hi mjcassel,

    Not with an automated way no, but you can add a specific css rule for each podcast post that you don’t want to have a slideshow. Replace the number with the one(s) you wish to hide the slideshow for.

    .post-entry-578 .slideshow_container {
    display: none;
    }

    Regards,

    Devin

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Related Posts not displaying featured image for Podcast’ is closed to new replies.