Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2904

    hi

    the related post thumbails doesn’t work, i have image with “?”

    thanks to resolve this other problem

    #39728

    nobody to help? :(

    #39729

    Did you set featured images for your posts/pages? Please have a look at the documentation (lit. B10) “B 10) Adding Content (how to create gallery entry and preview images)”

    The documentation is part of your themeforest package (zip file). It includes the theme files, the documentation and psd files (photoshop files). Please open index.html (located in the documentation folder) and search for “B 10) Adding Content” – a tutorial with screenshots will tell you how to add featured images to posts and pages. I can’t describe this in a better way so I refer you to the documentation :)

    #39730

    thanks but i don’t use this featured image, i insert my image by other way… so i can’t use related post include in the theme?

    i can install related post thumbails plugin maybe. but how i can desactive the retaled post in the theme?

    thanks

    #39731

    Hi, I have a similar problem with ‘related posts’, but not sure if it can be fixed. Most of my blog posts don’t have ‘feature images’, I put the images within the posts, so the related posts thumbnails are showing as question marks.

    Is there a way for the related posts feature to grab the images from within my blog posts instead of looking for the ‘feature image’?

    Thanks.

    (fpur sorry to hijack your post!)

    #39732

    ;) i would like a answer too. because all my blog posts don’t have feature images so there is never thumbails related posts.

    #39733

    Yeah, I am having the same problem. Evidently because of a circular reference the featured pictures don’t work on a number of the larger hosting companies including Media Temple. As result, I also have the ?. Any way to remove this, so that we can go with a third party ‘related post’ widget?

    #39734

    Hey,

    to remove the related post section just replace following code in single.php:

    <?php // related posts
    $this_id = $post->ID;
    $tags = wp_get_post_tags($post->ID);
    if ($tags) {

    $tag_ids = "";
    foreach ($tags as $tag ) $tag_ids .= $tag->name.",";
    $tag_ids = substr_replace($tag_ids ,"",-1);

    if($tag_ids)
    {
    $my_query = new WP_Query("tag=$tag_ids&showposts=7&caller_get_posts=1&orderby=rand");

    if ($my_query->have_posts())
    {
    $count = 0;

    $output = "<div class='related_posts entry'>";
    $output .= "<strong class='heading'>Related Posts</strong><ul>";

    while ($my_query->have_posts()) : $my_query->the_post();
    if($post->ID != $this_id && $count < 6)
    {
    $small_prev = kriesi_featured_images($post->ID, array( 'size'=> 'S',
    'link' => 'none',
    'style' => 'single',
    'overwrite' => false)
    );
    $output .= "<li class='relThumb ie6fix relThumb".($count+1)."'>n";
    $output .= "<a href='".get_permalink()."' class='relThumWrap noLightbox'>n";
    $output .= "<span class='relThumbTitle'>n";
    $output .= "<strong class='relThumbHeading rounded ie6fix'>".get_the_title()."</strong>n";
    $output .= "</span>n";
    $output .= "<span class='blank_image'>?</span>";
    $output .= $small_prev."";
    $output .= "</a>";
    $output .= "</li><!-- end .relThumb -->n";

    $count++;
    }
    endwhile;

    $output .= " </ul></div>";
    if($count != 0) echo $output;

    }
    wp_reset_query();
    }
    }

    with:

    <?php

    #39735

    okay thanks :) but there is no solution to have thumbails without featured image posts? thanks

    #39736

    No not really – I mean you can write your own function or you can use plugins with a custom code to display post images as featured images but it’s of course a bit of work and takes time…

    #39737

    Thanks Dude.

    #39738

    Glad that I could help you :)

    #39739

    I wouldn’t mind using the same image for each related post. Would you consider changing this feature so an image of our choice would display in lieu of the image that displays a question mark ?

    #39740

    I’ll report this feature request to Kriesi. I think the question mark is a sign (text) not an image at the moment….

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘related posts’ is closed to new replies.