Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29439

    My client would like to remove the iconlist animations in the Enfold theme. I have tried simply;

    Code:
    .avia_transform .avia-icon-list .avia_start_animation .iconlist_icon{
    -webkit-animation: none;
    -moz-animation: none;
    -o-animation: none;
    animation: none;
    }

    but that doesn’t seem to work.

    Can you give me some clues?

    Thanks!

    #140658

    How about if you try to use:

    -webkit-transition: none;

    -moz-transition: none;

    -o-transition: none;

    transition: none;

    #140659

    Hi,

    In your WordPress directory please go to Enfold > Js and open Shortcodes.js and search for “Iconlist shortcode javascript” ( should be in line 605 ) and comment out or delete all the code untill “Section Link Main Menu controler for one page sites”.

    Then add following code to Quick CSS in Enfold theme options under Styling

    .avia_transform .avia-icon-list .iconlist_icon { opacity: 1!important; -webkit-transform: scale(1)!important; transform: scale(1)!important;
    -ms-transform: scale(1)!important; }

    I’m not sure if this is the best way to do it but does the trick.

    Regards,

    Yigit

    #161608

    Thanks for the replies. Yigit, that did the job; I assume that upgrading enfold will overwrite the change – I’m using a child theme – is there a cleaner way I can do this with the child theme over-ride?

    #162003

    Hi,

    I tested this CSS code (without touching the JavaScript files), and it does the job:

    .avia_transform .avia-icon-list .iconlist_icon { 
    	opacity: 1 !important; 
    	-moz-transform:scale(1) !important;
    	-webkit-transform:scale(1) !important;
    	-o-transform:scale(1) !important;
    	transform: scale(1) !important;
    }
    
    .avia_start_animation .iconlist_icon{ 
    	-webkit-animation: none !important;
    	-moz-animation: none !important;
    	-o-animation: none !important;  
    	animation: none !important;    
    }

    You would only need to add it to the CSS in your child theme.

    Regards,
    Josue

    #162172

    Perfect – thanks!

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Remove iconlist animation effects’ is closed to new replies.